Вход | Регистрация


1С:Предприятие ::

Метки: 

1с 7.7 -выборка из справочника

Я
   leoshko84
 
30.10.17 - 09:36
СпрФТ = СоздатьОбъект("Справочник.ФильтрыТовары");
    а=СпрФТ.НайтиПоРеквизиту("Номенклатура", Источник.Наименование, 1);
Если а=1 Тогда
    Сообщить("бббб");
    СпрФТ.ВыбратьЭлементы(); 
    Пока СпрФТ.ПолучитьЭлемент() = 1 Цикл 
        Сообщить(СпрФТ.Номенклатура);
        Сообщить(СпрФТ.НоменклатураГруппа);
        Сообщить(СпрФТ.Фильтр);
    КонецЦикла;
иначе
    Сообщить("ввввв");
    
КонецЕсли;

Не происходит выбока. Пробовал и в строку Источник.Наименование-не помогает. В чем может быть дело?
 
 
   Amra
 
1 - 30.10.17 - 09:37
В типах
   МимохожийОднако
 
2 - 30.10.17 - 09:37
Объясни
а=СпрФТ.НайтиПоРеквизиту("Номенклатура", Источник.Наименование, 1);
   Ёпрст
 
3 - 30.10.17 - 09:38
(0)
[:]||||||||||[:]

пересоздавай объект после НайтиПоРеквизиту
   НЕА123
 
4 - 30.10.17 - 09:40
   leoshko84
 
5 - 30.10.17 - 09:51
Сделал так: а=СпрФТ.НайтиПоРеквизиту("Номенклатура", "искомое значение");

 Выдает: Недостаточное число параметров передано при вызове функции/процедуры объекта, хотя в сылке написано, <Родитель>, <Владелец> -необязательные реквизиты. А в справке написано: НайтиПоРеквизиту(<ИмяРеквизита>,<Значение>,<ФлагГлобальногоПоиска>).  Чего-то не вдупляю....
   МимохожийОднако
 
6 - 30.10.17 - 09:52
(5) <ФлагГлобальногоПоиска>
   leoshko84
 
7 - 30.10.17 - 09:54
отбросил флаг-ругается  "Недостаточное число параметров передано"
   Масянька
 
8 - 30.10.17 - 09:55
СпрФТ = СоздатьОбъект("Справочник.ФильтрыТовары");
    а=СпрФТ.НайтиПоРеквизиту("Номенклатура", Источник.Наименование, 1);

НайтиПоРеквизиту - фиг его знает - не использую.

СпрФТ = СоздатьОбъект("Справочник.ФильтрыТовары");
СпрФТ.НайтиПоРеквизиту("Номенклатура", Источник.Наименование, 1);
СпрФТ = СоздатьОбъект("Справочник.ФильтрыТовары");
а=СпрФТ.текущийЭлемент();
   Масянька
 
9 - 30.10.17 - 09:57
И это - присоединяюсь к (1).
Номенклатура - сто пудово справочник.
   leoshko84
 
10 - 30.10.17 - 10:00
СпрФТ = СоздатьОбъект("Справочник.ФильтрыТовары");
   
    Спр = СоздатьОбъект("Справочник.Номенклатура");
    б=Спр.НайтиПоНаименованию('Пенал-тубус " KWELT " 1 отд 180*40*25 Мишки');
    а=СпрФТ.НайтиПоРеквизиту("Номенклатура", б, 1);
Если а=1 Тогда
    Сообщить("бббб");
    СпрФТ.ВыбратьЭлементы(); 
    Пока СпрФТ.ПолучитьЭлемент() = 1 Цикл 
        Сообщить(СпрФТ.Номенклатура);
        Сообщить(СпрФТ.НоменклатураГруппа);
        Сообщить(СпрФТ.Фильтр);
    КонецЦикла;
иначе
    Сообщить("ввввв");
 
 Рекламное место пустует
   Масянька
 
11 - 30.10.17 - 10:02
(10) Конфигурация?
   leoshko84
 
12 - 30.10.17 - 10:04
7.7 ТИС
   Масянька
 
13 - 30.10.17 - 10:07
(12) В справочнике ФильтрыТовары номенклатура = справочник.Номенклатура?
   leoshko84
 
14 - 30.10.17 - 10:08
верно.
   Масянька
 
15 - 30.10.17 - 10:10
(14)
СпрФТ = СоздатьОбъект("Справочник.ФильтрыТовары");
   
    Спр = СоздатьОбъект("Справочник.Номенклатура");
    Спр.НайтиПоНаименованию('Пенал-тубус " KWELT " 1 отд 180*40*25 Мишки'); 
    б=Спр.ТекущийЭлемент();
    СпрФТ.НайтиПоРеквизиту("Номенклатура", б, 1);
    а=СпрФТ.ТекущийЭлемент();
Если (ПустоеЗначение(а)=0) Тогда
    Сообщить("бббб");
иначе
    Сообщить("Нету");
   leoshko84
 
16 - 30.10.17 - 10:18
Все пошел мыло и веревку готовить... Пенал-тубус " KWELT " 1 отд 180*40*25 Мишки -наименование такое есть. Кавычки верно экранировал -'моя "номенклатура" ' ?
   leoshko84
 
17 - 30.10.17 - 10:18
не находит.
   Z1
 
18 - 30.10.17 - 10:20
(0) Если имеешь ввиду выбрать по реквизиту то надо использовать так


СпрФТ.ВыбратьЭлементыПоРеквизиту("Номенклатура",Источник.Наименование,1,0);
Пока СпрФТ.ПолучитьЭлемент() = 1  Цикл
...
КонецЦикла;
   Масянька
 
19 - 30.10.17 - 10:21
(17) Попробуй не найтипонаименованию, а найтипокоду.
(16) Не уверена, но, по-моему, "".
   leoshko84
 
20 - 30.10.17 - 10:22
блин, да я номенклатуру не могу найти....
   HawkEye
 
21 - 30.10.17 - 10:23
(0) в чем сакраментальный смысл поиска по наименованию?
   leoshko84
 
22 - 30.10.17 - 10:25
Денсинг!!! Все спасибо.
   leoshko84
 
23 - 30.10.17 - 10:26
Хи))) А жизнь, то налаживается. Как в том анекдоте.
   Масянька
 
24 - 30.10.17 - 10:26
(21) А как иначе-то? :))))
   bodri
 
25 - 30.10.17 - 10:27
А у реквизита Номенклатура у этого справочника стоит "Отбор по реквизиту"?
   Масянька
 
26 - 30.10.17 - 10:27
(22) Рекомендую: по наименованию искать в исключительных случаях. Очень исключительных.
   Pit0n_08
 
27 - 30.10.17 - 10:57
(0) +1 Реквизит для поиска, скорее всего, тип "Справочник.Номенклатура", а значение для поиска "Источник.Наименование" - строка. Чего ж должно быть найдено?



Список тем форума
Рекламное место пустует Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует