Вход | Регистрация

1С:Предприятие ::

Метки: 

обработчик события не найден

Я
   Dimarik_1
 
28.10.17 - 14:37
Сделал кнопочку.
Вот такая ошибка возникает
{ОбщийМодуль.птОбщиеПроцедурыИФункцииКлиент.Модуль(162)}: Ошибка при вызове метода контекста (ОтменитьИПровестиДокументыПоГТД)
        птОбщиеПроцедурыИФункции.ОтменитьИПровестиДокументыПоГТД(СтарыйНомерГТД, Номенклатура, Характеристика, Склад, Форма.Объект, Отказ);
по причине:
При подписке ВлияющийНаСтатусПоступленияКиЗДокументПередЗаписью на событие ПередЗаписью произошла ошибка. Обработчик события не найден.

Ошибка возникает при выходе из процедуры.

Процедура ОтменитьИПровестиДокументыПоГТД(СтарыйНомерГТД, Номенклатура, Характеристика, Склад, ФормаОбъект, Отказ) Экспорт

    НачатьТранзакцию();
    Объект = ДанныеформыВЗначение(ФормаОбъект, Тип("ДокументОбъект.ПоступлениеТоваровУслуг"));
    ФормаОбъект = Объект;
    ФормаОбъект.Прочитать();
    Ссылка = ФормаОбъект.Ссылка;
МассивДокументовОтменаПроведения = ОтменитьПроведениеДокументовПоГТД(СтарыйНомерГТД, Номенклатура, Характеристика, Склад, Ссылка, Отказ);
        ФормаОбъект.Записать();
        ПровестиДокументыПоГТД(СтарыйНомерГТД, Номенклатура, Характеристика, Склад, Ссылка, Отказ, МассивДокументовОтменаПроведения);
        ЗафиксироватьТранзакцию();


КонецПроцедуры


я посмотрел на подписку ВлияющийНаСтатусПоступленияКиЗДокументПередЗаписью.
Ссылкается на ИнтеграцияГИСМ.ВлияющийНаСтатусПоступленияКиЗДокументПередЗаписью
Самое интересное что обработчик заполнен и вызывается он после ФормаОбъект.Записать(); но еще более странное что именно когда точка останова стоит на КонецПроцедуры, возникает данная ошибка.
Проверяли на разных компах под разными пользователями. КЭШ исключаю.
11.3.4.93.
MS SQL
 
  Рекламное место пустует
   Dimarik_1
 
1 - 28.10.17 - 14:40
8.3.10.2580 платформа
   Филиал-msk
 
2 - 28.10.17 - 14:43
Классика же.
Клиент. Сервер. Компиляция.
   Dimarik_1
 
3 - 28.10.17 - 19:00
(2) не понял. О чем речь. Можете пояснить?
   Cyberhawk
 
4 - 28.10.17 - 19:05
Подписка на сервере, а модуль на клиенте
   Dimarik_1
 
5 - 28.10.17 - 20:10
   Dimarik_1
 
6 - 28.10.17 - 20:17
и перед вызовом процедуры в серверном модуле нет &НаКлиенте
Вот правда нет ВызовСервера. Но почему он должен вызываться с клиента?
У меня на клиенте есть процедура

Процедура ОбработкаЗаменыГТД(Результат,Форма) Экспорт
    
    Если ЗначениеЗаполнено(Результат) Тогда
        СтарыйНомерГТД = Форма.Элементы.Товары.ТекущиеДанные.НомерГТД;
        Форма.Элементы.Товары.ТекущиеДанные.НомерГТД = Результат;
        //СписокРеализаций = ПолучитьСписокДокументов(Форма.Элементы.Товары.ТекущиеДанные.Номенклатура, Форма.Элементы.Товары.Характеристика, Форма.Элементы.Товары.НомерГТД);

        
        //УстановитьПривилегированныйРежим(Истина);

        
        Отказ = Ложь;
        Номенклатура = Форма.Элементы.Товары.ТекущиеДанные.Номенклатура;
        Характеристика = Форма.Элементы.Товары.ТекущиеДанные.Характеристика;
        Склад = Форма.Объект.Склад;

        птОбщиеПроцедурыИФункции.ОтменитьИПровестиДокументыПоГТД(СтарыйНомерГТД, Номенклатура, Характеристика, Склад, Форма.Объект, Отказ);
        //УстановитьПривилегированныйРежим(Ложь);

                        
        
        
        //птОбщиеПроцедурыИФункции.ПерепровестиДокументыПоГТД(СтарыйНомерГТД, Номенклатура, Характеристика, Склад, Форма.Объект.Ссылка, Отказ);

        Если Отказ = Истина Тогда
            Форма.Элементы.Товары.ТекущиеДанные.НомерГТД = СтарыйНомерГТД;
            Форма.Записать();
        КонецЕсли;
        
    КонецЕсли;
    
    
КонецПроцедуры

Ошибка возникает при выходе из ОтменитьИПровестиДокументыПоГТД
Код этой процедуры я высылал.
Не могу понять, почему именно не так.
Сделал точку останова в ПоступлениеТоваровИУслуг на ПередЗаписью.
Внутри процедуры Процедура ОтменитьИПровестиДокументыПоГТД после 
ФормаОбъект.Записать();
остановился в процедуре ПередЗаписью. Вышел из ОтменитьИПровестиДокументыПоГТД и не останаливался больше. В чем проблема никак не пойму....
   Cyberhawk
 
7 - 29.10.17 - 10:12
Сколько платят за решение вопроса?
   h-sp
 
8 - 29.10.17 - 11:36
(6) что за определяемый тип у вас? точно там ДокументОбъект? Какие типы входят?


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует