Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Не проходит обновление!

Не проходит обновление!
Я
   saniok87
 
27.10.17 - 17:00
Всем добрый день! Пытаюсь обновить Управление торговлей 11.2.3.300 на 11.3.3.190, платформы уже разные пробовал! В конфигураторе проходит, при запуске доходит до 80% и выдаёт ошибку:
https://cloud.mail.ru/public/GXAC/5svdFmjXm

https://cloud.mail.ru/public/EUKu/GGMAZ9eEY

Кто-нибудь знает как победить?
 
 
   Ц_У
 
1 - 27.10.17 - 17:01
Две бессмысленно-бесполезных картинки
   Мыш
 
2 - 27.10.17 - 17:03
(0) Вы программист?
   saniok87
 
4 - 27.10.17 - 17:07
(2) Я не програмист
   isa2net
 
5 - 27.10.17 - 17:09
(4) Файловая?
   saniok87
 
6 - 27.10.17 - 17:09
(5) Да
   elCust
 
7 - 27.10.17 - 17:12
(0) Удалить базу из списка, добавить взад в список.
   isa2net
 
8 - 27.10.17 - 17:12
Чистка кэша (перед этим бэкап), удалить все из папки базы, кроме cd(тоже после бэкапа )?
   saniok87
 
9 - 27.10.17 - 17:15
Это копия базы, взята из бэкапа, чистить нечего.
   LuciferArh
 
10 - 27.10.17 - 17:16
(9) Прогнать базу на предмет ошибок. Сделать ТиИ.
 
 Рекламное место пустует
   saniok87
 
11 - 27.10.17 - 17:17
(10) Делал.
   isa2net
 
12 - 27.10.17 - 17:18
a chdbfl?
   igork1966
 
13 - 27.10.17 - 17:19
(9) исходная? 11.2.3.300
   saniok87
 
14 - 27.10.17 - 17:20
(13) Да
   saniok87
 
15 - 27.10.17 - 17:21
(12) Пробовал
   igork1966
 
16 - 27.10.17 - 17:22
(14) а обновляешь cfu
Возможно предыдущие обновления криво прошли?
   saniok87
 
17 - 27.10.17 - 17:24
(16) Пробовал и cfu и cf
На предыдущих ошибок не было
   igork1966
 
18 - 27.10.17 - 17:30
(17) покажи что в районе этой строчки в коде
   saniok87
 
19 - 27.10.17 - 17:33
(18) Не совсем понял
   saniok87
 
20 - 27.10.17 - 17:36
(18) ?
   ptiz
 
21 - 27.10.17 - 17:36
(19) В конфигураторе открой эту строку
   isa2net
 
22 - 27.10.17 - 17:39
(21) там типа этого
// В случае нахождения вложенной транзакции обработчик обновления повторно не вызывается.

        ИнформацияОбОшибке = ИнформацияОбОшибке();
        ПодробноеПредставлениеОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке);
        
        ОбработчикОбновления.Статус = "Ошибка";
        ОбработчикОбновления.ИнформацияОбОшибке = ОбработчикОбновления.ИнформацияОбОшибке
            + Символы.ПС + ПодробноеПредставлениеОшибки;
        
        ОбработчикОбновления.ЧислоПопыток = 3;
    КонецПопытки;

   saniok87
 
23 - 27.10.17 - 17:44
(21) Я перед тем как сюда писать на всякий случай ещё раз пустил ТиИ, не знал что Вы так быстро откликнетесь!
   saniok87
 
24 - 27.10.17 - 17:45
(21) Я примерно представляю как её открыть, но не уверен что правильно. Как это сделать?
   kossmatiy
 
25 - 27.10.17 - 18:20
(0) Хотя бы полный текст ошибки напишите, а то не понятно что там..
   kossmatiy
 
26 - 27.10.17 - 18:26
(25) Недавно была похожая ошибка. В регистре КатегорииНовостейЧегототам оказались пустые строчки. Может и тут что то похожее..
   Филиал-msk
 
27 - 27.10.17 - 18:33
В ОбработчикОбновления.ИнформацияОбОшибке лежит Неопределено. Как вы с базой докатились до жизни такой, без конфигуратора и отладки не понять. Очевидно, какая-то фича в данных, которая выводит из себя БСПшный код.

Я бы дописал туда преобразование к строке и запустил ещё раз.
   saniok87
 
28 - 05.11.17 - 19:06
Все эти дни некогда было опять побиться с обновлением! Оно сильно долго идёт! Сегодня сделал опять ТиИ и пустил обновление, снова на 80% ошибка, но в этот раз я открыл конфигуратор:
Процедура УстановитьСостояниеПоляТабличногоДокумента(ПолеТабличногоДокумента, Состояние = "НеИспользовать") Экспорт
    
    Если ТипЗнч(ПолеТабличногоДокумента) = Тип("ПолеФормы") 
        И ПолеТабличногоДокумента.Вид = ВидПоляФормы.ПолеТабличногоДокумента Тогда
        ОтображениеСостояния = ПолеТабличногоДокумента.ОтображениеСостояния;
        Если ВРег(Состояние) = "НЕИСПОЛЬЗОВАТЬ" Тогда
            ОтображениеСостояния.Видимость                      = Ложь;
            ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.НеИспользовать;
            ОтображениеСостояния.Картинка                       = Новый Картинка;
            ОтображениеСостояния.Текст                          = "";
        ИначеЕсли ВРег(Состояние) = "НЕАКТУАЛЬНОСТЬ" Тогда
            ОтображениеСостояния.Видимость                      = Истина;
            ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.Неактуальность;
            ОтображениеСостояния.Картинка                       = Новый Картинка;
            ОтображениеСостояния.Текст                          = НСтр("ru = 'Отчет не сформирован. Нажмите ""Сформировать"" для получения отчета.'");;
        ИначеЕсли ВРег(Состояние) = "ФОРМИРОВАНИЕОТЧЕТА" Тогда  
            ОтображениеСостояния.Видимость                      = Истина;
            ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.Неактуальность;
            ОтображениеСостояния.Картинка                       = БиблиотекаКартинок.ДлительнаяОперация48;
            ОтображениеСостояния.Текст                          = НСтр("ru = 'Отчет формируется...'");
        Иначе
            ВызватьИсключение(НСтр("ru = 'Недопустимое значение параметра (параметр номер ''2'')'"));
        КонецЕсли;
    Иначе
        ВызватьИсключение(НСтр("ru = 'Недопустимое значение параметра (параметр номер ''1'')'"));
    КонецЕсли;
    
КонецПроцедуры

Как я уже писал - я не программист 1С, может кому-нибудь что-то скажет этот текст?
https://cloud.mail.ru/public/dhvx/RsJ4QEEHB
   ВыборКогдаТогда
 
29 - 05.11.17 - 20:59
(28) Если Вы не программист обратитесь тогда к программисту. Тут нужно разбирать непосредственно на базе, а не гадать на кофейной гуще.
   Serg_1960
 
30 - 05.11.17 - 21:13
"Как я уже писал - я не программист 1С" - sorry, но у меня для вас есть актуальный совет:

"Пригласите специалиста!"(с)

Причём в этом совете оба слова - важные. Впрочем, я опиши примерный порядок работы:
Открыть конфигуратор; поставить в алгоритме точку останова; запустить сервер на отладку; вызвать сеанс "1С:Предприятие"; при останове, посмотреть трассировку и определить процедуру обновления, на которой происходит ошибка; определить какие именно данные обрабатываются; проверить данные на предмет возникновения ошибки; выявить и устранить.

Как видите, я ничего не скрываю, всё объяснил. Вы способны это всё проделать самостоятельно? Я думаю - нет.
   saniok87
 
31 - 06.11.17 - 09:10
(30) Проблема в том, что ближайшие программисты находятся за 120 км от нас и не хотят ехать, а если всё-же договориться, то это будет стоить очень дорого!
   ildary
 
32 - 06.11.17 - 09:31
(31) телепатия обойдётся ещё дороже. Тогда единственный для вас способ - искать удаленного спеца, чтобы он подключившись к вашему серерву ковырял проблему.
   Филиал-msk
 
33 - 06.11.17 - 09:33
(31) То есть, если ты, неграмотный, сейчас от души нахреначишь в базе по советам незнакомых людей с форума, то это будет лучше и главное - дешевле. Прелестно.
 
 
   МимохожийОднако
 
34 - 06.11.17 - 09:34
(31) Съезди к ним со своей базой. Привези обратно обновлённую ими базу. И дешевле и прогуляешься.
А лечить зубы по телефону затратно и больно.
   saniok87
 
35 - 06.11.17 - 11:51
(34) Как вариант правда взять базу и съездить, надо только для  начала найти к кому ехать и убедить в этом начальника. Как будет результат отпишусь.
   APXi
 
36 - 06.11.17 - 12:26
(35) готов помочь, не бесплатно конечно.
   saniok87
 
37 - 06.11.17 - 18:39
(36) А сколько будет стоить? Я начальника уболтаю!
   Cyberhawk
 
40 - 06.11.17 - 20:59
Сколько платят за решение вопроса?
   Филиал-msk
 
41 - 06.11.17 - 21:01
А вот и девочка!
   Филиал-msk
 
42 - 06.11.17 - 21:01
Хочешь повозиться?
   APXi
 
43 - 09.11.17 - 09:01
(37) Не знаю, нужно сначала базу посмотреть.
   Serg_1960
 
44 - 09.11.17 - 12:59
Посмотри сначала разрешено ли с версии 11.2.3.300 перепрыгнуть на 11.3.3.190
   Затейник
 
45 - 09.11.17 - 15:02
(44) Разрешено
(0) Попробуйте на другой релиз прыгнуть 11.3.3.226
   Затейник
 
46 - 09.11.17 - 15:04
(0) Платформа должна быть не ниже (8.3.8.2137) Какая у вас ?
   _KaA
 
47 - 09.11.17 - 15:09
(0)

Коллега, на вашей второй картинке видно, что падает ЕГАИС. Это библиотека, думаю вы сами изменений туда не вносили, поэтому предположу, что ошибка типовой конфигурации (9 из 10 что это так).

Предлагаю обновлению пропустить, вернуться к архивной копии на момент до обновления, зарегистрировать ошибку к 1с (если такая возможность есть)... Самостоятельно я бы не правил, но решение, конечно, надо принимать только исходя из ваших обстоятельств.
   Затейник
 
48 - 09.11.17 - 15:15
(47) Это майские релизы, 1с ответит просто, переходите на последнюю версию программы (11.4.1.241) для начала и платформы, потом поговорим...


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует