Вход | Регистрация

1С:Предприятие ::

Метки: 

Конвертация данных 2 ПолучитьОбъект?

Я
   spiller26
 
27.10.17 - 14:31
Формирую таблицу документов для проведения после загрузки данных
Таблица заполнена.
При попытке Получения объекта по ссылке выходит ошибка. Не пойму почему, что может быть не так с ссылками.

Ошибка в обработчике события ПослеЗагрузкиДанных (конвертация)
    Обработчик             =  ПослеЗагрузкиДанных (конвертация)
    ОписаниеОшибки         =  Ошибка при вызове метода контекста (ПолучитьОбъект): Элемент не выбран!
    ПозицияМодуля          =  (5)
    КодСообщения           =  23

Вот текст обращения к объекту.

Если Параметры.ТаблицаДокументов.Количество() > 0 Тогда 
    Сообщить(Параметры.ТаблицаДокументов.Количество());
    Параметры.ТаблицаДокументов.Сортировать("ДатаДок Возр");
    Для Каждого СтрокаТч Из Параметры.ТаблицаДокументов Цикл
        ОбъектДок = СтрокаТч.СсылкаДок.ПолучитьОбъект();
        Попытка
            ОбъектДок.Записать(РежимЗаписиДокумента.Проведение);
            Сообщить("Документ проведен: " + СокрЛП(ОбъектДок));
        Исключение
            Сообщить("ДОКУМЕНТ НЕ ПРОВЕДЕН : " + СокрЛП(ОбъектДок));
        КонецПопытки;    
    КонецЦикла;    
Иначе
    Сообщить("Нет таблицы проведенных документов!")
КонецЕсли;
 
 
   Amra
 
1 - 27.10.17 - 14:35
Это ссылки из базы источника. В приемнике ссылки не ссылки
   mehfk
 
2 - 27.10.17 - 14:40
(0) Значит в какой-то строке у тебя как минимум пустая ссылка.
   spiller26
 
3 - 27.10.17 - 14:40
(1) Почему? Вот заполнение самой таблицы.

В конвертации "ПослеЗагрузкиОбъекта"

Если ИмяТипаОбъекта = "Документ" Тогда
    Если Объект.Проведен Тогда
        //Объект.Записать();

        НоваяСтрока = Параметры.ТаблицаДокументов.Добавить();
        НоваяСтрока.СсылкаДок = Объект.Ссылка;
        НоваяСтрока.ДатаДок = Объект.Дата;
    КонецЕсли;    
КонецЕсли;
   бомболюк
 
4 - 27.10.17 - 14:44
ПослеЗагрузки != ПослеЗаписи
сделай 
Если ИмяТипаОбъекта = "Документ" Тогда
    Если Объект.Проведен Тогда
        Объект.Записать();
        ОбъектМодифицирован = Ложь;

        НоваяСтрока = Параметры.ТаблицаДокументов.Добавить();
        НоваяСтрока.СсылкаДок = Объект.Ссылка;
        НоваяСтрока.ДатаДок = Объект.Дата;
    КонецЕсли;    
КонецЕсли;
   Naumov
 
5 - 27.10.17 - 15:00
ТАк проверь тип того, чью ссылку пытаешься получить.
   spiller26
 
6 - 27.10.17 - 15:00
(4) Точняк, пустышки оказались.
Выгружаю с записью.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует