Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Конвертация реквизита в дополнительный реквизит.

v7: Конвертация реквизита в дополнительный реквизит.
Я
   DenYuliya
 
26.10.17 - 18:31
Добрый вечер. Подскажите пожалуйста, кто знает? У меня перенос из ТиС (7.7) в Комплексную Автоматизацию 2. Но в КА справочники "Партнеры и "Контрагенты абсолютно идентичны таким же в УТ 11.
Переносимые реквизиты булево и в источнике (дописанные реквизиты спр. Контрагенты), и в Приемнике (доп.реквизиты в спр. Партнеры).

Скачала типовые правила переноса с ТиС в УТ 11.
Там есть ПКГС для доп реквизитов, "ПКГС_Контрагенты_Партнеры_ДополнительныеРеквизиты_ПередОбработкойВыгрузки_7_20"


Если ТипЗначенияСтр(ВходящиеДанные) <> "СписокЗначений" Тогда
    ВходящиеДанные = СоздатьОбъект("СписокЗначений");
КонецЕсли;

ВходящиеДанные.Установить("ВидСправочника", "СвойстваКонтрагентов");
ВыгрузитьДополнительныеРеквизиты();


ВыгрузитьДополнительныеРеквизиты - это алгоритм выгрузки.

КоллекцияОбъектов = СоздатьОбъект("ТаблицаЗначений");
КоллекцияОбъектов.НоваяКолонка("Значение");
КоллекцияОбъектов.НоваяКолонка("Свойство");

// Не допреквизиты, если они не используются

Если (ПустоеЗначение(Константа.ВидСвойстваКонтрагентов) = 1)
    И (ПустоеЗначение(Константа.ВидСвойстваНоменклатуры) = 1)
    ИЛИ (Источник.ЭтоГруппа() = 1) Тогда
    Возврат 0;
КонецЕсли;

ВидСправочника = ВходящиеДанные.Получить("ВидСправочника");

ТабДополнительныеРеквизиты = ?(ВидСправочника = "СвойстваНоменклатуры", 
                               Параметры.ДополнительныеРеквизитыНоменклатуры, 
                               Параметры.ДополнительныеРеквизитыКонтрагентов);

Если ТабДополнительныеРеквизиты = -1 Тогда
    
    ТабДополнительныеРеквизиты = СоздатьОбъект("ТаблицаЗначений");
    ТабДополнительныеРеквизиты.НоваяКолонка("Номенклатура");
    ТабДополнительныеРеквизиты.НоваяКолонка("КоллекцияОбъектов");

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(СвойстваНоменклатурыКонтрагентов)

    |ВидСвойства = Справочник.#.ВидСвойства;
    |ЗначениеСвойства = Справочник.#.ЗначениеСвойства;
    |Владелец = Справочник.#.Владелец;
    |Функция Счётчик = Счётчик();
    |Группировка Владелец упорядочить по Владелец.Код без групп;
    |Группировка ВидСвойства упорядочить по ВидСвойства.Код без групп;
    |Группировка ЗначениеСвойства без групп;
    |"//}}ЗАПРОС

    ;

    ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "#", ВидСправочника);
    
    Запрос.Выполнить(ТекстЗапроса);
    Пока Запрос.Группировка(1) = 1 Цикл
        
        ТабДополнительныеРеквизиты.НоваяСтрока();
        ТабДополнительныеРеквизиты.Номенклатура = Запрос.Владелец;
        ТабДополнительныеРеквизиты.КоллекцияОбъектов = СоздатьОбъект("ТаблицаЗначений");
        ТабДополнительныеРеквизиты.КоллекцияОбъектов.НоваяКолонка("Значение");
        ТабДополнительныеРеквизиты.КоллекцияОбъектов.НоваяКолонка("Свойство");
        
        Пока Запрос.Группировка(2) = 1 Цикл
            Пока Запрос.Группировка(3) = 1 Цикл
                
                ТабДополнительныеРеквизиты.КоллекцияОбъектов.НоваяСтрока();
                ТабДополнительныеРеквизиты.КоллекцияОбъектов.Значение    = Запрос.ЗначениеСвойства;
                ТабДополнительныеРеквизиты.КоллекцияОбъектов.Свойство    = Запрос.ВидСвойства;
                
                Прервать;
            КонецЦикла;
        КонецЦикла;
    КонецЦикла;
КонецЕсли;

Если ВидСправочника = "СвойстваНоменклатуры" Тогда
    Параметры.ДополнительныеРеквизитыНоменклатуры = ТабДополнительныеРеквизиты;
Иначе
    Параметры.ДополнительныеРеквизитыКонтрагентов = ТабДополнительныеРеквизиты;
КонецЕсли;

НомерСтроки = 0;
Если ТабДополнительныеРеквизиты.НайтиЗначение(Источник, НомерСтроки, "Номенклатура") = 1 Тогда
    КоллекцияОбъектов = ТабДополнительныеРеквизиты.ПолучитьЗначение(НомерСтроки, "КоллекцияОбъектов");
КонецЕсли;

Так же для ПКГС имеются 2 ПКС:
ПСК "Свойство" , с пустым источником и приемником "Свойство" (тип ПланВидовХарактеристикСсылка.ДополнительныеРеквизитыИСведения).
ПКС "Значение". так же с пустым Источником и Приемником "Значение" (тип множественный, ссылки на справочники, строка, булево и т.д)

В ПКС обработчики не заполнены.

В то же время погуглила - народ в инете этот алгоритм нигде не упоминает, говорят, что надо идти таким путем:

1) надо создать в ПКГС ТаблицуЗначений:

ТЗ= Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("Свойство");
ТЗ.Колонки.Добавить("Значение");
СтрокаТЗ = КоллекцияОбъектов.Добавить(); 
 
2) Потом для реквизитов "Свойство" и "Значение"сделать ПКС без источника, но с приемником.
3) для каждого приемника программно указать, какие значения они должны принимать.

В общем я запуталась... Можно несколько вопросов по пунктам? Извиняюсь, что так много, пытаюсь как-то структурировать все в голове...
1. Зачем тогда нужен сложный вариант с использованием Алгоритма в типовых правилах "ТиС - УТ11"?
Мне метод с созданием ТЗ и дальнейшим созданием ПКС для "Свойства" и "Значения" кажется более удобным, но может я что-то не понимаю просто?
2. Почему все на форумах советуют "Источник" оставлять пустым, заполняя только "Приемник"? Разве не лучше в качестве Источника указать реквизит в "Источнике" (Например, есть у меня рекв. "МеткаНедоверия", тип Булево), а в Приемнике осуществлять поиск по наименованию доп. Реквизита (то же "МеткаНедоверия")? И я правильно понимаю, что эта часть - выполняется в ПКС для "Свойства", в обработчике "ПередВыгрузкой"?
3. Теперь как-то заполнять ПКС для "Значения" надо...
Можно ли как-то из серии, правильно?
Значение = Источник.МеткаНедоверия;
4. Это надо прописывать отдельно для каждого доп.реквизита? поиск по наименованию, с указанием наименования, и дальнейшее заполнение значения.


В общем я просто не понимаю, что именно делать и верный ли у меня ход мыслей...Прокомментируйте? если бы хоть мааленький пример где-нибудь посмотреть, было бы вообще волшебно.
 
 
   toypaul
 
1 - 26.10.17 - 19:17
я делал всегда по варианту

"надо создать в ПКГС ТаблицуЗначений: "

так проще. тайный смысл манипуляций в типовых правилах мне непостижим
   SleepyHead
 
2 - 27.10.17 - 04:38
(1) Это претензия на универсальность, скорее всего. В коде анализируется, используеются ли допреквизиты, и если используются, то выгружаются.

По всей видимости, такой код для использования в различных конфигурациях.
   DenYuliya
 
3 - 27.10.17 - 09:16
(1) А ПКС надо создавать отдельно для каждого доп.реквизита?
Отдельно ПКС Свойсво + ПКС Значение для Доп.реквизита1, потом для ДопРеквизита2 и т.д?

В итоге, если у меня 20 доп.реквизитов, получится в 1 ПКГС 20 ПКС. Верно?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует