Вход | Регистрация

1С:Предприятие ::

Метки: 

Сихронизация времени на ККМ Атол

Я
   php5
 
26.10.17 - 15:08
Добрый день!

ККМ Атол 22Ф (~50 шт.) подключены по ip к "Рознице, редакция 2.2". Постоянно имеются расхождения по времени на минуты, хотелось бы реализовать синхронизацию времени перед открытием смены, но в интеграционной компоненте нет метода установки времени.

Если с ККМ работать напрямую, через драйвер АТОЛ, то там есть метод SetTime(), но не могу понять как подключиться к нужной ККМ через IP. Кто-нибудь сталкивался с подобной проблемой и как решали?
 
 
   php5
 
1 - 26.10.17 - 15:45
Путем опытов, получилось так, это черновик:

ECR.АдресХоста = "10.51.7.59:5555";
    ECR.НомерПорта = 99;
    
    // занимаем порт

    ECR.DeviceEnabled = 1;
    Если ECR.ResultCode <> 0 тогда
        Возврат;
    КонецЕсли;
    
    // получаем состояние ККМ

    Если ECR.GetStatus() <> 0 тогда
        Возврат;
    КонецЕсли;
    
    Если ECR.SessionOpened = 0 Тогда
        
        // устанавливаем время

        ECR.Час     = Час(ТекущаяДата());
        ECR.Минута  = Минута(ТекущаяДата());
        ECR.Секунда = Секунда(ТекущаяДата());
        
        ECR.SetTime();
                
    Иначе
        
        Сообщить("Смена открыта, время изменить нельзя!");
        
    КонецЕсли;
    
    // освобождаем порт

    ECR.DeviceEnabled = 0;
    Если ECR.ResultCode <> 0 тогда
        Возврат;
    КонецЕсли;
   Woldemar177
 
2 - 26.10.17 - 16:43
Молодец, нашел, сохраню к себе в бложик.
   mehfk
 
3 - 26.10.17 - 17:24
(2) Прямо так с тремя вподряд идущими ТекущаяДата() ?
   Woldemar177
 
4 - 26.10.17 - 17:52
(3) И даже с таким IP адресом.
   isa2net
 
5 - 26.10.17 - 18:45
В Program Files \ATOL\Drivers8\Samples примеры и там ECR = new ActiveXObject ("AddIn.FPrnM45");
   Сияющий в темноте
 
6 - 26.10.17 - 21:46
В новый год данный код может показать себя во всей красе


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует