Вход | Регистрация

1С:Предприятие ::

Метки: 

Переход 7.7 в УТ11

Я
   leoshko84
 
26.10.17 - 11:19
у спр Номенклатура есть подчиненный "НоменклатураГос" в Приемнике у номенклатуры поле "НаименованиеГос".
Как перенести?
 
  Рекламное место пустует
   ildary
 
1 - 26.10.17 - 11:23
(26) через любой, приятный программисту файл: TXT,DBF, XML... Если хочется необычного - то через OLE.
   leoshko84
 
2 - 26.10.17 - 11:28
Делаю так,  ПКС: источник пусто, приемник "НаименованиеГос"
В процедуре ПередВыгрузкой:
Если Источник.ЭтоГруппа()=0 Тогда
      СпрНГ = СоздатьОбъект("Справочник.НоменклатураГос");
        СпрНГ.ИспользоватьВладельца(Источник.Ссылка); 
      СпрНГ.ВыбратьЭлементы(); 
      Пока СпрНГ.ПолучитьЭлемент() = 1 Цикл 
        Значение=СпрНГ.Наименование; 
      КонецЦикла;
    
Иначе
    Отказ=1;
КонецЕсли;
   leoshko84
 
3 - 26.10.17 - 11:28
Использую Конвертацию данных. Мисье гурман.
   Alexor
 
4 - 26.10.17 - 11:30
(3) Вопрос то какой?
   Барматолог
 
5 - 26.10.17 - 11:30
(2) все верно, только я бы сделал только одну итерацию
     Если СпрНГ.ПолучитьЭлемент() = 1 Тогда 
        Значение=СпрНГ.Наименование; 
      КонецЕсли;
   leoshko84
 
6 - 26.10.17 - 11:32
Ошибка исполнения обработчика:  ПКС_ПередВыгрузкой_Номенклатура_НаименованиеГос_Реквизит32
  - Поле агрегатного объекта не обнаружено (Ссылка)
   leoshko84
 
7 - 26.10.17 - 11:32
Источник у меня пустой. Вот и ругается.
   Alexor
 
8 - 26.10.17 - 11:34
СпрНГ.ИспользоватьВладельца(Источник);

В 77 нет ссылок
   leoshko84
 
9 - 26.10.17 - 11:50
Ошибка получения значения свойства объекта
    Объект: Циркуль " Koh-i-Noor " школьный, свойство: НаименованиеГос.
   leoshko84
 
10 - 26.10.17 - 11:50
что ему надо? а-а-а!!!
 
 
   leoshko84
 
11 - 26.10.17 - 11:55
Тема закрыта. Разобрался. Всем спасибо!
   Барматолог
 
12 - 26.10.17 - 13:24
(11) согласно хорошему тону среди сударей адинэсников, желательно описывать решение.
   leoshko84
 
13 - 26.10.17 - 13:31
Сэры! Не внимателен просто был! Решение верное. О женщинах думаю, отвлекаюсь.....


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует