Вход | Регистрация



вывод в макете

вывод в макете
Я
   mighty_1
 
25.10.17 - 12:43
фаза1 | Строка1
      | Строка2
_______________
фаза2 | Строка1
      | Строка2
      | Строка3

Нужно к области фаза прикреплять справа области строк, строк может быть разное кол-во у каждой фазы
методом присоединить строки выводятся горизонтально.
Пока ВыборкаФазаПроизводства.Следующий() Цикл
            
            ОбластьФазаПроизводства.Параметры.Заполнить(ВыборкаФазаПроизводства);
            ТабДокумент.Вывести(ОбластьФазаПроизводства);
            
                        
            ВыборкаРабота = ВыборкаФазаПроизводства.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
            
            Пока ВыборкаРабота.Следующий() Цикл
                
                ОбластьРабота.Параметры.Заполнить(ВыборкаРабота);
                            
                ВыборкаДетальныеЗаписи = ВыборкаРабота.Выбрать();
                
                Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
                    ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
                    ВыборкаФазаПроизводства.Присоединить(ОбластьДетальныхЗаписей);
                                                        
                КонецЦикла;
                ВыборкаФазаПроизводства.Присоединить(ОбластьРабота);
            КонецЦикла;
            
        КонецЦикла;
Как вывести ?
 
 
   chelentano
 
1 - 25.10.17 - 12:45
ВыборкаФазаПроизводства.Присоединить(ОбластьДетальныхЗаписей);

Это чё такое?
   mighty_1
 
2 - 25.10.17 - 12:47
ОбластьФазаПроизводства.Присоединить(ОбластьДетальныхЗаписей);

я исправлял,не то вставил
   mighty_1
 
3 - 25.10.17 - 12:48
Можно области ОбластьРабота и ОбластьДетальныхЗаписей Присоединять к текущей области фаза?
   Ёпрст
 
4 - 25.10.17 - 12:49
(0)
задавай секции как пересечение горизонтальной и вертикальной.
   Ёпрст
 
5 - 25.10.17 - 12:49
иначе, ты выводишь всю строку целиком
   Ёпрст
 
6 - 25.10.17 - 12:50
и присоединяешь в конец, т.е с новой строки
   chelentano
 
7 - 25.10.17 - 12:50
ТабДокумент.Вывести(ОбластьФазаПроизводства);
ТабДокумент.Присоединить(ОбластьДетальныхЗаписей);

ну и +(4)
   mighty_1
 
8 - 25.10.17 - 13:04
у меня все области это и есть пересечение гориз и вертикальн области.
Он первую строку нормально выводит , а все следующие присоедяет справа, а мне нужно чтобы они потом вертикально выводились. и чтобы Область фаза растянулась как бы.
   Ёпрст
 
9 - 25.10.17 - 13:06
(8) моя твоя непонимать.
Покажи картинки макета и ка надо в итоге
   mighty_1
 
10 - 25.10.17 - 13:11
 
 Рекламное место пустует
   Fish
 
11 - 25.10.17 - 13:14
(10) Как вариант: Сначала выводишь строки (в каждой строке Фаза А), потом определяешь область, где Фаза А идёт подряд, и объединяешь.
   Fish
 
12 - 25.10.17 - 13:14
+(11) Либо можно при выводе запоминать номера строк для дальнейшего объединения.
   Ёпрст
 
13 - 25.10.17 - 13:15
(10) не видно горизонтальных секций
   Ёпрст
 
14 - 25.10.17 - 13:19
(0)

Тебе в вертикаль объединить надо что ле ?

Тупо выводишь строку целиком, без всяких там присоединить.
При смене фазы объединяешь область вертикальную.
Усё.
   mighty_1
 
15 - 25.10.17 - 13:56
запрос обхожу по группировкам по фазам, сырью и работам.
и надо сделать как на картинке в примере.
Фазу не сверху показывать как обычно, а сбоку
   Ёпрст
 
16 - 25.10.17 - 14:32
(15) и ?
В чем проблема то ?
   Fish
 
17 - 25.10.17 - 14:33
(15) Так тебе написали уже, как делать.
   Ёпрст
 
18 - 25.10.17 - 14:33
выводишь так

фаза1 хрень1
фаза1 хрень2
...
фаза1 хреньN

как только фаза поменялась, объединяешь ячейки в выведенном макете с фазой. и привет.
   chelentano
 
19 - 25.10.17 - 14:34
(15) А что, обязательно объединять? Нельзя просто выводить фазу только в первой строке?
   Fish
 
20 - 25.10.17 - 14:35
(19) Некрасиво же.
   Ёпрст
 
21 - 25.10.17 - 14:38
(19) можно, но тогда хотя бы в ячейке нижнюю границу удалить в макете
   Fish
 
22 - 25.10.17 - 14:42
(21) Так верхняя граница при выводе следующей строки станет нижней для предыдущей.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует