Вход | Регистрация


1С:Предприятие ::

Метки: 

v7: В 7-ке есть системная ПриПовторномОткрытии(). Пытаюсь применить - пока безуспешно.

Я
   aka AMIGO
 
25.10.17 - 12:38
Есть документ Док, в нём процедура ПриПовторномОткрытии()
Из Дока вызываю Обработку, что в составе конфигурации, в неё передаю параметр.
Закрываю Обработку, надеюсь попасть уже в Доке, в процедуру ПриПовторномОткрытии() - не попадаю..

Что я неправильно понимаю? В каком случае Док будет открыт повторно?
 
 
   Ёпрст
 
1 - 25.10.17 - 12:39
(0) повторно не открываешь форму документа - нет события
   Builder
 
2 - 25.10.17 - 12:40
ОткрытьФорму(Док)
   aka AMIGO
 
3 - 25.10.17 - 12:43
(1) Вроде-б уловил..

(2) сейчас попробую
   АЛьФ
 
4 - 25.10.17 - 12:56
FromEx: ПриАктивацииОкна()
?
   aka AMIGO
 
5 - 25.10.17 - 13:57
Спасибо, мужики!
В общем, выход я нашел.
Не понимаю только сам, что я к этому "ПриПовторномОткрытии" привязался!.. Обошелся без него.

Кратко - зачем мне это всё надо было:
Нужно в одной строке ТЧ готового Дока доформировать один Реквизит. Формируется обработкой прекрасно, а вот передать в Док - тут была засада.

Теперь я передаю в обработку Контекст дока, меняю в Контексте, что мне нужно, и.. и!! Не выходя из Обработки:
Конт.Форма.Обновить()
И всё. Всего-то навсего..

Итого - спасена Россия © :)

Еще раз спасибо за участие!
   АЛьФ
 
6 - 25.10.17 - 14:59
2(5) Ээээ... А чем не устроил Форма.Параметр?
   aka AMIGO
 
7 - 25.10.17 - 15:10
(6) Друже, при возврате в документ где-то его надо найти. Вот я и пытался отловить его в процедуре повт.открытия.
И не увидел, потому и постучался в форум
В процедуре вызова обработки нет остановки после вызова формы, выполняются все операторы, вплоть до "КонецПроцедуры"
   aka AMIGO
 
8 - 25.10.17 - 15:21
+7 а в (5) - я, не выходя из обработки, делаю изменения в Доке, и потом вхожу в него, и в нём уже есть готовый реквизит.
   АЛьФ
 
9 - 25.10.17 - 15:45
2(7) В документе:
ВозвратЗначения = "";
ОткрытьФормуМодально("Обработка.МояОбработка"), ВозвратЗначения);
Сообщить(ВозвратЗначения);

В обработке:
Процедура ПриЗакрытии()
Форма.Параметр = "Возвращаемое значение";

Как-то так.
   Ёпрст
 
10 - 25.10.17 - 15:50
(9) модальность зло :)
 
 Рекламное место пустует
   АЛьФ
 
11 - 25.10.17 - 15:52
2(10) И наша задача - заставить зло работать на благо человека!
   uno-group
 
12 - 25.10.17 - 15:53
При повторном открытии обычно для отчетов юзается когда
открываеш отчет откуда либа и передаеш в него параметры а есть вероятност что он уже открыт. тогда процедура ПриОткрытии не срабатывает. а срабатывает процедура приПовторном открытии.
   YFedor
 
13 - 25.10.17 - 15:55
можно еще открывать в режиме подбора и ловить в обработке подбора исходной формы
   aka AMIGO
 
14 - 25.10.17 - 15:58
(13) это я знаю, но у меня замах произошел не в ту сторону, откинул вариант :)
(9) Про "Модально" я помнил, и испробовано сегодня с утра всё, да вот тупиковая ситуация была: обработка была открыта модально, на форме открываю справочник - форму списка, и ни-че-го из него выбрать не могу, не пускает модальное окно обработки..

А то, что при модальном открытии процесс не падает вниз в теле  процедуры - это я тоже знаю.
   АЛьФ
 
15 - 25.10.17 - 16:00
2(14) Через подбор справочник открывал? Обычное Выбрать() вполне себе позволяет что угодно выбрать в модальной обработке.
   trdm
 
16 - 25.10.17 - 16:00
Процедура АбсолютлиПриОткрытии()
КонецПроцедуры;

Процедура ПриПовторномОткрытии()
АбсолютлиПриОткрытии();
КонецПроцедуры;

Процедура ПриОткрытии()
АбсолютлиПриОткрытии();
КонецПроцедуры;
   aka AMIGO
 
17 - 25.10.17 - 16:04
(15) Да, через подбор. Но за совет спасибо, запомню.
(16) интересно :)
   Злопчинский
 
Ведущий
18 - 25.10.17 - 20:38
Прикольно когда народ пишет всякие свои фильтры-подборы, когда задача поставлена вчерновую я тупоивываливаю юзверю учойс и принимаю список подобранных объектов и все..
   Злопчинский
 
Ведущий
19 - 25.10.17 - 20:41
   Aleksey
 
20 - 25.10.17 - 20:55
(18) мои не осилили эту форму подбора. Сказали слишком сложно, верни что попроще
   Злопчинский
 
Ведущий
21 - 25.10.17 - 23:22
(20) мои осилили. Но не все и не в полном объёме.
Часть по шаблону делает
Продвинутые - изредка.

Но в целом я с тобой согласен.
(Такие подборы у меня там, где юзверь не смог сформулировать свои хотелки или смог но для каждого случая - своя частная хотелка).

Поэтому когда пипл в соседних ветках заявляет что преимущество снеговика что юзвери на скд  могут настраивать отчёты под себя - я всегда в недоумении - такое впечатление что где-то есть секретная школа выпускающая продвинутых юзеров на оперативные контуры работы....
   youalex
 
22 - 26.10.17 - 02:27
ПриПовторномОткрытии() - норм. 
Можно пользовать как аналог ОбработкаОповещения()
   bolder
 
23 - 26.10.17 - 04:37
(21) Да,могут.Но только аналитики в пользовательском режиме так настраивают СКД и сохраняют вариант для всех остальных.Это очень мощно.



Список тем форума
Рекламное место пустует Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует