Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Одна обработка на обычных формах для разных конфигураций

Одна обработка на обычных формах для разных конфигураций
Я
   picom
 
24.10.17 - 12:33
На одной форме обработки с табличкой значений нужно две кнопки.
Каждая из кнопок заполняет таблицу по алгоритмам для каждой конкретной базы.

Однако запустить эту обработку не удается в обычном режиме, т.к. ругается на код кнопки не из выбранной базы. Например, не видит глобальных процедур...

Как эту проблему решить не создавая две обработки?
 
 
   Рэйв
 
1 - 24.10.17 - 12:43
(0)да сделай ты две и не мучайся.
Но если прям сильно религиозно против, то поставь глобальные процедуры-заглушки, чтобы не материлось
   picom
 
2 - 24.10.17 - 12:48
ну нет чтоль хэштега ?
#НеПроверятьПроцедуруПриОткрытииФормы
   Рэйв
 
3 - 24.10.17 - 12:49
(2)Хитрый какой!Сначала пишешь не проверять, а потом начинаешь ее гденибудь вызывать и все, 1С в шоке.
   VladZ
 
4 - 24.10.17 - 12:53
(0) Не использую типовые процедуры и функции (пиши свои).
   VladZ
 
5 - 24.10.17 - 12:54
+4 Упс. Опечатка "Не используй..."
   Ёпрст
 
6 - 24.10.17 - 12:55
(0) в модуле объекта пиши типа
#Если Ложь Тогда

 Процедура Вася() КонецПроцедуры
#КонецЕсли
   spiller26
 
7 - 24.10.17 - 13:27
(4) Я тоже за.
   FIXXXL
 
8 - 24.10.17 - 13:50
(0)
напиши текстом, он компилится без проверок
и Выполнить()
или вынеси код в макет(ы) :)
   picom
 
9 - 24.10.17 - 14:59
(8) зачет!
   drcrasher
 
10 - 24.10.17 - 15:11
(9) половина БСП так работает +)
 
 Рекламное место пустует
   youalex
 
11 - 24.10.17 - 15:39
+ Если ругается на общий модуль, можно костылем, типа:
Если Метаданные.ОбщиеМодули.Найти(ИмяМодуля) <> Неопределено Тогда
ОбщийМодуль = Вычислить(ИмяМодуля);
ОбщийМодуль.ФункцияМодуля();
КонецЕсли;
   Бычье сердце
 
12 - 24.10.17 - 15:48
Для каждой версии конфигурации и платформы свою кнопку))))))))))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует