Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

1С такси. У кого-то есть работающий код Выгрузки хранилища в файл?

1С такси. У кого-то есть работающий код Выгрузки хранилища в файл?
Я
   haggart
 
23.10.17 - 23:33
Привет, всем.
У кого-то есть работающий код Выгрузки хранилища в файл используя асинхронные методы?
Спасибо.
 
 
   haggart
 
1 - 24.10.17 - 00:13
Не могу на chrome подключить расширение для работы с файлами.
1С 8.3.10.1981
Chrome 61.0.3163.100
   Тихий омут
 
2 - 24.10.17 - 03:07
&НаКлиенте
Процедура СохранитьФайлРуководстваНаДиск(Команда)
    #Если ВебКлиент Тогда

        Файл=НаборКонстант.РуководствоПользователя.Файл;///файл - это хранилище 

        ПолучитьФайл(ПоместитьФайлВоВременноеХранилище(Файл), ПолучитьИмяФайла(Файл), Истина);
    #КонецЕсли// [ВебКлиент] 

КонецПроцедуры

&НаСервере
Функция ПоместитьФайлВоВременноеХранилище(Файл)
    Результат = ПоместитьВоВременноеХранилище(Файл.Получить(),ЭтаФОрма.УникальныйИдентификатор);
    Возврат Результат;
КонецФункции
   haggart
 
3 - 24.10.17 - 13:08
Большое спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует