Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Проверка существования документа в директории

Проверка существования документа в директории
Я
   Aydar
 
23.10.17 - 11:37
Как в 1с проверить существует ли в определенной директории, документ с определенным названием?

Например, как проверить существует ли документ 1.txt в директории C:\Users\
 
 
   Lexey_
 
1 - 23.10.17 - 11:38
(0) НайтиФайлы()
   Гипервизор
 
2 - 23.10.17 - 11:39
(0) Существует()
   Mankubus
 
3 - 23.10.17 - 11:40
(0) предлагаю купить СП
Файл (File)
Существует (Exist)
Синтаксис:

Существует()
Возвращаемое значение:

Тип: Булево.
Истина - файл существует; Ложь - в противном случае.
Описание:

Определяет, существует ли файл, соответствующий данному объекту.

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Примечание:

Для работы метода на веб-клиенте необходимо предварительно подключить расширение работы с файлами.
Пример:

Функция ПроверитьСуществованиеКаталога(ИмяКаталога) Экспорт
    КаталогНаДиске = Новый Файл(ИмяКаталога);
    Если КаталогНаДиске.Существует() Тогда
        Возврат Истина;
    Иначе
        Ответ = Вопрос("Каталог не существует. Создать?", 
                        РежимДиалогаВопрос.ОКОтмена);
        Если Ответ = КодВозвратаДиалога.ОК Тогда
            СоздатьКаталог(ИмяКаталога);
            Возврат Истина;
        Иначе
            Возврат Ложь;
        КонецЕсли;
    КонецЕсли;
КонецФункции
   1dvd
 
4 - 23.10.17 - 11:40
Документ для одинсеника это другое
   stix2010
 
5 - 23.10.17 - 12:07
(0) мда, это даже не Индия, это хуже

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует