Вход | Регистрация

1С:Предприятие ::

Метки: 

При объединении строк в табдок вводить значения в ячейки...?

Я
   Обработка
 
23.10.17 - 09:53
Парюсь что-то долго. Если при выводе в таб док я объединяю строки. Как мне вывести после объединения значение параметра или в выбранную ячейку

Дело в том что двух или более строках значение параметра последней строки равна суммирующему значению полей объединения
Код:
ОбъединитьЯчейки(ТабДок,МассивОбъединяемыхКолонок2, НомерСтрДо2);
                ТекОбласть = ТабДок.Область(ТабДок.ВысотаТаблицы  ,5,ТабДок.ВысотаТаблицы ,5);
                ТекОбласть.Текст = Подр;
 
 
   Обработка
 
1 - 23.10.17 - 09:53
проц:

Процедура ОбъединитьЯчейки(ТабДок,Массив,Начало)
    Если НеОбъединять Тогда
        Возврат;
    КонецЕсли;    
    НомерСтрПосле = ТабДок.ВысотаТаблицы;
    Если НомерСтрПосле > Начало Тогда
        //Объединим

        Для Каждого ОбъединяемаяКолонка Из Массив Цикл 
            ОбъединяемаяОблать = ТабДок.Область("R" + Формат(Начало, "ЧГ=0") + ОбъединяемаяКолонка + ":" + "R" + Формат(НомерСтрПосле, "ЧГ=0") + ОбъединяемаяКолонка);
            ОбъединяемаяОблать.Объединить();
        КонецЦикла;
    КонецЕсли;
    
КонецПроцедуры
   Тихий омут
 
2 - 23.10.17 - 10:20
Сумбурно как-то изложено.
При объединении ячеек значение в объединенной ячейке равно значению ячейки с наименьшим адресом из объединяемых.
Ещё раз - в чём проблема?
   Обработка
 
3 - 23.10.17 - 10:41
(2) В цикле вывожу строки. Потом по некоторым условиям  объединяю строки их может быть две или более. Но при выводе каждой строки некая ячейка  заполняется значением суммы всех строк Например Подр = Подр + Выборка.Подр;

Но на деле в реультирующей таблице не наблюдаю присвоение
последенего "Подр".
   Ёпрст
 
4 - 23.10.17 - 10:48
(3) после объединения помести значение в первую ячейку.
   Fedor-1971
 
5 - 23.10.17 - 10:49
(3) Так, где объединяешь, там и заполни выводимый текст в ячейке, типа
ТабДок.Область(НомерПервойСтрокиОбъединения, НомерКолонки).Текст = чтоНужноПолучить
   h-sp
 
6 - 23.10.17 - 11:01
(3) наверно так проще
            ОбъединяемаяОблать = ТабДок.Область(Начало, ОбъединяемаяКолонка, НомерСтрПосле, ОбъединяемаяКолонка);

чего-то фигню какую-то написал с форматами.
   Обработка
 
7 - 23.10.17 - 11:03
Нашел траблу

Вот как надо...
Я добавлял или писал в текущую.
ТекОбласть = ТабДок.Область(ТабДок.ВысотаТаблицы-1  ,5,ТабДок.ВысотаТаблицы-1 ,5);

Всем спасибо!!!


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует