Вход | Регистрация

1С:Предприятие ::

Метки: 

Проблема со чтением документа

Я
   Aydar
 
20.10.17 - 14:32
Допустим у меня есть простой текстовый файл (с содержимом в виде каког - нибудь реферата). Пишу следующим образом
Чтение         = Новый ЧтениеJSON;
Чтение.ОткрытьФайл("text.txt", "cp1251");
Пока Чтение.Прочитать Цикл
Значение =  Чтение.ТекущееЗначение;
КонецЦикла

но это не работает. Не подскажите как можно прочитать файл?
 
  Рекламное место пустует
   vicof
 
1 - 20.10.17 - 14:36
Новый текстовыйдокумент
   spiller26
 
2 - 20.10.17 - 14:39
(1) JSON - это текстовый формат обмена данными у которого есть некая структура.
   spiller26
 
3 - 20.10.17 - 14:41
//чтение файла целиком

Файл = Новый ЧтениеТекста("D:\Текстовый файл.txt");
ВесьФайлОднойСтрокой = Файл.Прочитать();
Файл.Закрыть();

//построчное чтение

мСтрокФайла = Новый Массив();
Файл = Новый ЧтениеТекста("D:\Текстовый файл.txt");

//прочитать строку считывает одну строку из файла

//если достигнут конец файла, то возвращается значение НЕОПРЕДЕЛЕНО
Строка = Файл.ПрочитатьСтроку();
//а не был ли файл пуст?

Если Строка <> Неопределено Тогда
     мСтрокФайла.Добавить(Строка);
КонецЕсли;

//цикл пока чтение строки не вернет НЕОПРЕДЕЛЕНО

//внутри цикла повторяем чтение
Пока Строка <> Неопределено Цикл
     Строка = Файл.ПрочитатьСтроку();
     Если Строка <> Неопределено Тогда
          мСтрокФайла.Добавить(Строка);
     КонецЕсли;
КонецЦикла;
     
Файл.Закрыть();
   Масянька
 
4 - 20.10.17 - 14:43
(0) Правильно "с чтением".
PS Это заразно :)


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует