Вход | Регистрация


Обычные формы. Не получается уравлять интерфейсом.

Обычные формы. Не получается уравлять интерфейсом.
Я
   Галахад
 
20.10.17 - 08:39
Для каждого ТекИнтерфейс Из ГлавныйИнтерфейс Цикл
        
        Стр = ТаблицаИнтерфейсов.Найти("" + ТекИнтерфейс);
        
        ТекИнтерфейс.Переключаемый = Стр.Переключаемый;
        ТекИнтерфейс.Видимость     = Стр.Видимость;
        
    КонецЦикла;

Убираю лишние интерфейсы. Потом пытаюсь восстановить как было.
Не получается. В ГлавныйИнтерфейс у всех интерфейсов видимость устанавливается "Истина", а "Переключаемый" вообще рандомно.
 
 
   Галахад
 
1 - 20.10.17 - 08:45
Или у меня глюки. На всякий пожарный вкладываю полный код:

Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    ТаблицаИнтерфейсов = Новый ТаблицаЗначений;
    ТаблицаИнтерфейсов.Колонки.Добавить("ТекИнтерфейс");
    ТаблицаИнтерфейсов.Колонки.Добавить("Переключаемый", Новый ОписаниеТипов("Булево"));
    ТаблицаИнтерфейсов.Колонки.Добавить("Видимость", Новый ОписаниеТипов("Булево"));
    
    Для каждого ТекИнтерфейс Из ГлавныйИнтерфейс Цикл
        
        НовСтр = ТаблицаИнтерфейсов.Добавить();
        НовСтр.ТекИнтерфейс = "" + ТекИнтерфейс;
        НовСтр.Переключаемый = ТекИнтерфейс.Переключаемый;
        Новстр.Видимость = ТекИнтерфейс.Видимость;
        
        ТекИнтерфейс.Переключаемый = Ложь;
        ТекИнтерфейс.Видимость     = Ложь;
        
    КонецЦикла;
    
КонецПроцедуры

Процедура ОсновныеДействияФормыВосстановитьИнтерфейсы(Кнопка)

    Для каждого ТекИнтерфейс Из ГлавныйИнтерфейс Цикл
        
        Стр = ТаблицаИнтерфейсов.Найти("" + ТекИнтерфейс);
        
        
        ТекИнтерфейс.Переключаемый = Стр.Переключаемый;
        ТекИнтерфейс.Видимость     = Стр.Видимость;
        
    КонецЦикла;
    
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует