Вход | Регистрация

1С:Предприятие ::

Метки: 

Изменить реквизит документа

Я
   first_may
 
19.10.17 - 21:24
Добрый день.

Конфигурация Управление производственным предприятием, редакция 1.3, но наверное это не важно.

Есть пользователь с правами Менеджер по продажам, по закупкам и тд, но у него нет роли Отражение в регламентированном учете.

Есть проведенный документ, допустим ПТиУ.

Вопрос - как сделать, что бы этот пользователь мог изменить значение Комментария?

Нашел, что можно использовать
Док.ОбменДанными.Загрузка = Истина;
Док.Записать();

но это вроде работает, когда документ не проведен.

Прошу помощи.
 
  Рекламное место пустует
   trooba
 
1 - 19.10.17 - 21:26
(0) Работает всегда. Читай УстановитьПривилегированныйРежим()
   first_may
 
2 - 19.10.17 - 22:55
(1) Зашел под пользователем у которого нет роли Отражение в регламентированном учете, но есть дополнительное право Разрешить отражать в регламентированном учете.

в списке стал на документ из закрытого периода и нажал кнопку, которая вызывает процедуру в которой написано

...
Попытка
    УстановитьПривилегированныйРежим(Истина);
    ДокОбъект.ОбменДанными.Загрузка = Истина;
    ДокОбъект.Записать(РежимЗаписиДокумента.Запись);
Исключение
    Сообщить("Не удалось установить документу признак" + Символы.ПС + ОписаниеОшибки());
КонецПопытки;

все это в модуле у которого свойства Сервер, Привилегированный.

В итоге получил сообщение
Не удалось установить документу признак.
{ОбщийМодуль.ОбработкаПривилигерированный.Модуль(83)}: Ошибка при вызове метода контекста (Записать): Не удалось записать "Реализация товаров и услуг ДМ000000027 от 17.11.2016 16:15:57"!
   patapum
 
3 - 19.10.17 - 23:07
(2) у пользователя нет прав на запись документа?
   first_may
 
4 - 19.10.17 - 23:11
(3) в открытом периоде есть..
   first_may
 
5 - 19.10.17 - 23:13
если дать роль Отражение в регламентированном учете, то все работает замечательно, но он сможет тогда открыть документ в закрытом периоде и поменять не только комментарий, а затем првоести
   first_may
 
6 - 20.10.17 - 10:02
Получается, что надо давать роль Отражение в регламентированном учете, но при открытии формы закрывать все реквизиты, кроме Комментария. По другому сделать нелья?
   Повелитель
 
7 - 20.10.17 - 10:06
(2) Заведите новое свойство "Комментарий документа".
И пусть заполнят, права будут.
В отчетах через свойство достать можно будет тоже.
   banzay
 
8 - 20.10.17 - 10:23
(0) Используй обработку, в которой устанавливается СОМ-соединение с этой-же базой, но логинится пользователь с полными правами, на форме обработки обязательный реквизит - строка, куда пользователь заносит новый (дополнительный) комментарий, нажимает кнопку "Выполнить", и с пом. СОМ изменяется комментарий нужного дока.
   John83
 
9 - 20.10.17 - 10:30
я сделал внеш. печ. форму, в которой задается комментарий, затем
объект.обменданными.загрузка = истина
   first_may
 
10 - 20.10.17 - 10:37
(9) о-о-о, это мысль!
 
 
   Волшебник
 
Модератор
11 - 20.10.17 - 10:40
(9) моветон
   first_may
 
12 - 20.10.17 - 22:26
Может бы поторопился немного. Сделал внешнюю печатную форму ТЕСТ в которой прописал
Функция Печать() Экспорт
    ДокОбъект = СсылкаНаОбъект.ПолучитьОбъект();
    
    ЕстьИзменения = Ложь;
    Если ДокОбъект.Метаданные().Реквизиты.Найти("ПолученоОЛ") <> Неопределено Тогда
        Если ДокОбъект.ПолученоОЛ = Истина Тогда
            ДокОбъект.ПолученоОЛ = Ложь;
        Иначе
            ДокОбъект.ПолученоОЛ = Истина;
        КонецЕсли;
        ЕстьИзменения = Истина;
    КонецЕсли;
    
    Если ЕстьИзменения Тогда
        Попытка
            УстановитьПривилегированныйРежим(Истина);
            
            ДокОбъект.ОбменДанными.Загрузка = Истина;
            ДокОбъект.Записать(РежимЗаписиДокумента.Запись);
            
            УстановитьПривилегированныйРежим(Ложь);
        Исключение
            Сообщить("Не удалось установить документу признак Получено ОЛ " + Символы.ПС + ОписаниеОшибки());
        КонецПопытки;
    КонецЕсли;
КонецФункции


Затем зашел под пользователем, у которого нет роли Отражение в регламентированном учете.

Далее в закрытом периоде (а можно и незакрытом) открыл два документа - один проведенный, второй нет.

В каждом из них вызвал внешнюю печатную форму ТЕСТ:
- в непроведенном документе реквизит изменился
- в проведенном выдалось сообщение
Запись документа: Реализация товаров и услуг ДМ0401062017 от 01.06.2017 9:00:03
Недостаточно прав для отражения в регламентированном учете. Изменения не могут быть записаны...
Не удалось установить документу признак Получено ОЛ


Получается, что пользователь без указаной роли не смог изменить реквизит проведенного документа.
   first_may
 
13 - 21.10.17 - 08:55
Очень нужен совет,как быть
   МимохожийОднако
 
14 - 21.10.17 - 10:25
(13) Тебе уже сказали. Используй дополнительный реквизит вместо реквизита Комментарий, который для другого предназначен.
   first_may
 
15 - 21.10.17 - 13:41
Понятно.


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует