Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Проблема с выборкой

↓ [Волшебник, 19.10.17 - 11:34]
Проблема с выборкой
Я
   proveri4
 
19.10.17 - 10:11
Всем добрый день, в конфигураторе, необходим вывод выбранных параметров с помощью установки флажков, база 1С:ERP, но постоянно оишбки разные
{Документ.СБ_РезультатыПланированияПроизводства.Форма.ФормаЭлемента.Форма(175,35)}: Тип не определен (СоответствиеФлажка)
 Объект.Продукция.Выборка = Новый <<?>>СоответствиеФлажка(Истина); (Проверка: Тонкий клиент)

http://screenshot.ru/upload/image/SfR8


&НаКлиенте
    Процедура тпОбъектПродукцияВыборкаПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
ОформлениеСтрокиЯчейкиОтметкаОтображатьФлажок = Истина;
         
Если Объект.Продукция.Выборка[ДанныеСтроки] = Неопределено Тогда
      ОформлениеСтроки.Ячейки.Отметка.Флажок = Ложь;
Иначе
     ОформлениеСтроки.Ячейки.Отметка.Флажок = Истина;
 КонецЕсли;
 Объект.Продукция.Выборка = Новый СоответствиеФлажка(Истина);
 СоответствиеФлажка = СписокВыбранныхСтрок;
КонецПроцедуры


&НаКлиенте
Процедура СоздатьДокументы(Команда)
    Если Модифицированность Тогда
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Перед выполнением действия необходимо записать документ!");
        Возврат;
    КонецЕсли;
    СписокСозданныхДокументов = (СписокВыбранныхСтрок);
    СоздатьЗаказыНаПроизводство = (СписокСозданныхДокументов);
    КоличествоДокументов = СписокСозданныхДокументов.Количество();
    ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Сформировано "+КоличествоДокументов+" документов!");
конецпроцедуры
 
 
   МимохожийОднако
 
1 - 19.10.17 - 10:16
<<?>>СоответствиеФлажка откуда такой тип?
   Волшебник
 
Модератор
2 - 19.10.17 - 10:17
что такое СоответствиеФлажка?
   Филиал-msk
 
3 - 19.10.17 - 10:22
Судя по префиксам СБ - ССЗБ
   proveri4
 
4 - 19.10.17 - 10:23
МимохожийОднако случайный заданный тип для записи значений флажков
   DTX 4th
 
5 - 19.10.17 - 10:35
И давно в 1С можно свои типы создавать?
Возможно, "Новый" лишнее?
   proveri4
 
6 - 19.10.17 - 10:36
DTX 4th ну я как бы поэтому и пишу, прошу помощи
   Волшебник
 
Модератор
7 - 19.10.17 - 10:38
Программирование — это точная наука, а не гадание на кофейной гуще.
   proveri4
 
8 - 19.10.17 - 10:38
новый убрал не помогло, 
{Документ.СБ_РезультатыПланированияПроизводства.Форма.ФормаЭлемента.Форма(175,29)}: Переменная не определена (СоответствиеФлажка)
 Объект.Продукция.Выборка = <<?>>СоответствиеФлажка; (Проверка: Тонкий клиент)
{Документ.СБ_РезультатыПланированияПроизводства.Форма.ФормаЭлемента.Форма(185,31)}: Переменная не определена (СоответствиеФлажка)
    СписокСозданныхДокументов = (<<?>>СоответствиеФлажка); (Проверка: Тонкий клиент)
   МимохожийОднако
 
9 - 19.10.17 - 10:39
(4) Расставь знаки препинания. Открой документацию и СП.
   Волшебник
 
Модератор
10 - 19.10.17 - 10:39
(8) Поставьте себя на место компилятора.
Он встречает новое слово, которое раньше никогда не видел. Ему непонятно, что вы хотели сказать. А значит он не сможет выполнить эту программу.
 
 Рекламное место пустует
   proveri4
 
11 - 19.10.17 - 10:43
хорошо, расставить знаки препинания,где с ними не так, я уже пересмотрел эту часть кода, что меня ночью разбуди наизусть скажу, и тогда какую лучше команду использовать чтобы она записывала, те строки к себе которые отмечены флажками и производилась уже по ним дальнейшая обработка
   Гипервизор
 
12 - 19.10.17 - 10:50
Поторопились вы, такая тема завтра бы хорошо зашла. Вы лучше наизусть про СоответствиеФлажка скажите, вам уже столько человек про это написали.
   1dvd
 
13 - 19.10.17 - 10:54
(11) у Вас, голубчик, каша в голове.

Кто ясно мыслит, тот ясно излагает
   Филиал-msk
 
14 - 19.10.17 - 10:55
(4) > МимохожийОднако случайный заданный тип

Я давно его подозревал! (:
   proveri4
 
15 - 19.10.17 - 11:37
про соответствиефлажка понял, исправил, но все равно проблема, мне тогда запись делать в какую команду, Соответствие.Количество или Соответствие.Получить, не могу разобраться
   proveri4
 
16 - 19.10.17 - 11:38
&НаКлиенте
    Процедура тпОбъектПродукцияВыборкаПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
ОформлениеСтрокиЯчейкиОтметкаОтображатьФлажок = Истина;
         
Если Объект.Продукция.Выборка[ДанныеСтроки] = Неопределено Тогда
      ОформлениеСтроки.Ячейки.Отметка.Флажок = Ложь;
Иначе
     ОформлениеСтроки.Ячейки.Отметка.Флажок = Истина;
 КонецЕсли;
 
 Объект.Продукция.Выборка = Соответствие.Получить(количество);
КонецПроцедуры


&НаКлиенте
Процедура СоздатьДокументы(Команда)
    Если Модифицированность Тогда
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Перед выполнением действия необходимо записать документ!");
        Возврат;
    КонецЕсли;
    СписокСозданныхДокументов = (Соответствие.Количество);
    СоздатьЗаказыНаПроизводство = (СписокСозданныхДокументов);
    КоличествоДокументов = СписокСозданныхДокументов.Количество();
    ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Сформировано "+КоличествоДокументов+" документов!");
конецпроцедуры
   proveri4
 
17 - 19.10.17 - 11:38
или меня опять не в ту степь несет?
   proveri4
 
18 - 19.10.17 - 12:09
получается мне значения в моей выборке нужно поместить в какой то массив и далее уже по нажатии кнопки сформировать заказ, чтобы он проверял значения массива, если выбрано что то то он выводит выбранные строки с талбицы в заказ, а если не выбрано ничего то он выводит все

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует