Вход | Регистрация

1С:Предприятие ::

Метки: 

Проблемы после свертки

Я
   CoderDecoder
 
19.10.17 - 08:25
Типовой обработкой свернули УТ 10.3. Все нормально, только вот долги контрагентов в отчетах верные, а на формах (надпись долга) совсем другие цифры. Посмотрел в отладке, вроде и отчет и форма берут данные из регистра ВзаиморасчетыСКонтрагентами. В самом регистре данные тоже правильные. Но все равно Надпись долга а соответственно и сумма долга в печатной форме неправильные. Остатки взаиморасчетов сформированы типовой обработкой через документ Корректировки записей регистров.
 
  Рекламное место пустует
   Рэйв
 
1 - 19.10.17 - 08:41
Пересчет итогов сделай.
   CoderDecoder
 
2 - 19.10.17 - 08:48
(1) Забыл сказать - первым делом итоги пересчитал: Операции->Управление итогами->Выполнить
   Рэйв
 
3 - 19.10.17 - 08:54
(2)Тогда вероятно, что для надписи берутся данные из регистра ВзаиморасчетыСКонтрагентами, но не так как это делает отчет.Что-то отнимается или наоборот добавляется
   CoderDecoder
 
4 - 19.10.17 - 09:12
Процедура СформироватьНадписьДолга(ДоговорКонтрагента, Сделка, ЭлементФормыНадписьДолга, 
                                     СсылкаДокумент = Неопределено, МожноНеРассчитывать = Ложь) Экспорт

    Если МожноНеРассчитывать Тогда
        Если НЕ УправлениеДопПравамиПользователей.РассчитыватьДолгПриОткрытииФорм() Тогда
            ЭлементФормыНадписьДолга.Заголовок = ПолучитьТекстДолга(ДоговорКонтрагента, Неопределено);
            Возврат;
        КонецЕсли;
    КонецЕсли;

    Если ТипЗнч(ДоговорКонтрагента) = Тип("СправочникСсылка.ДоговорыКонтрагентов") Тогда
        
        СуммаДолга = УправлениеВзаиморасчетами.ТекущийДолг(ДоговорКонтрагента, Сделка, СсылкаДокумент);

        ТекстДолга = ПолучитьТекстДолга(ДоговорКонтрагента, СуммаДолга);

        Если СуммаДолга > 0 Тогда// Долг контрагента, покрасим текст в особый цвет

            ЭлементФормыНадписьДолга.ЦветТекста = ЦветаСтиля.ТекстПредупреждающейНадписи;
        Иначе
            ЭлементФормыНадписьДолга.ЦветТекста = ЦветаСтиля.ТекстИнформационнойНадписи;
        КонецЕсли; 

        ЭлементФормыНадписьДолга.Заголовок = ТекстДолга;
    Иначе
        ЭлементФормыНадписьДолга.Заголовок = "";
    КонецЕсли; 

КонецПроцедуры// СформироватьНадписьДолга()


Типовая процедура!
   CoderDecoder
 
5 - 19.10.17 - 09:20
Причем, нет никакой связи между суммами. Имею в виду не наблюдается какой то одинаковый коэффициент пересчета. Помню как то такое было, но не могу вспомнить где была зарыта собака ((
   dezss
 
6 - 19.10.17 - 09:23
А что показывает отладка?
   Рэйв
 
7 - 19.10.17 - 09:26
(4)это может быть хоть сто раз типовой и не меняться сто лет.
Смотри  в ПолучитьТекстДолга().

Практически инкапсуляция,сэр! которой говорят нет в 1С:-)
   1dvd
 
8 - 19.10.17 - 09:26
(5) ты уверен что сравниваешь долги именно по договорам и на необходимую дату?
   1dvd
 
9 - 19.10.17 - 09:27
(7) ПолучитьТекстДолга можно не смотреть. главное посмотреть УправлениеВзаиморасчетами.ТекущийДолг
   Рэйв
 
10 - 19.10.17 - 09:28
(9)Ну да.
 
  Рекламное место пустует
   CoderDecoder
 
11 - 19.10.17 - 10:34
Вот тут:

            ТекущийДолг = РегистрыНакопления.ВзаиморасчетыСКонтрагентами.Остатки(,
                        СтруктураОтбора,"ДоговорКонтрагента","СуммаВзаиморасчетов").Итог("СуммаВзаиморасчетов");

уже возвращается завышенная сумма (4722)

Смотрю в тот же регистр с отбором по контрагенту - сумма правильная (2538)
   CoderDecoder
 
12 - 19.10.17 - 10:48
(8) Да, уверен. Договор один, дата текущая.
   agarych
 
13 - 19.10.17 - 11:08
Ты точно сравниваешь суммы взаиморасчетов, а не сумму упр и сумму взаиморасчетов?
   agarych
 
14 - 19.10.17 - 11:10
(11)

В отчете смотришь с отбором по контрагенту, а в документе с отбором по договору. В отчете сделай группировку по договорам и посмотри, что будет.
   SeriyP
 
15 - 19.10.17 - 11:25
(0) "Типовой обработкой свернули УТ 10.3" Что за обработка такая? Тут просто друг интересуется :)
   CoderDecoder
 
16 - 19.10.17 - 13:06
(13) Обе суммы в одной и той же валюте.
(14)  У контрагентов 1 договор.
   CoderDecoder
 
17 - 19.10.17 - 13:06
(15) да типовая с итс
   CoderDecoder
 
18 - 19.10.17 - 20:21
ап
   John83
 
19 - 20.10.17 - 10:46
пересчитай итоги через пофигуратор
а еще лучше полное ТиИ сделай
   CoderDecoder
 
20 - 20.10.17 - 12:05
(19) Да, спасибо! Уже сделал, помогло! Спасибо всем!


Список тем форума
Рекламное место пустует   Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует