Вход | Регистрация

1С:Предприятие ::

Метки: 

Сохранение документа из Телеграмма в 1с

Я
   Aydar
 
18.10.17 - 13:56
Как можно реализовать?
Нужно чтобы пользователи отправляли боту документ, а 1с-ка сохраняла эти  документы.
 
 
   Филиал-msk
 
1 - 18.10.17 - 15:10
Вчера же уже обсуждали - Прием файлов из телеграмм в 1с
   Лефмихалыч
 
2 - 18.10.17 - 15:40
(1) бестолково обсудили - ветка ни о чем.
   Numerus Mikhail
 
3 - 18.10.17 - 15:41
(2) Ну так и эта такая же
   PiotrLoginov
 
4 - 18.10.17 - 16:03
может, поможет  http://catalog.mista.ru/public/387433/
   BaHgaJI
 
5 - 18.10.17 - 16:53
Выполни метод телеграма getfile, туда передается id файла.

А потом разбирай полученный ответ:

Ответ =  Ответ.result.file_path; 

    Если Найти(Ответ,"photos/") Тогда
        ПутьКФалу = Ответ;
        ИмяСохраненияДляФайла = Сред(Ответ, Найти(Ответ,"/")+1) ;
    ИначеЕсли Найти(Ответ,"document/") Тогда
        ПутьКФалу = Ответ;
        ИмяСохраненияДляФайла = Сред(Ответ, Найти(Ответ,"/")+1) ;        
    КонецЕсли;

Ресурс = "https://"; + "api.telegram.org" + "/file/bot" + ТокенБотаТелеграма + "/" + ПутьКФалу;
    КопироватьФайл(Ресурс,ПутьКудаСкопироватьФайл);
   Aydar
 
6 - 19.10.17 - 13:43
(5) Делаю следующим образом
Процедура Скачать(file_id)
    
    Ключ         = Константы.КлючAPI.Получить();
    Сервер = "api.telegram.org";
    Команда = "getFile";
    Ресурс         = "bot" + Ключ + "/" + Команда + "?file_id=" + file_id;
    Соединение     = Новый HTTPСоединение(Сервер,,,,,, Новый ЗащищенноеСоединениеOpenSSL);
    Запрос         = Новый HTTPЗапрос(Ресурс);
    Ответ         = Соединение.Получить(Запрос);
    Чтение         = Новый ЧтениеJSON;
    Чтение.УстановитьСтроку(Ответ.ПолучитьТелоКакСтроку());
    ОтветСоотв = ПрочитатьJSON(Чтение, Истина);
    ok =  ОтветСоотв["ok"];
    Если ok Тогда
        path = ОтветСоотв["result"]["file_path"];
    КонецЕсли;
    Ресурс = "file" + "/" + "bot" + Ключ + "/" + path;
    Запрос         = Новый HTTPЗапрос(Ресурс);
    Ответ         = Соединение.Получить(Запрос);
    
    
КонецПроцедуры

Как можно исправить, что бы файл скачался?
   skela1c
 
7 - 19.10.17 - 14:25
"Ответ" будет иметь тип "HTTPОтвет" и использовать его  методы
   Aydar
 
8 - 19.10.17 - 14:31
(7) я знаю, что такой тип будет иметь)
как сделать так, что файл скачался?
в переменной ресурс хранится прямая ссылка на скачивание, если я эту ссылку вставляю в браузер, то файл скачивается, а почему
через 1с не скачивается?
   ilyavorobyev
 
9 - 19.10.17 - 14:32
(8) тебе же написали
Ресурс = "https://";; + "api.telegram.org" + "/file/bot" + ТокенБотаТелеграма + "/" + ПутьКФалу;
    КопироватьФайл(Ресурс,ПутьКудаСкопироватьФайл);
   Aydar
 
10 - 19.10.17 - 14:56
(9) так не работает
 
  Рекламное место пустует
   Aydar
 
11 - 19.10.17 - 15:12
(9) может как то с помощь json а нужно делать, только я не умею с ним работать
   skela1c
 
12 - 19.10.17 - 15:20
а если post запрос отправить?
   Aydar
 
13 - 19.10.17 - 16:10
(12) а как в 1с пост запрос отправлять?
   skela1c
 
14 - 19.10.17 - 16:49
ТелоЗапроса1 = запрос_на_Скачивание;

Запрос2  = Новый HTTPЗапрос(РесурсНаСервере, Заголовки2);
        Запрос2.УстановитьТелоИзСтроки(ТелоЗапроса1, "windows-1251");
фРезультата = КаталогВременныхФайлов()+"123.html";
Результа2 = Соединение.ОтправитьДляОбработки(Запрос2, фРезультата);
   Aydar
 
15 - 19.10.17 - 17:12
(14) тоже не работает


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует