Вход | Регистрация

1С:Предприятие ::

Метки: 

1С 8.2 НУФ Неудачная попытка удаления записи из регистра накопления!

Я
   DenisVich
 
17.10.17 - 10:28
Пытаюсь из регистра накопления удалить запись. Не удаляется. пишет "Неудачная попытка удаления записи из регистра накопления!". Удаляю своей обработкой. Что интересно в другом регистре накопления с таким же кодом все удалилось. Конфа самопал. В файловой базе все отлично удалилось. Любой регистр накопления, бухгалтерский подставляю все отлично.

"Процедура ОбработатьРегистрНакопления()
Запрос =  Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               |    Взаиморасчеты.Период,
               |    Взаиморасчеты.Регистратор,
               |    Взаиморасчеты.НомерСтроки,
               |    Взаиморасчеты.Активность,
               |    Взаиморасчеты.Организация,
               |    Взаиморасчеты.Сумма
               |ИЗ
               |    РегистрНакопления.Взаиморасчеты КАК Взаиморасчеты
               |ГДЕ
               |    Взаиморасчеты.Регистратор = &Регистратор
               |    И Взаиморасчеты.Период >= &ДатаНачало
               |    И Взаиморасчеты.Период <= &ДатаКонца";
Запрос.УстановитьПараметр("Регистратор", ЭтотОбъект.Регистратор);
Запрос.УстановитьПараметр("ДатаНачало", НачалоДня(ЭтотОбъект.ДатаНачала));
Запрос.УстановитьПараметр("ДатаКонца", КонецДня(ЭтотОбъект.ДатаОкончания));

НаборЗаписей = РегистрыНакопления.Взаиморасчеты.СоздатьНаборЗаписей();
Выборка = Запрос.Выполнить().Выбрать();
//Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока Выборка.Следующий() Цикл//Перебор в цикле регистраторов

    //Выборка.Регистратор

     НаборЗаписей.Отбор.Регистратор.Значение = Выборка.Регистратор;
     НаборЗаписей.Прочитать();
     ВыборкаНомерСтроки = Выборка.Выбрать();     
//     ВыборкаНомерСтроки = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

//   Пока ВыборкаНомерСтроки.Следующий() Цикл//Реребор в цикле номеров строк записей

//

//        НаборЗаписей.Удалить(ВыборкаНомерСтроки.НомерСтроки-1);    

//   КонецЦикла;

 БылиОшибки = Ложь;
 Попытка
           НаборЗаписей.Удалить(0);
           НаборЗаписей.Записать();
        Исключение
           БылиОшибки=Истина;
        КонецПопытки;
    
    КонецЦикла;
    Если БылиОшибки Тогда
       Предупреждение("Обработка завершена. Регистр очищен не до конца!!!");
    КонецЕсли;
    РегистрыНакопления.Взаиморасчеты.УстановитьИспользованиеИтогов(Истина);       
КонецПроцедуры
"
 
  Рекламное место пустует
   DenisVich
 
1 - 17.10.17 - 10:30
В SQL проблемы.
   DenisVich
 
2 - 17.10.17 - 10:43
Притом подобное в другом регистре накопления удалось удалить.
   Галахад
 
3 - 17.10.17 - 10:45
Может стоит регистратор посмотреть?
   h-sp
 
4 - 17.10.17 - 10:55
(2) наверно нечего удалять. Там пусто и так.
   DenisVich
 
5 - 17.10.17 - 11:04
Запись есть. Осталась. В том то и дело.


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует