Вход | Регистрация


1С:Предприятие ::

Метки: 

Несоответствие типов (параметр номер '1')

Я
   Sanr231
 
16.10.17 - 16:10
После обновления конфигурации 1с упрощенка 8 до версии 8.3.10.2580 платформы и 3.0.52.42 конфигурации при создании счета вылезла ошибка:
Несоответствие типов (параметр номер '1')

в отладчике:
{ОбщийМодуль.РегламентныеЗаданияСервер.Модуль(838)}: Ошибка при вызове метода контекста (НайтиПоУникальномуИдентификатору)
        РегламентноеЗадание = РегламентныеЗадания.НайтиПоУникальномуИдентификатору(Идентификатор);
по причине:
Несоответствие типов (параметр номер '1')


На этом мои познания в программировании 1с заканчиваются. Где собака закопана?
 
 
   Heckfy
 
1 - 16.10.17 - 16:18
У тебя Идентификатор имеет тип НЕ УНИКАЛЬНЫЙИДЕНТИФИКАТОР.
А нужно что бы был УникальныйИдентификатор.

МенеджерРегламентныхЗаданий (ScheduledJobsManager)
НайтиПоУникальномуИдентификатору (FindByUUID)
Синтаксис:

НайтиПоУникальномуИдентификатору(<Идентификатор>)
Параметры:

<Идентификатор> (обязательный)

Тип: УникальныйИдентификатор.
Идентификатор регламентного задания.
Возвращаемое значение:

Тип: РегламентноеЗадание; Неопределено.
Если задание для заданного идентификатора не найдено, возвращает Неопределено.
Описание:

Осуществляет поиск регламентного задания по уникальному идентификатору. Получение регламентного задания возможно только для администратора.

Доступность:

Сервер, толстый клиент, внешнее соединение.
   Sanr231
 
2 - 16.10.17 - 16:21
Соответственно, что мне нужно сделать?
   Heckfy
 
3 - 16.10.17 - 16:26
Присвоить переменной Идентификатор тип УникальныйИдентификатор. :)
   Sanr231
 
4 - 16.10.17 - 16:27
Так заводская конфигурация и модуль только для чтения.
   СамыйУмный
 
5 - 16.10.17 - 16:28
(4) А ну тогда все..ничего не сделать
   Sanr231
 
6 - 17.10.17 - 14:45
Функция ПолучитьРегламентноеЗадание(Знач Идентификатор) Экспорт
    
    ВызватьИсключениеЕслиНетПраваАдминистрирования();
    
    Если ТипЗнч(Идентификатор) = Тип("РегламентноеЗадание") Тогда
        Идентификатор = Идентификатор.УникальныйИдентификатор;
    КонецЕсли;
    
    Если ТипЗнч(Идентификатор) = Тип("УникальныйИдентификаторИдентификатор") Тогда
        Идентификатор = Новый УникальныйИдентификатор(Идентификатор);
    КонецЕсли;
    
    Если ТипЗнч(Идентификатор) = Тип("ОбъектМетаданных") Тогда
        РегламентноеЗадание = РегламентныеЗадания.НайтиПредопределенное(Идентификатор);
    Иначе
        РегламентноеЗадание = РегламентныеЗадания.НайтиПоУникальномуИдентификатору(Идентификатор);
    КонецЕсли;
    
    Если РегламентноеЗадание = Неопределено Тогда
        ВызватьИсключение( НСтр("ru = 'Регламентное задание не найдено.
                                      |Возможно, оно удалено другим пользователем.'") );
    КонецЕсли;
   Sanr231
 
7 - 17.10.17 - 14:46
Вот весь текст модуля. Где исправить идентификатор?
   X Leshiy
 
8 - 17.10.17 - 14:47
(0) Кэш чистил?
   Sanr231
 
9 - 17.10.17 - 14:54
Чистил
   ildary
 
10 - 17.10.17 - 15:05
(9) выгрузку-загрузку базы делал?
 
 Рекламное место пустует
   h-sp
 
11 - 17.10.17 - 15:09
(8) тии сделай
   Sanr231
 
12 - 17.10.17 - 15:09
Выгрузку загрузку - не делал.
А что такое тии?
   h-sp
 
13 - 17.10.17 - 15:11
тестирование и исправление в конфигураторе
   X Leshiy
 
14 - 17.10.17 - 15:12
(12) Тааак. А как ты чистил кэш?
   Sanr231
 
15 - 17.10.17 - 15:25
Тестирование  и  исправление запускал.

C:\Users\1\AppData\Roaming\1C\1Cv82
C:\Users\1\AppData\Local\1C\1Cv82
Из них грохнул папки с длинными названиями
Еще пробовал через \ClearCache и тонкий клиент
   Sanr231
 
16 - 17.10.17 - 15:56
Выгрузил - загрузил. Все равно так-же.
   Heckfy
 
17 - 17.10.17 - 16:33
Пройдись отладчиком, что у тебя в функцию передается? ИМХО, неопределено. И проблема не на самом деле не здесь, а при создании счета.
   Sanr231
 
18 - 17.10.17 - 16:40
{ОбщийМодуль.РегламентныеЗаданияСервер.Модуль(838)}: Ошибка при вызове метода контекста (НайтиПоУникальномуИдентификатору)
        РегламентноеЗадание = РегламентныеЗадания.НайтиПоУникальномуИдентификатору(Идентификатор);
по причине:
Несоответствие типов (параметр номер '1')

Это в отладчике
   Sanr231
 
19 - 17.10.17 - 16:43
Как посмотреть, что в функцию передается?
   Sanr231
 
20 - 17.10.17 - 16:57
Проблема была в расположении информационной базы. Перенес в корень другого диска. Все завелось))))
   h-sp
 
21 - 17.10.17 - 17:01
(20) это значит кэш. про кэш наврал.
   mr_K
 
22 - 17.10.17 - 17:02
Как говАривала Алиса "все чудесатее и чудесатее")
   Heckfy
 
23 - 17.10.17 - 17:12
(21) Не обязательно. Скорее всего на клиенте почистил. :)



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует