Вход | Регистрация

1С:Предприятие ::

Метки: 

Выбор элемента подчиненного справочника

Я
   AliAksA
 
16.10.17 - 10:57
Привет всем !
версия 8.2, обычное приложение

При попытке выбора из поля формы элемента основного справочника элемента подчиненного справочника при нажатии Ентера происходит не выбор а открытие формы элемента подчиненного справочника.

Причина: вызов подчиненного справочника производится через процедуру:

Процедура УдостоверениеНачалоВыбора(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    Если Ссылка.Пустая() Тогда ЭтотОбъект.Записать(); КонецЕсли;
    ЗначениеОтбора = Новый Структура("Владелец", Ссылка);
    ПараметрыФормы = Новый Структура("Отбор", ЗначениеОтбора);
    ОткрытьФорму("Справочник.ФизЛицаУдостоверы.ФормаСписка", ПараметрыФормы);
    
КонецПроцедуры// УдостоверениеНачалоВыбора()


в форме списка подчиненного справочника:

Процедура ПриОткрытии()
    
    ТекОтбор = СправочникСписок.Отбор.Получить(0);
    Если ТекОтбор.Значение.Пустая() Тогда
        ЭтаФорма.Заголовок = " Список удостоверений физических лиц ";
        ЭлементыФормы.СправочникСписок.Колонки.Владелец.Видимость = Истина;
    Иначе 
        ЭтаФорма.Заголовок = " Удостоверения :  " + ТекОтбор.Значение;
        ЭлементыФормы.СправочникСписок.Колонки.Владелец.Видимость = Ложь;
        ЭлементыФормы.СправочникСписок.НастройкаОтбора.Владелец.Доступность = Ложь;
    КонецЕсли;
    
    СправочникСписок.Порядок.Установить("Дата Возр");
    
КонецПроцедуры// ПриОткрытии()


Подскажите, плиз, как обойти эту хрень: чтобы при нажатии Ентера производился выбор элемента из списка а не открытие формы элемента.

Заранее благодарю.
 
  Рекламное место пустует
   Ёпрст
 
1 - 16.10.17 - 11:13
(0) открывать форму для выбора, в рткрытой форме проверять, что если открыта для выбора, то делать выполнитьВыбор
   Ёпрст
 
2 - 16.10.17 - 11:14
точнее, ОповеститьОВыборе
   AliAksA
 
3 - 16.10.17 - 11:15
(1) как проверить, что она открыта для выбора и сделать этот выбор? (я нубасик в 8-ке)
   AliAksA
 
4 - 16.10.17 - 11:15
(2) а вот это уже знакомо)
   AliAksA
 
5 - 16.10.17 - 11:21
хех, вырубил Процедура УдостоверениеНачалоВыбора(Элемент, СтандартнаяОбработка), поставил связь по владельцу - все заработало.
ВСЕМ СПАСИБО, ТЕМА ЗАКРЫТА


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует