Вход | Регистрация

1С:Предприятие ::

Метки: 

Задать цвет ячейки Excel из 1с

Я
   GrVas
 
16.10.17 - 10:15
Была тема, но ответа не нашел в ней.
Как задать цвет фона ячейки в EXCEL

Решил перебрать коды цветов от 1 до 2 000 000, получился файлик
https://www.dropbox.com/s/lt3ey2yfsxm3te1/Цвета%20из%201с.xls?dl=0
Нету в нем много много нужных цветов.
Показалось что чередуются коды от 1 до 65535.
Может кто знает как задать цвет ячейки, например светлосерый или бледно розовый и тд.
 
  Рекламное место пустует
   GrVas
 
1 - 16.10.17 - 10:18
вот часть кода где задается цвет
        ТекЦвет = НачЦвет; 
        Для ТекСтрока=2 по  10000 Цикл
            Состояние(ТекЦвет);
            Для кол = 1 по 200 Цикл
            ТекЦвет= ТекЦвет+1;
            Лист.Cells(ТекСтрока, кол).Value =ТекЦвет;
            Попытка 
              Лист.Cells(ТекСтрока, кол).Interior.Color = ТекЦвет;
            Исключение
               Продолжить;
            КонецПопытки;
         КонецЦикла        
            
        КонецЦикла;
   GrVas
 
2 - 16.10.17 - 10:32
Надо попробовать заполнить с шагом не 1 а 10, тк соседние 64 ячейки обычно имеют один цвет.
Получится перебор 20 000 000 цветов
   НЕА123
 
3 - 16.10.17 - 10:34
без мозгунства.
макрос в экселе запиши и посмотри, что там.
   VladZ
 
4 - 16.10.17 - 10:39
(0) Не понял. Что в итоге нужно получить?

Если не знаешь, как работать с цветом в Эксель: http://odinesnik.su/osnovnye_metody_raboty_s_excel_iz_1s/
   GrVas
 
5 - 16.10.17 - 10:41
Sub Макрос1()
'
' Макрос1 Макрос
'

'
    Range("C2").Select
    ActiveCell.FormulaR1C1 = "1"
    Range("C3").Select
    With Selection.Interior
        .Pattern = xlSolid
        .PatternColorIndex = xlAutomatic
        .Color = 16185076
        .TintAndShade = 0
        .PatternTintAndShade = 0
    End With
    Range("D3").Select
    ActiveCell.FormulaR1C1 = "2"
    Range("E7").Select
End Sub
   GrVas
 
6 - 16.10.17 - 10:46
(3) в экселе 2003  не нашел как задать любой цвет не только из заранее заданного цвета
   Гипервизор
 
7 - 16.10.17 - 10:51
(0)
Ячейка.Interior.Color = ПредставлениеЦветаЭксель(R,G,B);
Функция ПредставлениеЦветаЭксель(R,G,B)
   Возврат R*(Pow(256,0))+G*(Pow(256,1))+B*(Pow(256,2));
КонецФункции
   GrVas
 
8 - 16.10.17 - 10:56
(7) спасибо
сейчас попробую
   GrVas
 
9 - 16.10.17 - 13:09
В Excel 2003 в цветами проблема.
Есть определенный перечень цветов, его можно заполнить разными цветами, и потом из этого набора только можно разукрасить ячейки по коду ячейки :(
Если пере разукрасить предопределенные цвета , то и в таблице ячейки изменят цвет.
В настройках не нашел как непосредственно использовать цвета из полной палитры.
Может кто знает?


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует