Вход | Регистрация


Управляемые формы, немодальный выбор в списке значений

Управляемые формы, немодальный выбор в списке значений
Я
   ildary
 
16.10.17 - 08:36
Уважаемые специалисты, подскажите пожалуйста, почему мой код прекрасно работает, если вызывается из команды формы, но не работает, будучи вызванным из ПриОткрытии()? Выбор из списка значений не появляется на экране:

&НаКлиенте
Процедура ПолучитьКартыПартнера()
    
    Партнер            = ОбъектыНазначения.Получить( 0 ).Значение;
    КартыЛояльности = КартыПартнера( Партнер );
    Если КартыЛояльности.Количество() = 1 Тогда
        ОткрытьКартыЛояльности( КартыЛояльности[0] );
        Возврат;
    КонецЕсли;
    
    СписокКарт = Новый СписокЗначений;
    СписокКарт.ЗагрузитьЗначения( КартыЛояльности );
    
    ОповещениеПослеВыбораЭлемента = Новый ОписаниеОповещения( "ПолучитьКартыПартнераВыбораСписка", ЭтаФорма );
    СписокКарт.ПоказатьВыборЭлемента( ОповещениеПослеВыбораЭлемента,  "Выберите карту" );                
    
КонецПроцедуры

&НаКлиенте
Процедура ПолучитьКартыПартнераВыбораСписка( КартаЛояльности, Параметры ) Экспорт
    
    Если КартаЛояльности = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    ОткрытьКартыЛояльности( КартаЛояльности.Значение );
    
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПолучитьКартыПартнера();
КонецПроцедуры
 
 
   Тихий омут
 
1 - 16.10.17 - 08:41
Процедура ПриОткрытии(Отказ)
    ПодключитьОбработчикОжидания("ПолучитьКартыПартнера",0.01,Истина);
КонецПроцедуры
   ildary
 
2 - 16.10.17 - 08:42
(1) Спасибо за помощь! Я понял где я неправ.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует