Вход | Регистрация

1С:Предприятие ::

Метки: 

УФ Ошибка "Неизвестный идентификатор формы"

Я
   irina_pi
 
13.10.17 - 22:25
При открытии формы объекта Задача должна открываться форма объекта Бизнес-процессы.
В модуле менеждера Задачи
Процедура ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма,
    ДополнительнаяИнформация, СтандартнаяОбработка)
    Если ВидФормы = "ФормаОбъекта" И Параметры.Свойство("Ключ")Тогда
        ЗадачаСсылка = Параметры.Ключ;
        ЗадачаОбъект=ЗадачаСсылка.ПолучитьОбъект();
        Если ЗадачаОбъект.ТочкаМаршрута=БизнесПроцессы.СогласованиеНаряда.ТочкиМаршрута.СогласованиеСпециалистами тогда
            ВыбраннаяФорма="БизнесПроцессы.СогласованиеНаряда.Форма.ФормаСпециалиста";             
            Параметры.Ключ=ЗадачаОбъект.БизнесПроцесс;             
            СтандартнаяОбработка=Ложь;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры  


При попытке отрыть задачу выходит ошибка "Неизвестный идентификатор формы" и форма не открывается.
 
 
   Филиал-msk
 
1 - 13.10.17 - 22:39
ЗадачаМенеджер.<Имя задачи> (TaskManager.<Имя задачи>)
ОбработкаПолученияФормы (FormGetProcessing)

Синтаксис:
ОбработкаПолученияФормы(<ВидФормы>, <Параметры>, <ВыбраннаяФорма>, <ДополнительнаяИнформация>, <СтандартнаяОбработка>) 

Параметры:

<ВидФормы>
Тип: Строка. 
Имя стандартной формы. 

<Параметры>
Тип: Структура. 
Параметры формы. 

<ВыбраннаяФорма>
Содержит имя открываемой формы или объект метаданных Форма.
Если значение параметра изменено, то будет осуществлен поиск формы в пределах объекта, для которого открывается форма. 
...


Читать последние семь слов до просветления
   irina_pi
 
2 - 13.10.17 - 22:54
Прочла, не просветлилась.

Пример из УТ 11


Процедура ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка)
    
    Если ВидФормы = "ФормаОбъекта" И Параметры.Свойство("Ключ") Тогда
        ПараметрыФормы = БизнесПроцессыИЗадачиВызовСервера.ФормаВыполненияЗадачи(Параметры.Ключ);
        ИмяФормыЗадачи = "";
        Результат = ПараметрыФормы.Свойство("ИмяФормы", ИмяФормыЗадачи);
        Если Результат Тогда
            ВыбраннаяФорма = ИмяФормыЗадачи;
            СтандартнаяОбработка = Ложь;
        КонецЕсли; 
    КонецЕсли;

КонецПроцедуры


ИмяФормыЗадачи    "БизнесПроцесс.ТиповаяПродажа.Форма.Документы"    Строка
   Филиал-msk
 
3 - 13.10.17 - 23:00
Хе
   Филиал-msk
 
4 - 13.10.17 - 23:01
Ну тогда найди очень важное отличие в значении ИмяФормыЗадачи и твоей переменной (:
   Филиал-msk
 
5 - 13.10.17 - 23:01
Примерно в 14 знаке


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует