Вход | Регистрация

1С:Предприятие ::

Метки: 

Внешняя обработка - открытие документа по ссылке из таблицы значений

Я
   Алекс25501
 
13.10.17 - 15:14
Привет!

Сделал внешнюю обработку - обычное формы
Запрос выгружается в ТаблицуЗначений, далее ТаблицаЗначений загружается в форму обработки
 

Результат = Запрос.Выполнить().Выгрузить();
ЭлементыФормы.ТЗ.Значение = Результат;
ЭлементыФормы.ТЗ.СоздатьКолонки();

В ТЗ есть поля с типом ссылка! как мне в обработке сделать так что бы сразу открывались нужные мне документы щелкая на нужные значения в строке ТЗ
 
  Рекламное место пустует
   Numerus Mikhail
 
1 - 13.10.17 - 15:17
(0) Событие "Выбор"
   Алекс25501
 
2 - 13.10.17 - 15:21
Процедура ТЗВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    
    А = 0;
    
КонецПроцедуры

Зашел в отладчик - вижу ссылку ))) а как открыть ???????????
   Алекс25501
 
3 - 13.10.17 - 15:23
В ВыбраннаяСтрока - есть ссылка то что мне нужно))) а как открыть ?
   trooba
 
4 - 13.10.17 - 15:23
(2) ПолучитьФорму()
   mehfk
 
5 - 13.10.17 - 15:23
ОткрытьЗначение
   trooba
 
6 - 13.10.17 - 15:23
(2) Открыть()
   Алекс25501
 
7 - 13.10.17 - 15:30
Процедура ТЗВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    
    ОткрытьЗначение(ВыбраннаяСтрока.СсылкаЗаказ);
         
КонецПроцедуры

Так работает!
НО если у меня к примеру в строке ТЗ несколько разных документов ! как мне открыть ? тогда только необходмый документ ?
   trooba
 
8 - 13.10.17 - 15:33
(7) 4 и 6 читал?
   aleksonic
 
9 - 13.10.17 - 15:35
Консоль запросов посмотри
   trooba
 
10 - 13.10.17 - 15:35
(7) ДокументСсылка.<Имя документа>.ПолучитьФорму (DocumentRef.<Имя документа>.GetForm)
ДокументСсылка.<Имя документа> (DocumentRef.<Имя документа>)
ПолучитьФорму (GetForm)
Синтаксис:

ПолучитьФорму(<Форма>, <Владелец>, <КлючУникальности>)
Параметры:

<Форма> (необязательный)

Тип: Строка; ОбъектМетаданных: Форма .
Имя формы, как оно задано в конфигураторе, или объект описания метаданного требуемой формы. Если параметр не указан, то используется основная форма, заданная в конфигураторе.
<Владелец> (необязательный)

Тип: Форма; Элемент управления. 
Объект, который будет являться владельцем открываемой формы. 
<КлючУникальности> (необязательный)

Тип: Произвольный.
В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм.
При поиске учитываются значения свойств открытых форм соответствующим значениям параметров метода. Если найдена открытая форма (по совпадению всех параметров), то она будет возвращена вместо новой формы.
Если из некой формы (один и тот же владелец) требуется открывать новые экземпляры другой формы, то при каждом вызове метода значение данного параметра должно быть уникально (в рамках соответствующих значений свойств открытых форм).
Значение параметра присваивается свойству открываемой формы КлючУникальности.
Следует учитывать, что при получении формы из "объекта" система получает форму для конкретного экземпляра объекта с учетом совокупности переданных параметров, в то время как для "ссылки" всегда существует только один объект в базе данных и форма получается одна (для одинаковой совокупности параметров).
Возвращаемое значение:

Тип: Форма; Неопределено.
Неопределено - если в обработчике ПриСозданииНаСервере установлен признак отказа от создания формы.
Описание:

Получает форму документа.

Доступность:

Толстый клиент.
Пример:

ВыбДокумент.ПолучитьФорму().Открыть();
 

--------------------------------------------------------------------------------

     Методическая информация
 
  Рекламное место пустует
   Алекс25501
 
11 - 13.10.17 - 15:40
Нифига
   Алекс25501
 
12 - 13.10.17 - 15:42
Это работает !, но мне нужно открывать каждое значение !
если ссылка - то открывать документ, если справочник то справочник, если другой документ то другой документ

Процедура ТЗВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    
    ОткрытьЗначение(ВыбраннаяСтрока.СсылкаЗаказ);
         
КонецПроцедуры
   youalex
 
13 - 13.10.17 - 15:43
(12) Видимо, вместо ВыбраннаяСтрока.СсылкаЗаказ
нужно написать ВыбраннаяСтрока[ИмяКолонки]
ИмяКолонки - можно получить через параметр Колонка, например
   Алекс25501
 
14 - 13.10.17 - 15:54
непонятно
   Алекс25501
 
15 - 13.10.17 - 15:54
извините)
   Алекс25501
 
16 - 13.10.17 - 15:55
Работает только это 
Процедура ТЗВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    
    ОткрытьЗначение(ВыбраннаяСтрока.СсылкаЗаказ);
         
КонецПроцедуры
   Михаил Козлов
 
17 - 13.10.17 - 16:05
Получить значение в выбранной колонке (скорее всего ВыбраннаяСтрока[Колонка], ОткрытьЗначение(...).
Не забыть СтандартнаяОбработка = ЛОЖЬ;
   youalex
 
18 - 13.10.17 - 16:10
(14) отладчиком умеешь пользоваться?
Посмотри что у тебя в параметре Колонка


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует