Вход | Регистрация


1С:Предприятие ::

Метки: 

УПП. 8.3.При установке периода (ДокументСписок) выводит только проведенные документы

Я
   leonardovich
 
13.10.17 - 15:09
Всё перепробовал
1. ЭлементОтбора = Список.Отбор.Дата;
.....
2. НастройкаПериода = ЭлементыФормы.Список.СтандартныйПериод;
.....

Пробовал также комбинации обеих вариантов. 
Разумеется, Список.Обновить();
Ничего не помогает, жуть какая-то.
После установки периода программно выводит только проведенные документы.
Далее ни изменения отборов, ни обновления списка, ничего не помогает. Показывает все только после того, как из командной панели стандартной командой установить период.
 
  Рекламное место пустует
   Ёпрст
 
1 - 13.10.17 - 15:30
(0) УФ ?
   leonardovich
 
2 - 13.10.17 - 15:35
Сорри, забыл указать УПП 1.3 (1.3.77.2); 1С:Предприятие 8.3 (8.3.10.2580)
   leonardovich
 
3 - 13.10.17 - 15:35
Нет, обычная форма
   Serg_1960
 
4 - 13.10.17 - 17:08
ЭлементыФормы.Список.НастройкаОтбора.Очистить();
   Serg_1960
 
5 - 13.10.17 - 17:09
ДокументСписок.Отбор.Сбросить();
   leonardovich
 
6 - 16.10.17 - 08:05
Очистить(); Сбросить() разумеется пробовал.
   leonardovich
 
7 - 16.10.17 - 08:40
Перед и после программной установки периода, отбор пуст, применен только интервал дат. Но отображаются исключительно проведенные документы
   leonardovich
 
8 - 16.10.17 - 09:45
Даже при ручном изменении отбора из командной панели, ничего не меняется. Кнопка "Обновить" также не реагирует. Только при изменении периода из панели, начинают отображаться все документы.
   h-sp
 
9 - 16.10.17 - 10:03
(0) в стандартном отборе по периоду снимите нахрен галку "Использовать эту настройку при открытии". Потом радуйтесь.
   leonardovich
 
10 - 16.10.17 - 10:55
Тогда при открытии он будет вываливать весь список документов за период без ограничения.
 
  Рекламное место пустует
   h-sp
 
11 - 16.10.17 - 10:58
(10) вы не поняли. вам надо стереть то, что про проведение там затесалось. А потом уже опять установить эту галку, но свою.
   leonardovich
 
12 - 16.10.17 - 11:10
Список.Отбор.Очистить(); Список.Отбор.Сбросить() - не помогает. Также в отладчике видно, что отборы пустые, ничего нет
   leonardovich
 
13 - 16.10.17 - 11:14
Также удалял и заново создавал элемент Список
   leonardovich
 
14 - 17.10.17 - 08:59
Вообще шаман с бубном. Вот что обнаружил.
Устанавливаешь период
ЭлементОтбора.ЗначениеС  = 12.10.2017 00:00:00
ЭлементОтбора.ЗначениеПо = 13.10.2017 23:59:59

Показывает за 12 только проведенные, за 13 все документы.
Если ставить

ЭлементОтбора.ЗначениеС  = 12.10.2017 00:00:00
ЭлементОтбора.ЗначениеПо = 12.10.2017 23:59:59

То показывает за 12 только проведенные.
Никаких больше отборов не установлено, это 100%
   1dvd
 
15 - 17.10.17 - 09:00
покажика скриншот
   _Дайвер_
 
16 - 17.10.17 - 09:12
(14) У тебя за 12 число документы то не проведенные есть? xD
   leonardovich
 
17 - 17.10.17 - 09:30
Есть конечно
   leonardovich
 
18 - 17.10.17 - 09:31
(15) Что даст скриншот? Там понять сложно
   leonardovich
 
19 - 17.10.17 - 09:33
Детально просмотрел весь исходник обработки (не мое), ничего вообще нет. Период, Отбор, Проведен и вообще ничего необычного
   catena
 
20 - 17.10.17 - 09:36
А что за документы-то? Типовые или дописанные? Может там Дата переопределена.
   Ёпрст
 
21 - 17.10.17 - 09:40
(19) это уже обработка ?
продолжайте наблюдение
   leonardovich
 
22 - 17.10.17 - 09:56
Да, в обработке ДокументСписок
   leonardovich
 
23 - 17.10.17 - 09:56
(20) Дописанные
   catena
 
24 - 17.10.17 - 10:38
(23) И что там в дате, если запросом вытащить за 12-13 число?
   leonardovich
 
25 - 17.10.17 - 11:00
Запросом всё нормально, стандартно. Проблема в элементе формы ДокументСписок. Теперь уже просто любопытно, что за фигня
   catena
 
26 - 17.10.17 - 11:02
(25)Повторить можешь в пустой обработке?
   catena
 
27 - 17.10.17 - 11:02
Без лишнего кода, только установка отбора.
   leonardovich
 
28 - 17.10.17 - 11:14
(27) Хорошая мысль, сам реально не догадался.
Попробовал и.... ТОЖЕ САМОЕ, обалдеть
   leonardovich
 
29 - 17.10.17 - 11:14
Вот код, больше ничего нет

Перем ДатаРейсов;

Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    Если ВвестиДату(ДатаРейсов,,ЧастиДаты.Дата) Тогда
        УстановитьИнтервал();
    КонецЕсли;
    
КонецПроцедуры

Процедура УстановитьИнтервал()
    
    ЭлементОтбора = СписокРейсов.Отбор.Дата;
    ЭлементОтбора.Использование = Ложь;
    ЭлементОтбора.ЗначениеС        = НачалоДня(ДатаРейсов);
    ЭлементОтбора.ЗначениеПо    = КонецДня(ДатаРейсов);
    ЭлементОтбора.ВидСравнения    = ВидСравнения.Интервал;
    ЭлементОтбора.Использование = Истина;
    
КонецПроцедуры

Процедура ПриОткрытии()
    
    ДатаРейсов = ТекущаяДата();
    УстановитьИнтервал();
    
КонецПроцедуры
   leonardovich
 
30 - 17.10.17 - 11:17
На форме 2 элемента ДокументСписок и КоманджнаяПанель, привязанная к источнику (ДокументСписок)
   leonardovich
 
31 - 17.10.17 - 11:30
Тьфу, блин, нашел

ВидСравнения.ИнтервалВключаяГраницы
   leonardovich
 
32 - 17.10.17 - 11:31
А почему тогда показывало только проведенные и помеченные на удаление...........
   Serg_1960
 
33 - 17.10.17 - 12:09
(29) Я по прежнему не вижу чтобы очищался сам отбор перед установкой новых значений.

"Чудес не бывает"(с)

В процедуре СписокПриПолученииДанных() - точка останова.
В табло - "ЭлементыФормы.Список.Значение.Отбор.Проведен".
Смотреть значение и "Использование".
 
 
   leonardovich
 
34 - 17.10.17 - 12:25
Всё пусто - трассировкой смотрел. Тем более обработка пустая.
   catena
 
35 - 17.10.17 - 12:45
(32)А непроведенные документы случайно не сидят все в начале дня?
   timeforlive
 
36 - 17.10.17 - 14:03
Используй запрос для получения данных.
   Шаман
 
37 - 17.10.17 - 14:09
что то у вас со сдвигом границы итогов . или с настройкой прав к самим докуменатм
   leonardovich
 
38 - 17.10.17 - 15:28
(33)
Отбор.Проведен.Использование = Ложь
У всех отборов Использование = Ложь, кроме даты
   leonardovich
 
39 - 17.10.17 - 15:30
(37) Полные права
   leonardovich
 
40 - 17.10.17 - 15:31
(36) В запросе всё нормально.
Проблему-то решил тут , уже просто любопытство (31)



Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует