Вход | Регистрация


1С:Предприятие ::

Метки: 

Не могу сделать подчеркивание текста в WORD

Я
   Карамелька
 
13.10.17 - 13:32
Нужно подчеркнуть определенный текст в WORD.
Делаю как в v8: Изменение формата текста WORD
    Документ.Content.Find.Text=СтрокаДляПодчеркивания;
    Документ.Content.Find.Execute();
    
    Если Документ.Content.Find.Found=true тогда
        Selection = Документ.Content.Sentences.First;
        Selection.Font.Underline = 1;        
    КонецЕсли;
И ничего не происходит.
При этом если написать 
Документ.Content.Find.Execute(СтрокаДляПодчеркивания, , , , , , , , , "****************", Тип);
То все найдется и заменится на "****************"
 
 
   elCust
 
1 - 13.10.17 - 13:33
(0) Что говорит запись макроса?
   Карамелька
 
2 - 13.10.17 - 13:37
кто?
   aka AMIGO
 
3 - 13.10.17 - 13:40
Не кто, а что

В Ворде доступен запуск макроса, выполнить каки-то действия, а после остановки - подсмотреть нужные команды
Ну и подставить их в твой код
   aka AMIGO
 
4 - 13.10.17 - 13:41
запустить макрос, выполнить нужные действия (подчеркнуть текст), остановить макрос - подсмотреть нужные команды
   Карамелька
 
5 - 13.10.17 - 14:51
Selection.Font.UnderlineColor = wdColorAutomatic
    Selection.Font.Underline = wdUnderlineNone
    Selection.Font.UnderlineColor = wdColorAutomatic
    Selection.Font.Underline = wdUnderlineNone
   PiotrLoginov
 
6 - 13.10.17 - 14:58
(0) Известно ли, для какой версии Word'а было решение в той ветке?

Так что, с макросами Вы не дружили никогда?
   Карамелька
 
7 - 13.10.17 - 15:01
(6) С макросами работать и дружить не приходилось
   Масянька
 
8 - 13.10.17 - 15:18
(7) А можно спросить: вы уверены, что он находит "СтрокаДляПодчеркивания"?
   Карамелька
 
9 - 13.10.17 - 15:32
(8) Документ.Content.Find.Execute(СтрокаДляПодчеркивания, , , , , , , , , "****************", Тип); 
так находит и заменяет на *****
   Масянька
 
10 - 13.10.17 - 15:35
(9) А не работает (насколько я поняла):
   Если Документ.Content.Find.Found=true тогда
        Selection = Документ.Content.Sentences.First;
        Selection.Font.Underline = 1;        
    КонецЕсли;

А зачем такие сложности? Нельзя сразу сделать подчеркнутым?
 
 Рекламное место пустует
   Карамелька
 
11 - 13.10.17 - 15:37
Мне нужно подчеркнуть "мужской - 1" или "женский - 2". Изначально неизвестно какой будет
   Карамелька
 
12 - 13.10.17 - 15:38
Да. Мы не заходим в условие, так как там ложь
   Масянька
 
13 - 13.10.17 - 15:38
(11) А когда становится известно?
(12) Ну вот.
   Карамелька
 
14 - 13.10.17 - 15:42
Изначально в печатной форме пол не подчеркнут. Когда мы выводим печ форму по определенному сотруднику, то заполняем ее и подчеркиваем пол.
   Масянька
 
15 - 13.10.17 - 15:44
(14) Ничего не понятно...
Что в макете? Ну, то, что нужно подчеркнуть.
   Карамелька
 
17 - 13.10.17 - 15:51
нужно подчеркнуть "мужской - 1" или "женский - 2"
   Карамелька
 
18 - 13.10.17 - 15:57
В общем подчеркнуть так и не удалось, но задача решена
   Филиал-msk
 
19 - 13.10.17 - 16:00
(18) Сделала два макета - мужской и женский? )
   Масянька
 
20 - 13.10.17 - 16:01
(18) У меня шаблон (word) договора - http://pastenow.ru/6eb8cc7b4d2368f502a59927214bff50.
Все, что в [] подлежит замене.
А как у вас?
   Карамелька
 
21 - 13.10.17 - 16:04
(19) плохой вариант
   Карамелька
 
22 - 13.10.17 - 16:07
У меня теперь три поля [пол1][пол2][пол3]
пол2 с подчеркиванием по умолчанию. 
Если пол мужской, то пол1="" пол2="мужской - 1" пол3="женский - 2"
Если пол женский, то пол1="мужской - 1" пол2="женский - 2" пол3=""
   Масянька
 
23 - 13.10.17 - 16:08
(22) А смысл в таких извращениях? Чем отличаются [пол1][пол2][пол3]?
   Карамелька
 
24 - 13.10.17 - 16:12
Смысл в том что пол2 в макете подчеркнут изначально. Другим способом подчеркнуть не получается
   Масянька
 
25 - 13.10.17 - 16:14
(24) Так... Пойдем длинным путем...
А когда не нужно подчеркивать пол?
   Fish
 
26 - 13.10.17 - 16:16
(22) А третий пол это какой? :))
   Карамелька
 
27 - 13.10.17 - 16:35
(25)Пол нужно подчеркивать всегда, только иногда мужской, иногда женский.
(26) третий пол пустой
   Масянька
 
28 - 13.10.17 - 16:43
(27) Замечательно.
Итак, где определяется пол?
   Карамелька
 
29 - 13.10.17 - 16:56
6. Пол (подчеркнуть):    [шполМ] [шполЖ] 
это строка в шаблоне

    Документ.Content.Find.Text="[шполМ]";
    Документ.Content.Find.Execute();
    
    Если Документ.Content.Find.Found=true тогда
        Сообщить("нашли ");
        Selection = Документ.Content.Sentences.First;
        Selection.Font.Underline = 1;        
        //Text=Документ.Content.Selection();

        //Text.Font.Underline=1;

    Иначе
        Сообщить(" не нашли ");
    КонецЕсли;
    
    Документ.Content.Find.Text="[шполЖ]";
    Документ.Content.Find.Execute();
    
    Если Документ.Content.Find.Found=true тогда
        Сообщить("нашли ");
        Selection = Документ.Content.Sentences.First;
        Selection.Font.Underline = 1;        
        //Text=Документ.Content.Selection();

        //Text.Font.Underline=1;

    Иначе
        Сообщить(" не нашли ");
    КонецЕсли;

в итоге ничего не нашли
   ptiz
 
30 - 13.10.17 - 17:11
Правильная анкета должна выглядеть так:
https://yadi.sk/i/5eCuZNx23NjAqn
   Масянька
 
31 - 13.10.17 - 17:14
(29) Эта анкета кем-то утверждена?
   Масянька
 
32 - 13.10.17 - 17:15
(30) Во, ..., переводчики...
   Брудвар
 
33 - 13.10.17 - 18:04
(30) Анкена на программиста
 
 



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует