Вход | Регистрация

1С:Предприятие ::

Метки: 

Не удается прочитать файл.

Я
   prilforreal
 
12.10.17 - 15:20
Доброго дня! 1с8.3 конфа самописная. Не удается вывести текст из файла тхт в поле ввода, вылетает
Не удалось прочитать файл: {Обработка.ОтправкаПисем.Форма.Форма1.Форма(154)}: Значение не является значением объектного типа (Прочитать)

Ума не хватает самому дойти до причины, подскажите пожалуста

Процедура ЗагрузитьТекстИзФайла() 
    
   ДТФ = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
   ДТФ.Заголовок = "Выберите файл (*.TXT/.RTF.HTML*)";
   ДТФ.Фильтр = "Текстовый Документ (*.txt;*.doc;*.rtf)|*.txt;*.doc;*.rtf|";
   ДТФ.ПредварительныйПросмотр=Ложь;
   ДТФ.ПроверятьСуществованиеФайла=Истина;
   Если ДТФ.Выбрать() Тогда
       
   ПутьКТфайлу = ДТФ.ПолноеИмяФайла;
        КонецЕсли;
        Попытка
   ТекстПисьма.Прочитать(ПутьКТФайлу);
        Исключение
   Сообщить("Не удалось прочитать файл: " + ОписаниеОшибки(),СтатусСообщения.ОченьВажное);
   Сообщить(ДТФ.ПолноеИмяФайла,СтатусСообщения.ОченьВажное);
        Возврат;
        КонецПопытки;    
        
    КонецПроцедуры    

Процедура ОтправитьПисьма()
 
 
   Numerus Mikhail
 
1 - 12.10.17 - 15:21
(0) Что такое текст письма?
   prilforreal
 
2 - 12.10.17 - 15:24
(1) Имя поля ввода куда текст выгружаться должен
   Филиал-msk
 
3 - 12.10.17 - 15:49
(2) А почему ты думаешь, что оно так умеет?
   h-sp
 
4 - 12.10.17 - 15:53
(2) поле ввода читает файлы? Разве?
   prilforreal
 
5 - 12.10.17 - 15:56
(3) Метод же есть такой
   prilforreal
 
6 - 12.10.17 - 15:58
(4) А что читает? Или лучше как поле ввода научить?
   prilforreal
 
7 - 12.10.17 - 15:59
(4) В семерке читало
   prilforreal
 
8 - 12.10.17 - 16:00
(7) Внешней компонентой....
   prilforreal
 
9 - 12.10.17 - 16:03
(3) ТекстовыйДокумент (TextDocument)
Прочитать (Read)
Вариант синтаксиса: Из файла

Синтаксис:

Прочитать(<ИмяФайла>, <ТипФайла>, <РазделительСтрок>)
Параметры:

<ИмяФайла> (обязательный)

Тип: Строка.
Имя текстового файла. 
<ТипФайла> (необязательный)
   h-sp
 
10 - 12.10.17 - 16:06
(9) ну и читайте через текстовый документ. Зачем вы через поле ввода читаете?
 
 Рекламное место пустует
   prilforreal
 
11 - 12.10.17 - 16:11
(10) Чтобы текст из файла залетел в поле ввода, можно было его редактировать, а после отправлять в письме
   prilforreal
 
12 - 12.10.17 - 16:30
Скажите кто нибудь, возможно ли из текстового файла записывать текст в поле ввода?
   prilforreal
 
13 - 13.10.17 - 09:46
Кое как с горем пополам смог файл прочитать и вытащить в служебные сообщения, но все равно перенести данные в поле ввода ума не хватает... пока только текСтроку... устал уже на месте топтаться, подскажите народ как все строки вывести?

Текст = Новый ТекстовыйДокумент;
    Текст.Прочитать(ПутьКТФайлу);
    КоличествоСтрок = Текст.КоличествоСтрок();
Для Счетчик = 1 по КоличествоСтрок Цикл
    ТекСтрока = Текст.ПолучитьСтроку(Счетчик);
    Сообщить(ТекСтрока);
    ТекстПисьма = ТекСтрока;
    КонецЦикла;
   Elf_80_lvl
 
14 - 13.10.17 - 10:12
В какое поле ввода хотите перенести значение?
   youalex
 
15 - 13.10.17 - 10:21
(12) тебе похоже не поле ввода нужно, а поле текстового документа.
   youalex
 
16 - 13.10.17 - 10:22
Ну или у поля ввода установить свойства многострочный режим и расширенное редактирование
   prilforreal
 
17 - 13.10.17 - 10:53
Спасибо всем участникам) 
ТекстПисьма = Текст.ПолучитьТекст();
   Филиал-msk
 
18 - 13.10.17 - 10:54
Ожидаем вторую серию - как записать это все обратно (:


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует