Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

РегистрСведенийСписок в табличном поле отобразить срез последних

РегистрСведенийСписок в табличном поле отобразить срез последних
Я
   laby1
 
11.10.17 - 19:06
Здравствуйте.

Подскажите...

Я перенес из формы РС в другой справочник табличное поле.
У меня появился реквизит в форме мой РС типа РегистрСведенийСписок.***  


Программно делаю фильтр:

Процедура СправочникСписокПриАктивизацииСтроки(Элемент)
    
    РС.Отбор.Карта.Установить(Элемент.ТекущиеДанные.Ссылка);
    
КонецПроцедуры

Всё хорошо. Но как мне взять срез последних. А не весь регистр? Только запросом формировать и помещать в табл поле?
Работает.
 
 
   Филиал-msk
 
1 - 11.10.17 - 19:30
Использовать...

Динамический список. В управляемой форме. Для этого разрешить.

Использование управляемых форм в обычном приложении.
   reset2
 
2 - 11.10.17 - 19:31
Ничего не понял. Управляемые формы? Может так?
Реквизит с типом "ДинамическийСписок", и основной таблицей, "РегистрСведений.*".
https://ibb.co/f51Hiw
   laby1
 
3 - 11.10.17 - 19:49
У меня обычная форма пока.
   youalex
 
4 - 11.10.17 - 20:20
Попробуй ВыбиратьСрез (свойство ТП)
   Chameleon1980
 
5 - 11.10.17 - 20:31
посмотреть, например, ут10. форма элемента номенклатура - закладка цены - не?
   Chameleon1980
 
6 - 11.10.17 - 20:33
(0) а ка вы по-другому хотели?


Процедура КоманднаяПанельЦеныНоменклатурыПеречитатьТекущиеЦены(Кнопка)

    Запрос = Новый Запрос("
    |ВЫБРАТЬ
    |    Цены.ТипЦен КАК ТипЦен,
    |    Цены.Цена КАК Цена,
    |    Цены.СпособРасчетаЦены КАК СпособРасчетаЦены,
    |    Цены.Валюта КАК Валюта,
    |    Цены.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |    Цены.ПроцентСкидкиНаценки КАК ПроцентСкидкиНаценки
    |ИЗ
    |    РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&Дата, ТипЦен В (&ТипыЦен)
    |       И Номенклатура = &Номенклатура И ХарактеристикаНоменклатуры = ЗНАЧЕНИЕ(Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка)
    |    ) КАК Цены
    |");

    Запрос.УстановитьПараметр("Дата", РабочаяДата);
    Запрос.УстановитьПараметр("ТипыЦен", ЦеныНоменклатуры.ВыгрузитьКолонку("ТипЦен"));
    Запрос.УстановитьПараметр("Номенклатура", Ссылка);

    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        СтрокаЦен = ЦеныНоменклатуры.Найти(Выборка.ТипЦен, "ТипЦен");
        ЗаполнитьЗначенияСвойств(СтрокаЦен, Выборка);
    КонецЦикла;

КонецПроцедуры
   Chameleon1980
 
7 - 11.10.17 - 20:33
без дс не обойтись, но у вас ОФ

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует