Вход | Регистрация



1C77 ТИС запрос количество проданного товара

1C77 ТИС запрос количество проданного товара
Я
   geniusbsd
 
11.10.17 - 10:40
День добрый делаю отчет по продажам по группам 

Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |Товар = Регистр.ПартииТоваров.Товар;
    |Фирма = Регистр.ПартииТоваров.Фирма;
    |ОстатокТовара=Регистр.ПартииТоваров.ОстатокТовара;
    |Группировка Товар все; 
       |Функция РасхОстатокТовара=Расход(ОстатокТовара);
    |Функция ПрихОстатокТовара=Приход(ОстатокТовара);
    |"//}}ЗАПРОС

    ; 
    Если ПустоеЗначение(ВыбГруппа)=0 тогда
    ТекстЗапроса = ТекстЗапроса+ " 
         |Условие (Товар в ВыбГруппа);"    ;
    КонецЕсли;
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"

    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
      ПечРасходОстатокТовара=Строка(Запрос.РасхОстатокТовара-Запрос.ПрихОстатокТовара)+ " шт";   
         Если Запрос.Товар.ЭтоГруппа()=1 Тогда
        Таб.ВывестиСекцию("Группа");
        Иначе
        Таб.ВывестиСекцию("Товар");
    КонецЕсли;
    КонецЦикла;
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры

Кол проданого товара не совпадает с количеством который фомирует встроенный отчет по  продажам(В моем отчете в 2 раза больше). Что я делаю не правильно
 
 
   Ёпрст
 
1 - 11.10.17 - 10:44
(0)вот это что ?
ПечРасходОстатокТовара=Строка(Запрос.РасхОстатокТовара-Запрос.ПрихОстатокТовара)+ " шт";
   Builder
 
2 - 11.10.17 - 10:47
(1) Явное преобразование в строку :)
(0) Смотри условия в типовом запросе, там наверняка их побольше.
   geniusbsd
 
3 - 11.10.17 - 10:49
ПечРасходОстатокТовара Это строка в печатной форме
   Ёпрст
 
4 - 11.10.17 - 10:51
(3) Пилять, отнимая расход от Прихода, ты какой смысл  в это вкладываешь ?
   Ёпрст
 
5 - 11.10.17 - 10:51
И что потом с чем сравниваешь ?
   Базис
 
6 - 11.10.17 - 10:52
Разделил Упр и Фин?
   Zypse
 
7 - 11.10.17 - 10:53
1. Типовой отчет по продажам использует регистр "Продажи" ,а не "Партии".  Партии более громоздкий и тормозной регистр
2. Если уж преспичело использовать партии - нужно отсекать по виду операции приходы, перемещения и проч.
   Ёпрст
 
8 - 11.10.17 - 10:53
И если че, типовой отчет считает приход и расход по кодам операций, чтоб не учитывались, например, перемещения со склада на склад и т.д.
   Convert
 
9 - 11.10.17 - 10:53
(0) Регистр партиитоваров содержит не только продажи, но и перемещения, списания и прочие движения.
Возьми регистр Продажи
   Builder
 
10 - 11.10.17 - 10:55
Тут же регистр "партии", на них складов нет. Но всякая фигня типа списания есть.
Да и приход из расхода вычитать - это сильно.
 
 Рекламное место пустует
   VladZ
 
11 - 11.10.17 - 10:56
(0) И не будет совпадать. См. регистр "Продажи"
   VladZ
 
12 - 11.10.17 - 10:56
И еще вопрос: зачем понадобилось что-то писать, когда есть стандартный отчет по продажам?
   Масянька
 
13 - 11.10.17 - 10:57
Извините, что я приперлась, но - чем не устраивает стандартный "Отчет по продажам ТМЦ"?
   Масянька
 
14 - 11.10.17 - 10:57
(12) Не надо красть мои мысли....
   geniusbsd
 
15 - 11.10.17 - 11:03
(4) Эту строку я подсмотрел в типвом отчете
   geniusbsd
 
16 - 11.10.17 - 11:04
(11) Типовый отчет берет из регистра партий
   Ёпрст
 
17 - 11.10.17 - 11:05
(15) в типовом отчете таких строк нет
   Ёпрст
 
18 - 11.10.17 - 11:06
Ибо в типовых, нигде не используется функция Строка
   geniusbsd
 
19 - 11.10.17 - 11:06
(13) (12) В стандартном отчете нет разделения по группам товара, если в множественом фильтре выбрать несколько групп, то все валится в одну кучу
   Ёпрст
 
20 - 11.10.17 - 11:06
ну и такой бред, там не могли написать
   Ёпрст
 
21 - 11.10.17 - 11:07
(19) брехня.
В анализеПродаж всё и так есть
   Масянька
 
22 - 11.10.17 - 11:10
(19) Группа товара - это что?
   geniusbsd
 
23 - 11.10.17 - 11:12
Торговля и склад для украины 7.70.008
   geniusbsd
 
24 - 11.10.17 - 11:14
(22) Это группа в справочнике номенклатуры
   Масянька
 
25 - 11.10.17 - 11:16
(24) Ты хочешь мне сказать, что в стандартном отчете нет выбора группы? Ложь.
   VladZ
 
26 - 11.10.17 - 11:20
ТИС для Украины не видел. В стандартной ТИС продажи проходят по регистру "Продажи". В партиях нужно фильтровать движения по видам. Там могут быть перемещения / списания / продажи и прочее.
   Ёпрст
 
27 - 11.10.17 - 11:20
(25) см (23) - там может быть что угодно
:)
   Масянька
 
28 - 11.10.17 - 11:21
(27) "Москаль мени ни брат" (С) - "За что боролись - на то и напоролись" (С)
   geniusbsd
 
29 - 11.10.17 - 11:24
(25) Там Есть выбор групп, но в печатной форме нет разделения на группы
   Ёпрст
 
30 - 11.10.17 - 11:25
(29) возьми готовый отчет АнализПродаж с российчкой ТиС, переделай текст запроса, наслаждайся
   geniusbsd
 
31 - 11.10.17 - 11:28
Вот сей час ставлю буду смотреть
   Масянька
 
32 - 11.10.17 - 11:29
(29) А "Анализа продаж" нет?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует