Вход | Регистрация


Удалить движения документа с отбором

Удалить движения документа с отбором
Я
   tatoshka0403
 
10.10.17 - 17:47
Суть такова, документ при проведении делает две записи в регистр в одной сумма + в другой сумма -. Хочу удалить только +. Написал код:

Движ1 = Док.ПолучитьОбъект().Движения.РасчетыСКлиентами;
Движ1.Прочитать();
    Для каждого Стр из Движ1 цикл
        Попытка
        Если Стр.Сумма>0 ИЛИ Стр.Сумма=0 тогда
            Стр.Очистить()
        КонецЕсли;
        Исключение
        КонецПопытки;
    КонецЦикла;
Движ1.Записать();


Не работает( Пожалуйста подскажите как это реализовать.
 
 
   YFedor
 
1 - 10.10.17 - 17:48
(0) где этот код выполняется, в обработке?
   tatoshka0403
 
2 - 10.10.17 - 17:48
(1) Да
   tatoshka0403
 
3 - 10.10.17 - 17:49
Движ1.Прочитать();
Движ1.Очистить();
Движ1.Записать();

Вот так отчищает все, но мне это не надо
   YFedor
 
4 - 10.10.17 - 17:52
(2) При перепроведении что будешь делать?
   tatoshka0403
 
5 - 10.10.17 - 17:54
(4) их запрещено перепроводить)
   _Дайвер_
 
6 - 10.10.17 - 17:57
(5) Пиши запрос, делай соединение с регистром, и удаляй
   craxx
 
7 - 10.10.17 - 17:58
(6) не обязательно, можно в цикле по записям из набора почикать согласно условиям.
   h-sp
 
8 - 10.10.17 - 17:58
(5) Стр.Очистить() что это такое?

надо  Движ1.Удалить(Стр);
   azernot
 
9 - 10.10.17 - 18:01
Движ1 = РегистрыНакопления.РасчетыСКлиентами.СоздатьНаборЗаписей();
Движ.Отбор.Регистратор.Установить(Док.Ссылка);

Движ1.Прочитать();
Для каждого Стр из Движ1 цикл
  Если Стр.Сумма>0 ИЛИ Стр.Сумма=0 тогда
      Движ1.Удалить(Стр)
  КонецЕсли;
КонецЦикла;
Движ1.Записать();
   craxx
 
10 - 10.10.17 - 18:02
(9) неа. сначала в массив складываешь, а потом из массива удаляешь.
 
 Рекламное место пустует
   azernot
 
11 - 10.10.17 - 18:04
(10) В (0) сказано про 2 записи, удаляется одна. В таких условиях (9) сработает.
   craxx
 
12 - 10.10.17 - 18:06
(11) сработает, только вот случайным образом, а не тем которым надо ТС
   tatoshka0403
 
13 - 10.10.17 - 18:11
(8-12) Спасибо помогло

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует