Вход | Регистрация

1С:Предприятие ::

Метки: 

как вставить в ТаблЗначений колонку с типом Структура

Я
   Игорь_МММ
 
04.10.17 - 00:23
Управляемая форма, реквизит с типом Таблица Значений. Нужна колонка с реквизитом типа Структура. Можно ли это сделать?
 
  Рекламное место пустует
   zak555
 
1 - 04.10.17 - 00:30
1. на форме не ТЗ, а коллекция
2. что в структуре будет ?
3. дерево не подойдёт для задачи?
   Игорь_МММ
 
2 - 04.10.17 - 00:37
нужно загнать в один реквизит(ячейку) строки ТаблицыЗначений, несколько значений (произвольное количество). Подойдет что угодно - списокЗначений, ТЗ, Структура ...
Пробовал делать реквизит типом ТЗ, но получается какая-то лабуда с вводом значения в это поле. Делал так:

&НаКлиенте
Процедура СписокРазделовВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
        
    Если ВыбраннаяСтрока <> Неопределено Тогда
        Элементы.Таблица.ВыделенныеСтроки.Очистить();     
        Если Элемент.ТекущийЭлемент.Заголовок = "Структура колонок" Тогда
            ТЗ = ДанныеФормыВЗначение(Элемент.ТекущиеДанные.СтруктураКолонок,Тип("ТаблицаЗначений"));
                        
            Форма = ПолучитьФорму("Документ.РегистрацияПрайсЛиста.Форма.ФормаРедактированияСтруктуры");
            Форма.ТЗ = ТЗ;
            ТЗ = Форма.ОткрытьМодально();
            ЗначениеВДанныеФормы(ТЗ,Элемент.ТекущиеДанные.СтруктураКолонок);
            
        КонецЕсли;
    КонецЕсли;      

КонецПроцедуры
   VladZ
 
3 - 04.10.17 - 05:02
(2) "нужно загнать в один реквизит(ячейку) строки ТаблицыЗначений, несколько значений (произвольное количество)."  - зачем? Дерево не подойдет?
   Игорь_МММ
 
4 - 04.10.17 - 23:54
(3) дерево не очень красиво будет. Подредактировал вышенаписанное и все ок. Спасибо


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует