Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Отбор в табличном поле на форме обработки

Отбор в табличном поле на форме обработки
Я
   skupidom5
 
03.10.17 - 20:10
Есть 2 табличных поля с типами значений таблица значений.1 связана с другой.
Сделал так:
Процедура ТабличноеПолеДанныхПриАктивизацииСтроки(Элемент)
    
    ТекСтрока = ЭлементыФормы.ТабличноеПолеДанных.ТекущаяСтрока;
    ТаблицаДанныхИзеняемая.Очистить();
    
    СтруктураПоиска = Новый Структура;
    СтруктураПоиска.Вставить("НомерСтрокиИсходТаб",СтрокаНомерСтр);
    Если ЗначениеЗаполнено(ТаблицаДанныхНайденыСтроки) = Истина Тогда
         НайденыСтроки = ТаблицаДанныхНайденыСтроки.НайтиСтроки(СтруктураПоиска);
         Если не НайденыСтроки.Количество()>0 Тогда
              ТаблицаДанныхНайденыСтроки.Очистить();              
         КонецЕсли;     
    КонецЕсли;
    
    // ТаблицаДанныхНайденыСтроки

    Отбор = Новый Структура;
    Отбор.Вставить("НомерСтрокиИсходТаб",Строка(ТекСтрока.НомерСтроки));

    ТаблицаДанныхНайденыСтроки.Очистить();
    ТаблицаДанныхНайденыСтроки = ТаблицаДанныхНайденыСтрокиСлужебная.Скопировать(Отбор);
                 
КонецПроцедуры
 
 
   skupidom5
 
1 - 03.10.17 - 20:13
для отбора использую служебную некую тз - реквизит формы, которую при открытии обработки присваиваю знач своей основной тз,которую нужно фильтровать.Потом везде копирую данные между этими 2 таблицами с отбором по нужной строке 1 главного табличного поля. Есть ли более эффективный и оптимальный способ решения, мне кажется этот перегружен и не оптимален.
   Сти
 
2 - 03.10.17 - 23:00
С таблицей значений в качестве источника данных в общем-то так и выкручиваются. Но если это обработка, то в ней можно создать табличную часть, запихивать туда данные, а уже ее выводить на форму в табличном поле. Там отборы прекрасно работают.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует