Вход | Регистрация


Заполнение поля ввода из регистра сведений по выбранной строке

Заполнение поля ввода из регистра сведений по выбранной строке
Я
   gaur777
 
03.10.17 - 16:44
Подскажите пожалуйста, как можно при выборе поля ввода на УПРАВЛЯЕМОЙ форме, чтоб с регистра сведений заполнялось значение одного из полей выбранной строки.

На обычной форме выполнялось так:

Процедура ТорговыеТочкиПредприятияНачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;    
        
    ПараметрыВыбора = Новый Структура;
    ПараметрыВыбора.Вставить("РежимВыбора", Истина);
        
    ВыбранноеЗначение = ОткрытьФорму("РегистрСведений.КлассификаторВЕТИС.Форма.ФормаВыбора",ПараметрыВыбора, Элемент);
    
КонецПроцедуры

Процедура ТорговыеТочкиПредприятияОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    СтандартнаяОбработка = ЛОЖЬ;
    мз=РегистрыСведений.КлассификаторВЕТИС.СоздатьМенеджерЗаписи();
    
    ЗаполнитьЗначенияСвойств(мз,ВыбранноеЗначение);
    
    мз.Прочитать();
    
    Элемент.Значение = мз.UUID;

КонецПроцедуры

На управляемой делаю так:

&НаКлиенте
Процедура ТорговыеТочкиПредприятияНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;    
        
    ПараметрыВыбора = Новый Структура;
    ПараметрыВыбора.Вставить("РежимВыбора", Истина);
        
    ВыбранноеЗначение = ОткрытьФорму("РегистрСведений.КлассификаторВЕТИС.Форма.ФормаВыбора",ПараметрыВыбора, Элемент);
    
КонецПроцедуры

&НаКлиенте
Процедура ТорговыеТочкиПредприятияОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    СтандартнаяОбработка = ЛОЖЬ;
    мз=РегистрыСведений.КлассификаторВЕТИС.СоздатьМенеджерЗаписи();
    
    ЗаполнитьЗначенияСвойств(мз,ВыбранноеЗначение);
    
    мз.Прочитать();
    
    Элементы.Значение = мз.UUID;
    
КонецПроцедуры

Выдаёт ошибку -  Поле объекта не обнаружено (Значение)
 
 
   ГдеСобакаЗарыта
 
1 - 03.10.17 - 16:47
Элемент.Значение = мз.UUID;
Элементы.Значение = мз.UUID;
   gaur777
 
2 - 03.10.17 - 16:50
(1) {ВнешняяОбработка.ИнтеграцияМеркурияС1С.Форма.ОбщаяФорма.Форма(1980)}: Поле объекта не обнаружено (Значение)
    Элемент.Значение = мз.UUID;
   gaur777
 
3 - 03.10.17 - 16:55
отладчиком как-то не могу найти нужное свойство управляемой формы
   ГдеСобакаЗарыта
 
4 - 03.10.17 - 16:57
(2) Присваивай значение реквизиту формы, а не элементу.
ТорговыеТочкиПредприятия эт что? Список, ТЗ, Дерево?
   Numerus Mikhail
 
5 - 03.10.17 - 16:59
(3) Объект.ТорговыеТочкиПредприятия = мз.UUID
или если это реквизит формы, то просто ТорговыеТочкиПредприятия = мм.UID.

А если это список какой-то, то через Элементы.ТвойРеквизит.ТекущиеДанные = мз.UUID
   gaur777
 
6 - 03.10.17 - 17:25
(4) я ведь написал выше что поле ввода
уже решил вопрос

Элемент.ВыделенныйТекст = мз.UUID;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует