Вход | Регистрация


1С:Предприятие ::

Метки: 

Загрузка с ftp.

Я
   bard666
 
03.10.17 - 14:42
Не могу победить загрузчик 1С. Сменили платформу на 8.3.10.2252 и начались затыки.
Ошибка работы с Интернет remote file not found.

Код:

//FTP Соединение
Попытка
        Сервер = Новый FTPСоединение(ИмяСервераFTP,,ИмяПользователяFTP,ПарольFTP,,Истина,20,,УровеньИспользованияЗащищенногоСоединенияFTP.НеИспользовать);
        Если ЗначениеЗаполнено(КаталогFTP) тогда
            Сервер.УстановитьТекущийКаталог(КаталогFTP);
        КонецЕсли;
    Исключение
        Возврат;
КонецПопытки;

СписокФайлов = Сервер.НайтиФайлы(КаталогFTP, "*." + ?(Формат = "xml", "*", Формат));
    
        Для Каждого Файл Из СписокФайлов Цикл
            Если Файл.ЭтоФайл() Тогда
                Отказ = Ложь;
                Попытка
                    Сервер.Получить(Файл.ПолноеИмя, "D:\Заказы\" + Файл.Имя);
                Исключение
                    Сообщить(ОписаниеОшибки());
                    Отказ = Истина;
                КонецПопытки;
КонецЕсли;
КонецЕсли;


Ошибка на строке Сервер.Получить(...  К серваку подключается, каталог виден, массив файлов получает. Может кто сталкивался? Видел тему, что править имя "%23" на "#". Таких символов нету.
 
 
   vis_tmp
 
1 - 03.10.17 - 14:51
А "D:\Заказы\ имеется?
   vis_tmp
 
2 - 03.10.17 - 14:51
И права на неё?
   bard666
 
3 - 03.10.17 - 14:54
(1) (2) Уточняю. Файлы в каталоге появляются, но размер 0байт. Разрешение "xml".
   bard666
 
4 - 03.10.17 - 14:57
На платформе 8.2 код отрабатывал. Может на новой есть нюансы?
   bard666
 
5 - 03.10.17 - 15:43
Уважаемые специалисты, есть мысли?
   antgrom
 
6 - 03.10.17 - 15:51
(0) а в каталоге временных файлов файл корректно создаётся ?
   bard666
 
7 - 03.10.17 - 15:57
(6) Да, в каталоге файл корректный. Если Зайти через проводник на ftp, скопировать на комп, 1С их прошерстит. А вот функция Получить() отрабатывает некорректно.
   piter3
 
8 - 03.10.17 - 15:58
от какого пользователя
   bard666
 
9 - 03.10.17 - 16:01
(8) Не понимаю вопрос.
   piter3
 
10 - 03.10.17 - 16:01
(9) проверяешь от user1,код работает от user2
 
  Рекламное место пустует
   bard666
 
11 - 03.10.17 - 16:03
Сейчас тестирую на чистой базе. Пользователей в ней нет, на компе залогинен под админом.
   antgrom
 
12 - 03.10.17 - 16:09
(7) смотри сам : 1С сформировала файл в временном каталоге . Файл ты проверил и его корректность проверишь ещё раз. Осталось его записать в ФТП. Записывается он средствами Винды ( вы на линукс-подобные серверы не переходили недавно ? ). Значит это проблема не 1С-ников , а админов )
   bard666
 
13 - 03.10.17 - 16:13
(12) Файлы собираем с сервака клиента. Там виндовозка. И трудности только с xml, а dbf тырятся без трудностей... И начались трудности с перехода на 8.3.
   piter3
 
14 - 03.10.17 - 16:19
поставь каталог временных файлов если уверен,что дело в 1с и/или локальной машине.Укажи конкретный файл.xml
   antgrom
 
15 - 03.10.17 - 16:25
"Ошибка на строке Сервер.Получить("

ошибка недостаточно полно описана
сделай через попытку , пиши в ЖР результаты , в т.ч. описание ошибки.
Так будет понятнее.
   bard666
 
16 - 03.10.17 - 16:25
Во временные также копируется 0 кб
   mehfk
 
17 - 03.10.17 - 16:26
Смотри логи ftp сервера.
   bard666
 
18 - 03.10.17 - 16:27
(15) Ошибка работы с Интернет: remote file not found.
   piter3
 
19 - 03.10.17 - 16:37
если мне память не изменяет то ftp должен трехзначный код вернуть ошибки
   NeoVision
 
20 - 03.10.17 - 16:40
(0) у одного клиента рпохст начал падать после перехода на 8.3.10 при работе с фтп, пока вернули 8.3.8, времени на подробные тесты пока нет, скорее всего косяки в платформе
   bard666
 
21 - 03.10.17 - 16:44
(19) Ошибка при вызове метода контекста (Получить): Ошибка работы с Интернет: адрес ftp с портом remote file not found
   piter3
 
22 - 03.10.17 - 16:47
(21) Это мы уже знаем.Что говорит лог ftp или платформу понизь



Список тем форума
  Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует