Вход | Регистрация

1С:Предприятие ::

Метки: 

Обновил БП3. Пропали внешние формы для собственных документов

Я
   BolshoySmal
 
03.10.17 - 13:51
Всем доброго дня.
После очередного обновления до версии БП 3.0.52.36 отвалились все печатные формы собственных документов. Может кто сталкитвался. Помогите.
 
  Рекламное место пустует
   Волшебник
 
Модератор
1 - 03.10.17 - 13:52
Значит так обновились
   BolshoySmal
 
2 - 03.10.17 - 13:54
Спасибо ВАм уважаемый. Я помощи попросил у коллег а не констатации факта, к тожу же я не один такой.
Вот  пример похожей ситуации.https://forum.infostart.ru/forum9/topic177730/#message1859210
   DrShad
 
3 - 03.10.17 - 13:54
но физически то они остались? и что значит отвалились?
   BolshoySmal
 
4 - 03.10.17 - 13:55
Конечно. Макеты и функции в документах. Пр запуске на форме документа нет кнопки печать, а раньше была.
   DrShad
 
5 - 03.10.17 - 13:56
(4) ну по той ссылке что ты сам и нарыл и решение написано
   BolshoySmal
 
6 - 03.10.17 - 14:00
я его вообще не понял.у мну в модуле УправлениеПечатьюПереопределяемый.ПриОпределенииОбъектовСКомандамиПечати такой процедуры нет.
   kubik_live
 
7 - 03.10.17 - 14:05
Вот это появилось во всех формах документов 52 релиза: (см. в конце модуля формы) - у меня из-за этого не шла печать:

#Область СлужебныеПроцедурыИФункцииБСП


// СтандартныеПодсистемы.ПодключаемыеКоманды

&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
    ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
    ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды


#КонецОбласти
   ildary
 
8 - 03.10.17 - 14:06
(6) процедуры, указанные ниже "также не забудь в форме новые вставить стандартные процедуры" надо писать в форме самописного документа, а не в УправлениеПечатьюПереопределяемый.
   BolshoySmal
 
9 - 03.10.17 - 14:14
Вот что это значит   процедуры, указанные ниже "также не забудь в форме новые вставить стандартные процедуры" ?
Понятно, что указаенные выше процедуры необходимо вставить в форму своего документа.
   DrShad
 
10 - 03.10.17 - 14:17
(6) а у меня такая есть в Бухгалтерия предприятия, редакция 3.0 (3.0.52.39)
 
 
   BolshoySmal
 
11 - 03.10.17 - 14:23
до релиза  процедуры, указанные ниже "также не забудь в форме новые вставить стандартные процедуры" не обновлялся. При обновлении специально посмотрю.
   BolshoySmal
 
12 - 03.10.17 - 14:31
Всё. С ума сошел.
прр обновлении до релиза Бухгалтерия предприятия, редакция 3.0 (3.0.52.39) посмотрю наличие УправлениеПечатьюПереопределяемый.ПриОпределенииОбъектовСКомандамиПечати
   vis_tmp
 
13 - 03.10.17 - 14:38
Очередная переделка общих модулей...
   makaorel
 
14 - 03.10.17 - 16:06
еще не забыть прописать свои доки в процедуру ПриОпределенииОбъектовСКомандамиПечати
   BolshoySmal
 
15 - 06.10.17 - 09:47
нашел всетаки процедуру .ПриОпределенииОбъектовСКомандамиПечати


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует