Вход | Регистрация

1С:Предприятие ::

Метки: 

ПередЗаписью выводом вопроса если нет то Отказ = Истина;

Я
   Радим1987
 
03.10.17 - 12:36
передаю в Отказ если не устанавливаю Отказ = Истина . но после выполненея процедуры ПередЗаписьюЗавершение Отказ = ложь. Как можно решить эту проблему, или есть другие варианты?
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    
    Если ПараметрыЗаписи.РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда
        ДополнительныеПараметры = Новый Структура;     
        ДополнительныеПараметры.Вставить("Отказ",Отказ);
        ТекстВопроса = НСтр("ru = 'Вы действительно провести документ? После проведения документ будет недоступен для редактирования'") + Символы.ПС + НСтр("ru = 'Продолжить?'"); 
        Оповещение = Новый ОписаниеОповещения("ПередЗаписьюЗавершение", ЭтотОбъект, ДополнительныеПараметры);
        ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);          
    КонецЕсли; 
    
КонецПроцедуры

&НаКлиенте
Процедура ПередЗаписьюЗавершение(Ответ, ДополнительныеПараметры) Экспорт 

    Если Ответ <> КодВозвратаДиалога.Да Тогда 
        ДополнительныеПараметры.Отказ = Истина;
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Документ не проведен";
        Сообщение.Сообщить();         
    Иначе
        Возврат;
    КонецЕсли;   
        
КонецПроцедуры

 
  Рекламное место пустует
   Радим1987
 
1 - 03.10.17 - 12:37
Функция Вопрос() не подходит в конфигурации свойство РежимИспользованияМодальности установлен в НеИспользовать,
   vicof
 
2 - 03.10.17 - 12:38
Потому что ДополнительныеПараметры.Отказ не равно Отказ
   Радим1987
 
3 - 03.10.17 - 12:39
(2) Не понял
   Радим1987
 
4 - 03.10.17 - 12:39
ДополнительныеПараметры.Вставить("Отказ",Отказ);
   Радим1987
 
5 - 03.10.17 - 12:40
в процедуре ПередЗаписьюЗавершение в начале ДополнительныеПараметры.отказ = ложь
   Радим1987
 
6 - 03.10.17 - 12:42
Все понял именно в теле процедурвы надо установить
   Радим1987
 
7 - 03.10.17 - 12:42
а есть другие варианты?
   Филиал-msk
 
8 - 03.10.17 - 12:48
   Радим1987
 
9 - 03.10.17 - 12:56
(8) Спасибо
   Радим1987
 
10 - 03.10.17 - 13:00
пришлось свою кнопку добавить
 
  Рекламное место пустует


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует