Вход | Регистрация

1С:Предприятие ::

Метки: 

Подбор из группы в форме выбора

Я
   lirt82
 
02.10.17 - 07:26
Конфа на управляемых, в справочнике ВидыЦен есть таб часть Склады, жмем кнопку Добавить, открывается форма выбора справочника склады, как закодить чтоб при выборе группы складов все элементы этой группы переносились в таб часть Склады?
 
 
   lirt82
 
1 - 02.10.17 - 07:27
как закодить чтоб при выборе группы складов из формы выбора справочника склады, все элементы этой группы переносились в таб часть Склады
   МимохожийОднако
 
2 - 02.10.17 - 07:29
Что не получается? Приведи код, с которого начал.
   Филиал-msk
 
3 - 02.10.17 - 07:30
как закодить чтоб при выборе группы складов из формы выбора справочника склады, все элементы этой группы переносились в таб часть Склады?
   Филиал-msk
 
4 - 02.10.17 - 07:30
Как закодить?
   Филиал-msk
 
5 - 02.10.17 - 07:30
Или что?
   lirt82
 
6 - 02.10.17 - 07:35
какой обработчик нужен? возможно галочки в свойствах формы
   МимохожийОднако
 
7 - 02.10.17 - 07:37
Например,
Из каждого ТекСтрИз Склады Цикл
НовСтр=НекийОбъект.Склады;
ЗаполнитьЗначенияСвойств(НовСтр,ТекСтр);
...
   Филиал-msk
 
8 - 02.10.17 - 07:39
Обработка выбора!
Или при начале выбора!
Или форму выбора исправить!
   Филиал-msk
 
9 - 02.10.17 - 07:40
Так закодить!
   lirt82
 
10 - 02.10.17 - 07:59
вот ее нужно переделать
&НаКлиенте
Процедура СписокВыборЗначения(Элемент, Значение, СтандартнаяОбработка)
    
    Если ЗначениеЗаполнено(ВыборГруппыСкладов) И ЗначениеЗаполнено(Значение) И Элементы.Список.ТекущиеДанные <> Неопределено Тогда
        
        ТекущиеДанные = Элементы.Список.ТекущиеДанные;
        ВыборЗапрещен = ТекущиеДанные.ЭтоГруппа;
        
        Если ВыборЗапрещен Тогда
            Если ТипЗнч(ВыборГруппыСкладов) = Тип("ФиксированныйМассив") Тогда
                Для Каждого ТекЭлемент Из ВыборГруппыСкладов Цикл
                    Если ТекЭлемент = ТекущиеДанные.ВыборГруппы Тогда
                        ВыборЗапрещен = Ложь;
                        Прервать;
                    КонецЕсли;
                КонецЦикла;
            Иначе
                Если ВыборГруппыСкладов = ТекущиеДанные.ВыборГруппы Тогда
                    ВыборЗапрещен = Ложь;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
        
        Если ВыборЗапрещен Тогда
            
            СтандартнаяОбработка = Ложь;
            Отказ = Истина;
            ТекстПредупреждения = НСтр("ru='Группу ""%ГруппаСкладов%"" нельзя выбирать в документ.'");
            ТекстПредупреждения = СтрЗаменить(ТекстПредупреждения, "%ГруппаСкладов%", ТекущиеДанные.Наименование);
            ПоказатьПредупреждение(Неопределено, ТекстПредупреждения);
            
        КонецЕсли;
        
    КонецЕсли;
    
КонецПроцедуры
 
 
   lirt82
 
11 - 02.10.17 - 08:09
короче нужно передать на форму что-то чтоб форма помнила что ее вызвали из справочника ВидыЦен, тогда можно условие поставить и написать свой обработчик события выбора
   lirt82
 
12 - 02.10.17 - 08:09
:) потому что из других доков или справочников будет вызываться и начнутся проблемы
   МимохожийОднако
 
13 - 02.10.17 - 08:13
(11) Добавь реквизит на форму, в который пиши откуда вызвал. Приведи пример как вызываешь форму подбора.
   lirt82
 
14 - 02.10.17 - 08:21
(13)форму выбора складов вызываю по кнопке добавить над таб частью склады из формы элемента справочника ВидыЦен. Подскажи точнее где создать реквизит в который передавать ссылку?
   lirt82
 
15 - 02.10.17 - 08:22
откуда вызываю или что вызываю?
   МимохожийОднако
 
16 - 02.10.17 - 08:28
(14) Должно быть событие при добавлении строки. Реквизит можно добавить на закладке Реквизиты.
   МимохожийОднако
 
17 - 02.10.17 - 08:29
(16) ***обработчик события**
   lirt82
 
18 - 02.10.17 - 08:32
аа точно:)


Список тем форума
Рекламное место пустует   Рекламное место пустует
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует