Вход | Регистрация


1С:Предприятие ::

Метки: 

v7: ТиС - отрицательные остатки

Я
   Масянька
 
29.09.17 - 16:18
День добрый!
Кто в курсе: как работают отрицательные остатки в ТиС?
Спасибо.
 
  Рекламное место пустует
   Ёпрст
 
1 - 29.09.17 - 16:24
(0) Очень просто - увольняют МОЛ-а, и людей, обслуживающих ИБ
   Изучаю1С8
 
2 - 29.09.17 - 16:25
Постановка вопроса непонятна
   lubitelxml
 
3 - 29.09.17 - 16:26
(0) также как в 8.х - количество с минусом )
   Aleksey
 
4 - 29.09.17 - 16:26
(0) Где? В кассе?
Обычно те кто в курсе уже не работают, иначе их платить заставят
   пипец
 
5 - 29.09.17 - 16:31
запросто,  изменение прихода задним числом
   Масянька
 
6 - 29.09.17 - 16:40
Пардон.
Реализация в минус. Приход (завтрашним).
Почему так остается - http://pastenow.ru/1066e46a80e10a04473f9f73309f7ec5?
   Масянька
 
7 - 29.09.17 - 16:42
+(6) Причем, я еще могу понять в остатках, но в партиях - http://pastenow.ru/838228d8ca99332b8e88f406c5c7718d
   Масянька
 
8 - 29.09.17 - 16:43
(4) Нет. Остатки ТМЦ.
   Ёпрст
 
9 - 29.09.17 - 16:48
(8) приход переместили вперёд и всего лишь
   lubitelxml
 
10 - 29.09.17 - 16:49
(7) у тебя при продаже кол-во списывается, а сумма не списывается (откуда он знает какая она должна быть?). Далее приходуется и сумма и кол-во, в итоге остается сумма в регистре висет
 
  Рекламное место пустует
   lubitelxml
 
11 - 29.09.17 - 16:49
висет = висеть
   Джинн
 
12 - 29.09.17 - 16:49
(6) Потому что "Реализация в минус, приход завтрашним"
   Масянька
 
13 - 29.09.17 - 16:51
(9) (10) Так поясните смысл "отрицательных остатков"?
   Масянька
 
14 - 29.09.17 - 16:51
(10) Я думала, что как только будет приход - зачтется минус и останется 0. И по кол-ву и по сумме. Не логично?
   lubitelxml
 
15 - 29.09.17 - 16:53
(14) видимо нет ) Поставь приход раньше реализации и перепроведи и будет как ты хочешь
   Джинн
 
16 - 29.09.17 - 16:56
(14) Нет, не логично.
   Ёпрст
 
17 - 29.09.17 - 17:09
(14) сальдо будет 0 на конец периода, но на дату реализации будет -1.
Тебе отчет это и показывает собственна
   пипец
 
18 - 29.09.17 - 17:13
торговля воздухом в особо крупных размерах ))))
   Масянька
 
19 - 29.09.17 - 17:13
(17) Фишка в том, что кол-во 0 (на дату прихода), а вот сумма висит...
   Масянька
 
20 - 29.09.17 - 17:13
(18) Было бы смешно, если бы не было грустно...
   пипец
 
21 - 29.09.17 - 17:14
(19) есть такая весч как граница последовательности (сиречь списание партий) .... думай, на разную дату , сумма складсская на складе при равном количестве может быть разной
   пипец
 
22 - 29.09.17 - 17:17
если например приходы с равным количеством но разными ценами поменять датами , местами, то так у тебя и получится , без перепроведения расходных если, да (с) Йода
   Джинн
 
23 - 29.09.17 - 17:18
(20) Чтобы продать что-нибудь ненужное, надо сначала купить что-нибудь ненужное. (с) Кот Матроскин
   piter3
 
24 - 29.09.17 - 17:19
(14) Неа,совсем не логично
   пипец
 
25 - 29.09.17 - 17:20
(23) не поверишь, в бытность 90-х еще, с одного автозавода так и продали ))) агрегат, сначала продали а приход оформлен только спустя два месяца, и данные в накладных и ПТС разнились)))), долго смеялся когда нашёл , показывал неким ответственным - отмахнулись )))
   Масянька
 
26 - 29.09.17 - 17:20
(21) Ну, и смысл "отрицательных останков"?
   Масянька
 
27 - 29.09.17 - 17:21
(26) Блин... Описка по Фрейду :)
   пипец
 
28 - 29.09.17 - 17:22
(26) понимаишъ , к окну дебет , к двери кредит , или наоборот, но ниразу не в одну сторону!!! патаму чьта!
   Джинн
 
29 - 29.09.17 - 17:26
(26) Чтобы продать по фактическим остаткам, а затем оформить документальное поступление.
   Злопчинский
 
Ведущий
30 - 29.09.17 - 22:52
(7) всеиочень просто
Следует для начала административно запретить все действия задним числом, которые приводят к уменьшению остатков на складе.
Отмена проведения перемещения  - нельзя
Отмена проведения прихода - нельзя
   Злопчинский
 
Ведущий
31 - 29.09.17 - 22:52
.. Ну и т.д.
   Злопчинский
 
Ведущий
32 - 29.09.17 - 22:55
Провели сегодня плановую квартальную инв.
3414 ячеек. 6.5 человек, 2 из них штабелеромсчитали высоту, остальные - рабочие ячейки и мезонин.
Повторные пересчеты для 64 ячеек.
Отрицательных остатков - не обнаружено.
   vadim777
 
33 - 30.09.17 - 08:07
(0) Я еще десять лет назад для ТиС, в документ "Приходная накладная", встроил код, перепроводящий все зависимые от данной ПН документы. А то было, работник откроет прошлую ПН просто посмотреть, и жмет ОК - ПН перепроводится, остатки поплыли. В результате проблема с отрицательными остатками исчезла. Административные меры воздействия для небольшой фирмочки - это нереально.
 
  Рекламное место пустует
   Злопчинский
 
Ведущий
34 - 30.09.17 - 09:50
(33) просто тупо вычислял все доки, в которых содержатся товары из этой приходной накладной?
   Злопчинский
 
Ведущий
35 - 30.09.17 - 09:52
Про административные меры - это обязавтельно надо, чтобы потом, прияд к куроводству - сказать-показать - смотрите, какие д...ы, слова руководства не доходят, похренисты, - и тогда у куроводства не будет - как в соседней ветке - а чего это мы "программисту" так много платим?
   vcv
 
36 - 30.09.17 - 10:29
(33)
1. Определил пять зависимых от ПН документов и перепровёл
2. Определил 100 зависимых от перепроведённых пяти и перепровёл.
3. Определил 300 зависимых от .....
И так далее.
Самый надёжный вариант, это "умное" восстановление последовательности. При проведении документа определяешь набор аналитик, по которым нужно восстановить последовательность. Номенклатура, договор, возможно еще что. И перепроводишь только по ним.
   Aleksey
 
37 - 30.09.17 - 11:38
(34) при партионном учете можно глянуть движение по партии. Если есть движение - от винта

А по сабжу - почему все упираются в приходы? Что мешает мне задним числом провести/изменить расход (перемещение,списание,продажу). Это тоже может привести к минусу
   Злопчинский
 
Ведущий
38 - 30.09.17 - 12:54
(37) тоже может быть.
но это совсем уж фигня
   Злопчинский
 
Ведущий
39 - 30.09.17 - 12:54
то есть бардак полный...
   vadim777
 
40 - 30.09.17 - 14:48
(34)// Проверка и перепроведение зависимых от приходной накладной документов

// (для случая, если ПН перепроводится задним числом (когда есть документы расхода)
Процедура ПроверкаЗависимыхДокументов()
    Перем спТовары, спРасходныеДокументы, спФирмы, РегПартии;
    
    Если Проведен() = 0 Тогда
        Возврат;
    КонецЕсли;
    
    Если Модифицировано = 0 Тогда
        Возврат;
    КонецЕсли;
    
    спТовары = СоздатьОбъект("СписокЗначений");
    ВыгрузитьТабличнуюЧасть(спТовары, "Товар");
    
    КодыОперацийПродажи = СоздатьОбъект("СписокЗначений");
    // все продажи, все товары

    КодыОперацийПродажи.ДобавитьЗначение(ПродажаКупленногоТовара);
    КодыОперацийПродажи.ДобавитьЗначение(ПродажаКупленногоПереданногоТовара);
    КодыОперацийПродажи.ДобавитьЗначение(РозничнаяПродажаКупленногоТовара);
    КодыОперацийПродажи.ДобавитьЗначение(ВозвратТовараОтПокупателя);
    КодыОперацийПродажи.ДобавитьЗначение(ВозвратКупленногоПереданногоТовара);
    КодыОперацийПродажи.ДобавитьЗначение(ВозвратРозничныйКупленногоТовара);
    КодыОперацийПродажи.ДобавитьЗначение(ПродажаПринятогоТовара);
    КодыОперацийПродажи.ДобавитьЗначение(ПродажаПринятогоПереданногоТовара);
    КодыОперацийПродажи.ДобавитьЗначение(РозничнаяПродажаПринятогоТовара);
    КодыОперацийПродажи.ДобавитьЗначение(ВозвратПринятогоТовараОтПокупателя);
    КодыОперацийПродажи.ДобавитьЗначение(ВозвратПринятогоПереданногоТовара);
    КодыОперацийПродажи.ДобавитьЗначение(ПродажаУслуги);
    КодыОперацийПродажи.ДобавитьЗначение(СторноПродажаУслуги);
    
    РегПартии=СоздатьОбъект("Регистр.ПартииТоваров");
    РегПартии.УстановитьЗначениеФильтра("Товар",спТовары,2);
    РегПартии.УстановитьЗначениеФильтра("Статус",Купленный);
    РегПартии.УстановитьЗначениеФильтра("ПрихДокумент",ТекущийДокумент());
    РегПартии.УстановитьЗначениеФильтра("КодОперации",КодыОперацийПродажи,2);
    
    спРасходныеДокументы = СоздатьОбъект("СписокЗначений");
    
    спФирмы = глПолучитьФирмы(Контекст);
    
    Для Инд=1 по спФирмы.РазмерСписка() Цикл
        текФирма = спФирмы.ПолучитьЗначение(Инд);
        РегПартии.УстановитьЗначениеФильтра("Фирма",Фирма,1);
        РегПартии.ВыбратьДвижения(,);
        Пока РегПартии.ПолучитьДвижение() = 1 Цикл
            Если РегПартии.Расход = 1 Тогда
                Если спРасходныеДокументы.НайтиЗначение(РегПартии.ТекущийДокумент()) = 0 Тогда
                    спРасходныеДокументы.ДобавитьЗначение(РегПартии.ТекущийДокумент());
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
    
    Если спРасходныеДокументы.РазмерСписка() > 0 Тогда
        Текст = "Документ был изменен!"+РазделительСтрок;
        Текст = Текст + "Имеются следующие расходные документы,"+РазделительСтрок;
        Текст = Текст + "зависимые от текущего документа:"+РазделительСтрок;
        Текст = Текст + РазделительСтрок;
        Для Ном = 1 По спРасходныеДокументы.РазмерСписка() Цикл
            Текст = Текст + СокрЛП(спРасходныеДокументы.ПолучитьЗначение(Ном))+РазделительСтрок;
        КонецЦикла;
        Текст = Текст + РазделительСтрок;
        Если Константа.ПроведениеЗависимыхРасходныхДокументов = 0 Тогда
            Текст = Текст + "Эти документы будут перепроведены!"+РазделительСтрок;
            Предупреждение(Текст, 7);
            Текст = Шаблон("Перепроведение зависимых от '[ТекущийДокумент()]' расходных документов...");
            Сообщить(Текст);
        Иначе
            Текст = Текст + "Эти документы необходимо перепровести!"+РазделительСтрок;
            Текст = Текст + "Сделать это сейчас?";
            Если Вопрос(Текст, 4) = 7 Тогда
                Возврат;
            КонецЕсли;
        КонецЕсли;
        СпособСообщенияПродажаНижеСебестоимости = Константа.СпособСообщенияПродажаНижеСебестоимости;
        Константа.СпособСообщенияПродажаНижеСебестоимости = 0;
        Доки = СоздатьОбъект("Документ");
        Для Ном = 1 По спРасходныеДокументы.РазмерСписка() Цикл
            Док = спРасходныеДокументы.ПолучитьЗначение(Ном);
            Если Доки.НайтиДокумент(Док) = 0 Тогда
                Текст = Шаблон("Системная ошибка: документ '[Док]' не найден. Сообщите программисту.");
                Сообщить(Текст,"!!!");
                Продолжить;
            КонецЕсли;
            Док = Доки.ТекущийДокумент();
            Если Док.Проведен() = 0 Тогда
                Текст = Шаблон("Системная ошибка: документ '[Док]' не проведен, хотя по нему есть движения регистра партий. Сообщите программисту.");
                Сообщить(Текст,"!!!");
                Продолжить;
            КонецЕсли;
            Если Доки.Провести(,"Программно") = 0 Тогда
                Текст = Шаблон("Ошибка проведения '[Док]'. [ОписаниеОшибки()]");
                Сообщить(Текст);
            Иначе
                Сообщить(СокрЛП(Док)+" проведен.");
            КонецЕсли;
        КонецЦикла;
        Константа.СпособСообщенияПродажаНижеСебестоимости = СпособСообщенияПродажаНижеСебестоимости;
    КонецЕсли;
КонецПроцедуры
....
Процедура ПриЗакрытии()
    ПроверкаЗависимыхДокументов();
КонецПроцедуры
   Злопчинский
 
Ведущий
41 - 30.09.17 - 18:49
(40) А зависимые от зависимых - или они не нужны?
   Aleksey
 
42 - 30.09.17 - 19:19
(38) у меня менеджеры по началу любили так с резервами страдать. Не хватает товара - создаем док заявку вчерашним числом.
Другая любимая фишка - заявка, на основании заявки оперзал делает реализацию. Потом менеджер правит заявку и начинает наезд почему отгрузили не то что в заявки
Лечилось все запретом на правку и контроль структуры подчинености
   linoblack
 
43 - 30.09.17 - 20:09
(26) смысл "отрицательных остатков" в подсчете количества. количества, которое нужно будет оприходовать задним числом, чтобы эти отрицательные остатки убрать. это временная мера. и обязательно нужно перепроведение, т.к. количество закроется в ноль, но определение себестоимости происходит в момент проведения расходника.
   Злопчинский
 
Ведущий
44 - 30.09.17 - 20:21
(43) это смысл в том, что бардак. товары для продажи типа есть. но почему-то их на "балансе" нет... (бюджетников не рассматриваем с их заморочками)
   Злопчинский
 
Ведущий
45 - 30.09.17 - 20:23
(43) "смысл "отрицательных остатков" в подсчете количества. количества, которое нужно будет оприходовать задним числом, чтобы эти отрицательные остатки убрать."
- хреновое объяснение. отсюда непонятно нифейхоа. может можно не делать отрицательных остатков, тогда и не нужен "подсчет количества"...
   linoblack
 
46 - 30.09.17 - 20:26
(44) это не бардак - а особенности бизнеспроцессов, необходимые для минимизации или уклонения от всяческих поборов )))) временно продаем то, чего нет и не интересуемся ни доходом ни себестоимостью, только количеством. а потом приходуем ровно столько, сколько продали и после перепроведения выводим доход и т.п.
   Злопчинский
 
Ведущий
47 - 30.09.17 - 20:58
(46) не, это бардак.. просто ничего не считают... хренячат по факту. тоже вариант. вполне норм.
   vcv
 
48 - 30.09.17 - 20:58
(46) Если очень хочется - немного допилите.
Во первых, отказаться от партий (FIFO). Партии сильно усложняют работу в такими извратами.
Во вторых, сделать в документе поступления. Проверяем после приходования остаток по номенклатуре и, если он меньше, чем приходованное количество, списываем излишки себестоимости пропорционально.
В третьих, дописать документ, например, "закрытие месяца", процедурой корректировки себестоимости. По принципам, как оно работает в типовой бух 7.7.
   vcv
 
49 - 30.09.17 - 21:01
(47) Не обязательно бардак. Бывает же еще неотфакруровка, которая в ТиС не реализована. Привезли тебе товар. Положили на склад. Счет-фактура и хоть какие-то цены будут когда-нибудь потом. А продавать уже надо.
 
  Рекламное место пустует
   Злопчинский
 
Ведущий
50 - 30.09.17 - 21:21
(49) какое отношение счф имеет к собственности на товар?
товар вообще без документов? - ставим на ОХ - продавать не имеем права. оприходуем по инв., продаем.
документы будут-когда нибудь потом - то есть ДОСТОВЕРНО известно что документы будут? - ну так вводим эти документы - они же будут? - то есть известно что они есть...
   Смотрящий
 
51 - 30.09.17 - 23:42
(50) Будут то они будут, вопрос каким числом бумажку напишут.
   Злопчинский
 
Ведущий
52 - 01.10.17 - 09:16
(51) пофиг каким, главное - до продажи...
или главное чтобы на конец отчетного периода минуса закрылись, а был товар или нет во время продажи - по барабану..?
   Смотрящий
 
53 - 01.10.17 - 09:28
(52) Могут принести бумажку прихода и на следующий день после продажи, и через неделю
   Lionee
 
54 - 01.10.17 - 09:44
ох как я наепался с этой ТиС  5 лет назад в одном магазине,с этими партиями,остатками, бррр как страшный сон вспоминаю восстановление последовательности
   aka AMIGO
 
55 - 01.10.17 - 10:07
У меня не ТиС. От тис в старушке только первая буква,  "Т", что значит "Торговля" (если кте не в курсе) :)
С отрицательными остатками пришлось бороться, с переменным успехом.. Т.е. то я их побеждал, то они меня.
Чтобы не ловить досадных блошек, и не ломить голову, где, как и что - есть написал летучие отчетики:
https://yadi.sk/d/5l8LTJus3NMnw3

https://yadi.sk/d/RXa-f9Z_3NMnxb

Коечно, надо из преломить под регистры и документы ТиС, ибо, как вы уже знаете, у меня уделанная "Торговля"
Помогут - хорошо, не помогут - ну, что-ж.. я хотел, как лучше :)
   aka AMIGO
 
56 - 01.10.17 - 10:25
Да, совсем забыл, ведь я поддерживал ТиС, но давно уже не общаюсь с заказчиком, он получил, что хотел, и успокоился :)
Его, как и всех, тоже интересовали отрицательные остатки
Вот журнал документов (чисто евойный, как он просил)
https://i.paste.pics/96b8bb94cc695a3bdb99cee1dbf9c04a.png
слева - колонка пиктограмм, отражающих состояние документов. В красном квадратике - док, имеющий ошибки.
В модуле журнала отслеживаются/насчитываются остатки в некоторых регистрах. Понятно расчет тормозит вывод журнала, но, уважаемые, игра стОит свеч.. До появления этой колонки мы с заказчиком наелись этих минусов по самое не-хочу.
Есть и отчет по "синякам", достаточно просмотреть последовательность доков, сразу станет ясно, что надо сделать.

Такая-же колонка есть в журнале Счета (Это документы "Заявки покупателя", только названны по-другому
https://i.paste.pics/ed63c68a932d66569fa3ada2c3c593b5.png

Могу привести фрагмент кода)
   aka AMIGO
 
57 - 01.10.17 - 10:28
* названны = названы

ЗЫ. лень проверить..
   Злопчинский
 
Ведущий
58 - 01.10.17 - 13:00
(55) ну, у меня у лавочника одного больше десятка точек. отрицательных остатков нет. ибо то что в базе - соответствует действительности. Есть товар - его приход заведен в базу. нет товара - нет прихода. нет прихода - нет товара.
   Злопчинский
 
Ведущий
59 - 01.10.17 - 13:03
(55) я летучие отчетики не писал ;-)
достаточно в типовые отчеты по движениям вставить пропуск вывода строки (и соотв.флажок на форму) если остаток >=0 -
будет выводить только "неправильные" отрицательные остатки...
   linoblack
 
60 - 01.10.17 - 14:21
(58) да? и документы "списние недостач" и "оприходование излишков" не приходится делать никогда? завидую....
   Злопчинский
 
Ведущий
61 - 01.10.17 - 16:51
(60) почему, приходится по мелочи, но к отрицательным остаткам это как относится?
   Злопчинский
 
Ведущий
62 - 01.10.17 - 16:52
Вот висит на остатке -5шт
Вопрос - это правильно или это ошибки в базе/учете?
   linoblack
 
63 - 01.10.17 - 19:40
(61) не к отрицательным остаткам , а к "то что в базе - соответствует действительности" )))

человеческий фактор в виде конечного звена всей технологической цепочки под названием "грузчик" может порушить всю красивость ))))
   Злопчинский
 
Ведущий
64 - 01.10.17 - 22:07
(63) соответствие действительности конечно идеально достичь трудно, всегда есть неконтролируемые отклонения, которые при текущих бизнес процессах не отлавливаются. У меня таких отклонений по сумме составляет уже длительное время в районе 0.02% - две сотых - от суммы продаж за период.
   Злопчинский
 
Ведущий
65 - 01.10.17 - 22:11
(63) да, может потушить.
Но 1. Если это рухнуло на эн шаге - эн плюс первый не отработает.
2. Как только например всплыли отрицательные остатки - мне не надо думать это ошибка или так и должно быть или половина отриц остатков это ошибка, а половина - это норма. У мну если отриц остаток всплыл то сразу понятно что это ошибка.
   linoblack
 
66 - 01.10.17 - 23:54
(65) аналогично, но у меня отрицательные остатки разрешены только в определенный период времени, пока идут продажи. продажи прошли, на приход поставил - робот восстанавливает последовательность. если минус - это ошибка. в большинстве случаев исправляется перестановкой доков по времени. иногда приходится оприходовать излишек. при этом закрыто любое редактирование раньше трех дней назад. для "аудиторского следа" есть специальный документ - "заявка на корректировку", который вводится на основании любого документа и в нем детально необходимо описать требуемые изменения а так же причины возникновения ошибок. вот пользователи и пишут кто, где, когда и почему лоханулся ))) а я уже исправляю. ну и в шутку шантажирую всех угрозой распечатать этот журнал )))))
   Злопчинский
 
Ведущий
67 - 02.10.17 - 01:15
(66) ты противоречишь сам себе
* "у меня отрицательные остатки разрешены только в определенный период времени" - минус это не ошибка
* "если минус - это ошибка" - минус это ошибка.

если у тебя в какой-то период времени "минус это не ошибка" - то уже в общем случае невозможно БЕЗ ДОПОЛНИТЕЛЬНЫХ КОПАНИЙ определить что в этом минусе "норма", а что вполне возможная реальная ошибка...

а такие доп.копания - ужас как трудозатратны...
   Злопчинский
 
Ведущий
68 - 02.10.17 - 01:26
(66) "при этом закрыто любое редактирование раньше трех дней назад." - почему не 5 дней? почему не квартал? какая разница?
   Злопчинский
 
Ведущий
69 - 02.10.17 - 01:28
у мну оперативный персонал продаж вообще назад никогда не лазит, даже секунду назад... в его распоряжении только текущие оперативные остатки, которые доступны для свободного товарооборота и подтверждены документально. Все что не подтверждено документально - к продажникам в базу в свободный остаток вообще не попадает...
   vcv
 
70 - 02.10.17 - 05:42
(69) "Все что не подтверждено документально - к продажникам в базу в свободный остаток вообще не попадает..."
Хорошо, что можешь себе это позволить.
А у меня вон, приходит вагон металла. Вагон идёт своими путями, ТОРГ-12 и с/ф - своими. Зачастую в разные концы страны, потому что грузополучатель и покупатель территориально очень разные.
Покупатель на вагон часто уже стоит и ждёт, он заказ месяц назад размещал у производителя. И деньгами трясёт - вагончик 2-4 миллиона стоит в зависимости от вида металлопродукции. Покупателю нельзя вагон не отдать. Вагон нельзя не разгрузить. Даже если по документам в вагоне совсем не то, что на самом деле.
Крутятся как могут. Приходуем по факту. С ценами или без цен. Лишь бы покупателю отдать. Слишком дорогое удовольствие, когда вагон завис.
   Масянька
 
71 - 02.10.17 - 08:50
Во, вы тут накидали... Что - выходные отменили? :)
(44) В данном случае - изврат бюджетников. Причем, конкретный изврат...
Отриц. остатки - запрещены. Все чисто и хорошо (сама в шоке :) ).
А что мешает - в момент прихода вместе с кол-вом списывать сумму? Абсолютно не логично: ни по реалу, ни по бух. учету.
   Масянька
 
72 - 02.10.17 - 08:51
А вообще - финт ушами уже придумали :(
   aka AMIGO
 
73 - 02.10.17 - 09:20
Я сделал проверку в модулях документов, лапающих важные регистры
А в некоторых на форму подвесил кнопку "Проверка на проведение"

Можно было-б сделать запрет отмены проведения доков прихода, но я не выложил идею шефу/шефке.. Сразу скажут "хочу-хочу"..
   Злопчинский
 
Ведущий
74 - 02.10.17 - 10:38
(70) у тебя есть оприходовпние по факту и ты это и про даёшь отгрузка ешь. А выше продают в минус. То есть типа они откуда-то знают что есть на остатках но его нет и это продают. Тихий бред. Откуда они знают что есть на остатках чтобы продавать это в минус? Из какой-то другой системы?
   Масянька
 
75 - 02.10.17 - 11:03
(73) Извраты были бы не нужны (практически) - если бы бюджетники работали, как люди.
Прострелить бы коленку (да, и не только) "изобретателю" сего чуда.
   Масянька
 
76 - 03.10.17 - 12:37
(17) Огромное спасибо!
   Масянька
 
77 - 03.10.17 - 12:47
Я тут продолжу - вариант при групповом проведении запретить проведение док-та? Восстановление последовательности и пр.
   linoblack
 
78 - 03.10.17 - 19:14
(67) никакого противоречия. запрет на три дня в глубь, т.к. три дня как раз время, чтоб все продажи устаканились - выписка документов, сборка товара, доставка клиенту, возврат исправленных документов, внесение исправлений в выписку. городить огород с корректировочными документами неудобно, проще зайти в исходный документ и исправить нужное. для аудиторского следа ведется стандартный журнал плюс логирование изменений в ключевых документах (и шапок и табличных частей). в целом отрицательные остатки конечно же запрещены. но в течении дня выделяется несколько часов, когда они разрешены, для проведения в минус порции свежих расходников. провели, сформировали приход равный количеству минусов, провели его началом дня, опять запретили минуса. далее робот начинает восстанавливать последовательность и если встречается минус - то это уже явная ошибка. если достаточно переставить документы по времени - робот это делает, если недостаточно - делает оприходование излишков. более сложные ошибки случаются очень редко, т.е. "ручного" разбирательства почти не требуется.
   Злопчинский
 
Ведущий
79 - 03.10.17 - 19:38
(78) " доставка клиенту, возврат исправленных документов,"
ну не знаю... это только для мутных клиентов у которых у самих бардак.
в остальном если на складе поставлено нормально - отклонения реальных отгрузок от выписанных документов (или хотелок клиентов типа не нашел 2шт и идем ему навстречу) - ну ОЧЕНЬ редко. то есть это не система
   Злопчинский
 
Ведущий
80 - 03.10.17 - 19:39
(78) "в целом отрицательные остатки конечно же запрещены. но в течении дня выделяется несколько часов, когда они разрешены,"
- почему несколько часов а не минут? а не дней? типа стоял вахтер и проверял пропуска, но если пропуска не было - пускал и так...
   linoblack
 
81 - 03.10.17 - 21:04
(79)например, привезли клиенту, при выгрузке побили. да, есть акт боя, но и расходник надо бы откорректировать.
   linoblack
 
82 - 03.10.17 - 21:05
(80) несколько часов - это время, в течении которого операторы проводят и печатают расходники
   Злопчинский
 
Ведущий
83 - 03.10.17 - 22:01
(81) это рядовая ситуация, отрабатывается штатно и ну никаким боком к отрицательным остаткам не стоит...
   Злопчинский
 
Ведущий
84 - 03.10.17 - 22:05
(82) это понятно, но каким боком это к отрицательным остаткам... я ладно понимаю еще пересорт по партиям/срокам может быть... но чисто отрицательные остатки.. все равно непонятно...

возможно (?) у вас документы к товару (в т.ч. и от поставщиков) ходят сами по себе, а товары сами по себе. актуальных остатков нет (?), собирают что собрали (?) выписывают по факту того что собрали, а не того, что по остаткам есть по базе (?) поэтому и выписка в минус по факту сборки (?)...???
   linoblack
 
85 - 03.10.17 - 22:47
(84) не, тут такая шляпа - СОХ, склад ответственного хранения. на нашем складе есть наш товар. он оприходован и мы его продаем. практически полное соответствие картины в базе реальности. и тут все норм, но.....часть склада занимает товар, привезенный поставщиком в большом количестве, и принадлежащий поставщику. естественно в нашей базе он не существует, но продавать его нужно. для этого и разрешаю отрицательные остатки, набиваю продажи, и полученное минусовое количество приходую началом дня. т.е. как бы сколько оприходовали, столько в этот же день и продали, у нас этого товара на остатке никогда нет. я не знаю зачем это бухам, но это какой-то шахер-махер и им побоку мои умничанья, что так не делается.....



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует