Вход | Регистрация

1С:Предприятие ::

Метки: 

БСП. Работа с файлами. Дополнительный реквизит файла

Я
   ТимурСФ
 
29.09.17 - 09:34
Добрый день,

Стоит задача для прикрепляемых файлов (БСП) добавить указание типа файла (новый справочник ТипыФайлов: "Документ", "заявка" и тп).
Схема работы пользователя предполагается следующая:
Пользователь нажимает прикрепить файл, выбирает файл, далее указывается тип этого файла. Соответственно в списке прикрепленных файлов нужна колонка "тип файла".
Можно ли это реализовать стандартными инструментами БСП? Если нельзя, то как можно это реализовать максимально безболезненно для БСП?
 
 
   toypaul
 
1 - 29.09.17 - 09:54
Я делал так

&НаКлиенте
Процедура ОткрытьСвойстваФайла(Команда)
    
    Если Элементы.Список.ТекущиеДанные = Неопределено Тогда
        Возврат
    КонецЕсли;
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ПрисоединенныйФайл", Элементы.Список.ТекущиеДанные.Ссылка);
    
    //++ ООО ПРОСТО Шемякин П.А. 

    ИмяОсновнойФормы = пр_ОбщегоНазначенияВызовСервера.пр_ОсновнаяФормаОбъекта(Элементы.Список.ТекущиеДанные.Ссылка);
    Если НЕ ПустаяСтрока(ИмяОсновнойФормы) Тогда
        ОткрытьФорму(ИмяОсновнойФормы, ПараметрыФормы);
    Иначе
        ОткрытьФорму("ОбщаяФорма.ПрисоединенныйФайл", ПараметрыФормы);
    КонецЕсли; 
    //ОткрытьФорму("ОбщаяФорма.ПрисоединенныйФайл", ПараметрыФормы);

    //-- ООО ПРОСТО Шемякин П.А. 

    
КонецПроцедуры
   toypaul
 
2 - 29.09.17 - 09:59
Но сейчас я понял что был не прав. потому что есть подписка ПереопределитьПолучаемуюФормуПрисоединенногоФайла

она зараза в в подсистему не включена
   toypaul
 
3 - 29.09.17 - 10:31
кстати через подписку чот не работает. она срабатывает только когда открываешь файл через "Все функции". но этим же никто пользоваться не будет. файл открываются из формы владельца. а там напрямую открывается общая форма.

вообще не понял для чего эту подписку сделали. главное еще и на ИТС про нее написано.

если что у меня ЕРП 2.2. может где и будет работать.


Список тем форума
Рекламное место пустует Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует