Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Контур.EDI

Контур.EDI
Я
   evgilm
 
28.09.17 - 22:14
Доброго времени суток.
Решился задать свой вопрос.
Клиент работает с торговыми сетями по ЭДО через модуль к 1С КонтурEDI.
Существует такая проблема, что при отправке УПД в поле основание не проставляется Договор/Основание. Вроде все пересмотрел (и отладкой прошелся) и параметры в запись XML уходят, но не заполняет, так и не понял, кажется что то упускаю. Думаю, что связь в том что заказы приходят без привязки к договору, т.к. на те заказы которые пришли с договором, УПД так же формируется с договором.
Прошу Вас помочь или дать совет в каком направлении искать.
Прошу сильно не критиковать.
 
 
   Djelf
 
1 - 28.09.17 - 23:23
Звякни в техподдержку, у Контура она адекватная (в Питере).
   evgilm
 
2 - 29.09.17 - 09:01
(1) Звонил. Обращение находится у экспертов уже целую неделю.
   МимохожийОднако
 
3 - 29.09.17 - 09:04
(2) для них это нормально. Какая конфигурация? Внедрены модули или внешняя обработка? Посмотри в отладчике, как заполняется это поле.
   БородаДжигурды
 
4 - 29.09.17 - 09:40
Номер инцидента напишите пожалуйста - посмотрю что по нему.
   evgilm
 
5 - 29.09.17 - 09:45
(4) Номер обращения 13980183 (3) Внешняя обработка
   БородаДжигурды
 
6 - 29.09.17 - 09:45
Вы отправляете не УПД а сообщение INVOIC (из него потом сервер делает УПД)- зайдите в свой мониторинг - найдите это сообщение и скачайте - проверьте есть ли в нем необходимое значение (поиском)  После этого станет понятно где проблема - не вашей стороне или на стороне Сервера.
Торговая Сеть какая?
   БородаДжигурды
 
7 - 29.09.17 - 09:46
обращение нашел, смотрю
   evgilm
 
8 - 29.09.17 - 10:02
(7) При просмотре XML файла из INVOIC в модуле, нет пункта contractidentificator number.
При просмотре схожих сообщений на примере сети Магнит, увидел что при заполненном поле Договор в Заказе(ORDERS) от поставщика, формируется INVOIC с заполненным полем Основание. Если в заказе не заполнено поле Основание, то так же в INVOIC не заполняется. Может ли быть в этом связь?
   oleg_km
 
9 - 29.09.17 - 11:46
(6) Интересно, если сервер делает УПД, то как он к нему делает вашу ЭЦП? Или вы им отдаете и закрытый ключ ЭЦП?
   evgilm
 
10 - 29.09.17 - 12:04
(9) Документы подписываются через модуль Диадок этой же фирмы.
 
 Рекламное место пустует
   oleg_km
 
11 - 29.09.17 - 12:06
(10) исчерпывающе.
   evgilm
 
12 - 29.09.17 - 12:08
Решено благодаря техподдержки Контур.
Всем спасибо.

Может кому пригодится.
Добавлено расширение для процедуры ПослеЗаполнения_EdiMessageXDTO

Сообщение = Параметры.Сообщение;
Если Сообщение.ТипСообщения = "INVOIC" Тогда
    Если Сообщение.Свойство("Контракт") Тогда
        Если НЕ ЗначениеЗаполнено(Сообщение.Контракт.Номер) Тогда
            Если Сообщение.Свойство("Контракт1С") Тогда
                Если ЗначениеЗаполнено(Сообщение.Контракт1С) Тогда
                Сообщение.Контракт.Номер = СтрЗаменить(Сообщение.Контракт1С.Номер,"№","");
                Сообщение.Контракт.Дата = Сообщение.Контракт1С.Дата;
                    xmlЗаполнитьDocumentIdentificator(Параметры.EdiMessage.invoice, "contractIdentificator", Сообщение, "Контракт");//Теперь называется Контракт а не КОнтрактEDI

                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
КонецЕсли;
   evgilm
 
13 - 29.09.17 - 12:08
(11) К сожалению, еще мало с этим знаком.
   k_st84
 
14 - 29.09.17 - 12:11
(6) сервер формирует xml УПД из EDI сообщения Invoic учитывая особенности торговых сетей (add info с нужным содержанием, правильные адреса и пр).
Далее в модуль EDI возвращаются идентификаторы УПД в Диадоке, по которым можно получить контент и подписать его на своей стороне.
   oleg_km
 
15 - 29.09.17 - 12:23
(14) понятно.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует