Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

План обмена. Выдается ошибка как отловить где она?

Ø [Волшебник, 28.09.17 - 21:17]
План обмена. Выдается ошибка как отловить где она?
Я
   Босечка
 
28.09.17 - 11:40
Ошибка при вызове метода контекста (ВыполнитьВыгрузку): Произошла исключительная ситуация (1C:Enterprise 8.3.8.2054): Ошибка инициализации модуля: Документ.ЗаказПоставщику.МодульОбъекта
{Документ.ЗаказПоставщику.МодульОбъекта(1897,127)}: Переменная не определена (РежимДиалогаВопрос)
Захожу в модуль,  а там пустая строка. В обработке заполнения.  Как быть без этого не работает план обмена.
 
 
   Волшебник
 
Модератор
1 - 28.09.17 - 11:41
Не в тот модуль заходите
   Босечка
 
2 - 28.09.17 - 11:43
А в какой надо заходить?
   Волшебник
 
Модератор
3 - 28.09.17 - 11:44
Документ.ЗаказПоставщику.МодульОбъекта
   Босечка
 
4 - 28.09.17 - 11:44
Как это найти отладчик туда не входит.
   Босечка
 
5 - 28.09.17 - 11:45
(3)туда и захожу
   Босечка
 
6 - 28.09.17 - 11:45
там вообще нет РежимДиалогаВопрос
   aka AMIGO
 
7 - 28.09.17 - 11:47
Щелчок по строке сообщения об ошибке не открывает конфигуратор?
   Ёпрст
 
8 - 28.09.17 - 11:47
(0)
>>>Захожу в модуль,  а там пустая строка. В обработке заполнения

Куда заходишь ?
Что за пустая строка и хде ?
   aka AMIGO
 
9 - 28.09.17 - 11:48
(6) Глоб.поиском поищи этот текст в конфигурации
   Ёпрст
 
10 - 28.09.17 - 11:49
в модуле документа нажимаешь Ctrl+G и вводищь номер строки из ошибки, позиционируешься на ней, исправляешь.
И, задавать вопросы в модуле, не комильфо
 
 Рекламное место пустует
   Босечка
 
11 - 28.09.17 - 11:50
(8)В Документ.ЗаказПоставщику.МодульОбъекта захожу и в 1897,127 пустая строка.
   Босечка
 
12 - 28.09.17 - 11:50
там ничего нет. Если бы так просто все было.
   Босечка
 
13 - 28.09.17 - 11:51
в этом модуле это вообще нет.
   Босечка
 
14 - 28.09.17 - 11:54
Как отладчик там запустить?
   Numerus Mikhail
 
15 - 28.09.17 - 11:54
(13) почисти кеш
   aka AMIGO
 
16 - 28.09.17 - 11:58
(14) Не "отладчик", а "отладку"

в левом обрезе/рамке окна модуля пару раз кликаешь мышкой напротив нужной строки останова, появится сфера - точка останова.
Далее запускаешь свой обмен/отчет/обработку/ЧтоУтебяТам..
   aka AMIGO
 
17 - 28.09.17 - 11:58
ИМХО 100% не тот модуль открыт..
   drcrasher
 
18 - 28.09.17 - 12:02
(0) кэш, не та конфа, не тот конфигуратор
   h-sp
 
19 - 28.09.17 - 12:20
(13) может вы к другой базе подключаетесь? а не к этой. Что за процедура "ВыполнитьВыгрузку?
   ColonelAp4u
 
20 - 28.09.17 - 12:44
Как происходит обмен? подключением к другой базе?
Если да то возможно ошибка на стороне приемника, поищите эту строку в базе куда выгружаете.
   Босечка
 
21 - 28.09.17 - 12:58
да. Там и ищу. Но все бесполезно.
   h-sp
 
22 - 28.09.17 - 13:13
(21) ну покажите этот модуль

Документ.ЗаказПоставщику.МодульОбъекта(1897,127)

строка 1897. и в той и в этой базе.
   aka AMIGO
 
23 - 28.09.17 - 13:35
   Босечка
 
24 - 28.09.17 - 13:40
(23)Да.
(22)Вот сюда курсор переходит по ошибке
Процедура ПроизвестиОбменДаннымиПоНастройке(СтруктураНастроекОбменаДанными)
    
    // начальные функции инициализации обмена

    РезультатаНачалаОбмена = ВыполнитьДействияПередНачаломОбменаДанными(СтруктураНастроекОбменаДанными);
    Если Не РезультатаНачалаОбмена Тогда
        Возврат;
    КонецЕсли;
    
    // ВЫПОЛНЕНИЕ ОБМЕНА ДАННЫМИ

    ОбработкаОбменаПриемника = Неопределено;
    Попытка
        
        Если СтруктураНастроекОбменаДанными.ДанныеНастройки.OnLineОбмен
            И СтруктураНастроекОбменаДанными.ДанныеНастройки.ТипНастройки = Перечисления.ТипыАвтоматическогоОбменаДанными.ОбменЧерезComСоединение Тогда
            
            // обмен через com соединение

            // выполняем и выгрузку и загрузку данных

            ВыполнитьОбменДаннымиЧерезComСоединение(СтруктураНастроекОбменаДанными, ОбработкаОбменаПриемника);
            
        Иначе
        
             ВыполнитьОбычныйОбменДанными(СтруктураНастроекОбменаДанными);    
            
        КонецЕсли;
        
        // оставшееся действия после обмена данными выполняем

        ВыполнитьДействияПослеЗавершенияОбменаДанными(СтруктураНастроекОбменаДанными, ОбработкаОбменаПриемника);
                
    Исключение
        
        СтрокаОписанияОшибки = ОписаниеОшибки();
        // отмечаем то что обмен произведен

        ЗафиксироватьЗавершениеОбмена(СтруктураНастроекОбменаДанными, СтрокаОписанияОшибки, , ОбработкаОбменаПриемника);
        
        #Если Клиент Тогда

        ЗакрытьФормуОбработкиДанных(СтруктураНастроекОбменаДанными);
        #КонецЕсли

        
        ОбработкаОбменаПриемника = Неопределено;
        
        // прокидываем ошибку дальше

        ВызватьИсключение СтрокаОписанияОшибки;
        
    КонецПопытки;
    
    ОбработкаОбменаПриемника = Неопределено;
        
    #Если Клиент Тогда

        Состояние("");
    #КонецЕсли

    
КонецПроцедуры
   Босечка
 
25 - 28.09.17 - 13:44
Процедура ОбработкаЗаполнения(Основание)

    ДокументОснование = Основание;
    Если ТипЗнч(Основание) = Тип("ДокументСсылка.Событие") Тогда
        // Заполнение шапки

        КонтактноеЛицоКонтрагента = Основание.КонтактноеЛицо;
        Контрагент     = Основание.Контрагент;
        Организация =     УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновнаяОрганизация");
        
        ДоговорКонтрагента     = ЗаполнениеДокументов.ПолучитьДоговорПоОрганизацииИКонтрагенту(Организация, Контрагент, мСтруктураПараметровДляПолученияДоговора);
    ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.ЗаказПокупателя") Тогда
        
        // Заполнение шапки

        ВалютаДокумента                   = Основание.ВалютаДокумента;
        ИспользоватьПлановуюСебестоимость = Основание.ИспользоватьПлановуюСебестоимость;
        ИтогПлановаяСебестоимость         = Основание.ИтогПлановаяСебестоимость;
        Комментарий                       = Основание.Комментарий;
        КратностьВзаиморасчетов           = Основание.КратностьВзаиморасчетов;
        КурсВзаиморасчетов                = Основание.КурсВзаиморасчетов;
        Подразделение                     = Основание.Подразделение;
        СтруктурнаяЕдиница                = Основание.СтруктурнаяЕдиница;
        СуммаВключаетНДС                  = Основание.СуммаВключаетНДС;
        СуммаДокумента                    = Основание.СуммаДокумента;
        УчитыватьНДС                      = Основание.УчитыватьНДС;
        
        Склад = ?(ТипЗнч(Основание.СкладГруппа) = Тип("СправочникСсылка.Склады"), Основание.СкладГруппа, Неопределено);
        Если НЕ ЗначениеЗаполнено(Склад) Тогда
            Склад = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновнойСклад");
        КонецЕсли;
        #Если Клиент Тогда

        Если НЕ ЗначениеЗаполнено(Склад) Тогда
            ВвестиЗначение(Склад, "Выберите склад", Тип("СправочникСсылка.Склады"));
        КонецЕсли;
        #КонецЕсли

        ОрганизацияКонтрагента = ЗаполнениеДокументов.ПолучитьОрганизациюПоКонтрагенту(Основание.Контрагент);
        Если ЗначениеЗаполнено(ОрганизацияКонтрагента) Тогда
            Контрагент  = ЗаполнениеДокументов.ПолучитьКонтрагентаПоОрганизации( Основание.Организация);
            Организация = ЗаполнениеДокументов.ПолучитьОрганизациюПоКонтрагенту( Основание.Контрагент);
        
            ЗаполнениеДокументов.ПриИзмененииЗначенияКонтрагента(ЭтотОбъект, мСтруктураПараметровДляПолученияДоговора);
            
            СкопироватьТабличнуюЧасть(Основание, "ВозвратнаяТара");
            СкопироватьТабличнуюЧасть(Основание, "Товары");
            СкопироватьТабличнуюЧасть(Основание, "Услуги");

        Иначе
            Организация = Основание.Организация;

            //переносим в документ необеспеченную часть заказа покупателя

            ЗаполнитьТабличнуюЧастьНеобеспеченнойЧастьюЗаказа(Товары, Основание);
            ЗаполнитьТабличнуюЧастьНеобеспеченнойЧастьюЗаказа(ВозвратнаяТара, Основание);

        КонецЕсли;
        
    ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.СчетНаОплатуПоставщика") Тогда

        // Заполнение шапки

        ВалютаДокумента                   = Основание.ВалютаДокумента;
        ДатаОплаты                        = Основание.ДатаОплаты;
        ДатаПоступления                   = Основание.ДатаПоступления;
        ДоговорКонтрагента                = Основание.ДоговорКонтрагента;
        ИспользоватьПлановуюСебестоимость = Основание.ИспользоватьПлановуюСебестоимость;
        ИтогПлановаяСебестоимость         = Основание.ИтогПлановаяСебестоимость;
        КратностьВзаиморасчетов           = Основание.КратностьВзаиморасчетов;
        Комментарий                       = Основание.Комментарий;
        КонтактноеЛицоКонтрагента         = Основание.КонтактноеЛицоКонтрагента;
        Контрагент                        = Основание.Контрагент;
        КурсВзаиморасчетов                = Основание.КурсВзаиморасчетов;
        Организация                       = Основание.Организация;
        Ответственный                     = Основание.Ответственный;
        Подразделение                     = Основание.Подразделение;
        Склад                             = Основание.Склад;
        СтруктурнаяЕдиница                = Основание.СтруктурнаяЕдиница;
        СуммаВключаетНДС                  = Основание.СуммаВключаетНДС;
        СуммаДокумента                    = Основание.СуммаДокумента;
        ТипЦен                            = Основание.ТипЦен;
        УчитыватьНДС                      = Основание.УчитыватьНДС;
        
        УправлениеЗаказами.УстановитьДатуОплатыПоДоговору(ЭтотОбъект);

        Для Каждого ТекСтрокаВозвратнаяТара Из Основание.ВозвратнаяТара Цикл
            НоваяСтрока = ВозвратнаяТара.Добавить();
            ЗаполнитьЗначенияСвойств(НоваяСтрока, ТекСтрокаВозвратнаяТара);
        КонецЦикла;
        Для Каждого ТекСтрокаТовары Из Основание.Товары Цикл
            НоваяСтрока = Товары.Добавить();
            ЗаполнитьЗначенияСвойств(НоваяСтрока, ТекСтрокаТовары);
        КонецЦикла;
        Для Каждого ТекСтрокаУслуги Из Основание.Услуги Цикл
            НоваяСтрока = Услуги.Добавить();
            ЗаполнитьЗначенияСвойств(НоваяСтрока, ТекСтрокаУслуги);
        КонецЦикла;
    // Слепанов Р.И. 2016.10.11. Начало

    ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.ЗаказТранспорта") Тогда
        
        // Заполнение шапки

        Организация                       = Основание.Организация;
        Контрагент                        = Основание.Контрагент;
        ВалютаДокумента                   = мВалютаРегламентированногоУчета;
        ЗаполнениеДокументов.ПриИзмененииЗначенияКонтрагента(ЭтотОбъект, мСтруктураПараметровДляПолученияДоговора);
        
        ЗаполнениеДокументов.ЗаполнитьШапкуДокумента(ЭтотОбъект, глЗначениеПеременной("глТекущийПользователь"), мВалютаРегламентированногоУчета, "Покупка", Основание, Основание, мСтруктураПараметровДляПолученияДоговора);
        
        НоваяСтрока = ЭтотОбъект.Услуги.Добавить();
        НоваяСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоКоду("00000000929");
        ОбработкаТабличныхЧастей.ЗаполнитьСтавкуНДСТабЧасти(НоваяСтрока, ЭтотОбъект, "Приобретение");
        
        НоваяСтрока.Содержание = "Заказ транспорта № " + СокрЛП(Основание.Номер) + " от " + Формат(Основание.Дата, "ДЛФ=Д");
        НоваяСтрока.Количество = 1;
        НоваяСтрока.Цена = Основание.СуммаДокумента;
        
        ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(НоваяСтрока, ЭтотОбъект);
        ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(НоваяСтрока, ЭтотОбъект);
        
    // Слепанов Р.И. 2016.10.11. Окончание

    КонецЕсли;

КонецПроцедуры// ОбработкаЗаполнения()


В предпоследней процедуре встает.
   Босечка
 
26 - 28.09.17 - 13:44
извиняюсь строке
   Волшебник
 
Модератор
27 - 28.09.17 - 13:50
Чистить кэш
   Босечка
 
28 - 28.09.17 - 13:54
уже почистили. Все тоже самое.
   h-sp
 
29 - 28.09.17 - 13:56
(26) Слепанов Р.И. виноват
   h-sp
 
30 - 28.09.17 - 13:57
(28) запустите  Конфигурация-Проверка конфигурации с галкой "внешнее соединение" и "внешнее соединение Клиент-Сервер"
   Tateossian
 
31 - 28.09.17 - 14:04
РежимДиалогаВопрос = это клиентская процедура, а обмен на сервере происходит.

И однозначно компилируется весь модуль.

Смотрите, есть ли вообще в модуле РежимДиалогаВпрос. По хорошему ее нужно убрать, ну или завернуть в директивы препроцессора #Если Клиент
   aka AMIGO
 
32 - 28.09.17 - 14:11
И я бы посмотрел еще, что найдет глоб.поиск по конфигурации текста "РежимДиалогаВопрос"
   Босечка
 
33 - 28.09.17 - 14:16
Я это уже делала. Но везде стоит если клиент
 
 
   Галахад
 
34 - 28.09.17 - 14:22
А закомментить весь модуль. Временно?
   Босечка
 
35 - 28.09.17 - 14:51
попробую...
   mmmarat
 
36 - 28.09.17 - 14:53
(0) Попробуйте весь модуль документа ЗаказПоставщику убрать в условие:

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
//код модуля


#КонецЕсли
   Босечка
 
37 - 28.09.17 - 15:03
(36) Это тоже не помогло.
   Босечка
 
38 - 28.09.17 - 15:04
комментировала весь модуль все равно не работает
   h-sp
 
39 - 28.09.17 - 15:07
(38) а в другой базе?
   mmmarat
 
40 - 28.09.17 - 15:08
(37) Отладка - подключение - автоматическое подключение... галка на фоновые задания.
далее отладка - остановка по  ошибке - останавливаться по ошибке.
Запускаем обмен, смотрим ошибку и место вызова.
   Босечка
 
41 - 28.09.17 - 15:24
делала так, все равно не работает. Ошибка неизвестно где.
   Босечка
 
42 - 28.09.17 - 15:25
подставила там в одном месте 
#Если клиент

#КонецЕсли
   h-sp
 
43 - 28.09.17 - 15:52
(41) как это неизвестно? известно. При попытке открыть модуль объекта Заказ Поставщику.
   h-sp
 
44 - 28.09.17 - 15:53
(41) вы (30) запускали?
   vicof
 
45 - 28.09.17 - 15:53
Пригласить специалиста уже предлагали?
   Лефмихалыч
 
46 - 28.09.17 - 16:01
(41) не в той конфигурации смотрите.
   Босечка
 
47 - 28.09.17 - 17:29
Проблема решилась так. Обмен настроила в другой базе. Там было хоть понятно по каким ошибкам идти, не было пустых строк. Все исправила и все выгрузилось успешно.
   Босечка
 
48 - 28.09.17 - 17:32
(45) Ты, что ли, главный специалист? Так что же ты ничего не посоветовал? Хамить все могут. А вот дельный совет дают на форумах единицы. Но это не вы.
   Волшебник
 
Модератор
49 - 28.09.17 - 21:17
(48) Не грузите общественность магией.
 
 Рекламное место пустует


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует