Вход | Регистрация


1С:Предприятие ::

Метки: 

Движения по регистрам

Я
   4ekHyTblu NigGa
 
28.09.17 - 06:31
Сразу ребята скажу, я новенький в этом деле, только учусь. Задание в интернете нашел.
Подскажите пожалуйста как сделать, я пытался ну у меня не выходит
или дайте подсказку, где найти информацию.
Движения по регистрам:

ОстаткиТоваров – движение содержит записи (Приход) по каждой строчке табличной части «Товары», все данные для записи берутся из документа. Сумма в записи должна рассчитываться вот по такому алгоритму:

Сумма = Количество * СредневзвешеннаяЦена

СредневзвешеннаяЦена = ОстатокСумма / ОстатокКоличество;

ОстатокСумма = нужно вычислить остаток Суммы в регистре накопления ОстаткиТоваров, на дату документа, с отбором по Номенклатура и Склад:

ОстатокКоличество = нужно вычислить остаток Количество в регистре накопления ОстаткиТоваров, на дату документа, с отбором по Номенклатура и Склад
 
 
   Zombi
 
1 - 28.09.17 - 06:50
Сумма прихода обычно берется непосредственно из документа прихода, а не рассчитывается исходя из остатков на складе. А что будешь делать если товар в первый раз приходит или просто его нет на остатках на дату документа?
   VladZ
 
2 - 28.09.17 - 06:52
Либо кто-то не понял задание, либо "одна из черепашек звездит".
   4ekHyTblu NigGa
 
3 - 28.09.17 - 06:53
Процедура ОбработкаПроведения(Отказ, Режим)
    // регистр ОстаткиТоваров Приход

    Движения.ОстаткиТоваров.Записывать = Истина;
    Движения.ОстаткиТоваров.Очистить();
    Для Каждого ТекСтрокаТовары Из Товары Цикл
        Движение = Движения.ОстаткиТоваров.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Движение.Период = Дата;
        Движение.Номенклатура = ТекСтрокаТовары.Товар;
        Движение.Склад = Склад;
        Движение.Количество = ТекСтрокаТовары.Количество;
        Движение.Сумма = ТекСтрокаТовары.Количество * РегистрыНакопления.ОстаткиТоваров.Остатки(Дата,РегистрыНакопления.ОстаткиТоваров.Номенклатура,,РегистрыНакопления.ОстаткиТоваров.Сумма) / РегистрыНакопления.ОстаткиТоваров.Остатки(Дата,РегистрыНакопления.ОстаткиТоваров.Номенклатура,,РегистрыНакопления.ОстаткиТоваров.Количество);
    КонецЦикла;

    // регистр ВзаиморасчетыСКонтрагентами Приход

    Движения.ВзаиморасчетыСКонтрагентами.Записывать = Истина;
    Движения.ВзаиморасчетыСКонтрагентами.Очистить();
    Для Каждого ТекСтрокаТовары Из Товары Цикл
        Движение = Движения.ВзаиморасчетыСКонтрагентами.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Движение.Период = Дата;
        Движение.Контрагент = Контрагент;
        Движение.Сумма = ТекСтрокаТовары.Сумма;
    КонецЦикла;

КонецПроцедуры
   4ekHyTblu NigGa
 
4 - 28.09.17 - 06:53
в чем ошибка?
   4ekHyTblu NigGa
 
5 - 28.09.17 - 06:56
вот ссылка на задание 1clancer.ru/download/fileId=41594
   МимохожийОднако
 
6 - 28.09.17 - 06:57
(4) Тебе то самому что не нравится? ))
   Zombi
 
7 - 28.09.17 - 06:58
(4) В отборе ошибка В СП вот что про него пишут:

<Отбор> (необязательный)

Тип: Структура.
Структура, содержащая набор значений для измерений регистра. Имя ключа структуры должно совпадать с именем измерения регистра, заданного в конфигураторе, а значение элемента структуры - задает отбираемое по данному измерению значение.
Если параметр не указан, то отбор не используется.
   Zombi
 
8 - 28.09.17 - 07:02
Измерение и ресурс - строка должны быть
   Zombi
 
9 - 28.09.17 - 07:04
И вообще правильно все запросом делать и 1 раз обращаться к БД, а не в цикле, как у тебя. Короче, матчасть тебе учить и учить.
   Oleg_ka
 
10 - 28.09.17 - 07:04
Ошибка...в задании.
Написано:  "Реализация товаров", а далее...движение содержит записи (Приход)<- вот тут должно быть "Расход"
 
 Рекламное место пустует
   4ekHyTblu NigGa
 
11 - 28.09.17 - 07:06
Где по этой теме найти информацию, посоветуйте источники или книги
   Zombi
 
12 - 28.09.17 - 07:08
(11) Радченко купи. Для начинающего самое то.
   4ekHyTblu NigGa
 
13 - 28.09.17 - 07:12
у меня есть, но в ней нет такого,именно алгоритмов в движении
   4ekHyTblu NigGa
 
14 - 28.09.17 - 07:14
движениях*
   Oleg_ka
 
15 - 28.09.17 - 07:15
Гхм. Занятие 11. (Радченко)
   МимохожийОднако
 
16 - 28.09.17 - 07:16
(14) Сделай теми алгоритмами, что в книге.
   Zombi
 
17 - 28.09.17 - 07:17
(13) Тогда есть вероятность, что тебе ничего уж и не поможет.
   4ekHyTblu NigGa
 
18 - 28.09.17 - 07:20
подбодрил) решение, то должно быть) пасиб, что хоть так помогли
   Zombi
 
19 - 28.09.17 - 07:21
(18) Ну Радченко у тебя есть, это уже хорошо. Попробуй прочитать. Может и не настолько все плохо.
   4ekHyTblu NigGa
 
20 - 28.09.17 - 07:23
какого года актуальна книга? у меня 2013 года
   Zombi
 
21 - 28.09.17 - 07:25
(20) Норм. Для изучения основ она пока актуальна.
   Oleg_ka
 
22 - 28.09.17 - 07:26
Радченко "не нравится", тогда рекомендую старые курс П.Чистова
   4ekHyTblu NigGa
 
23 - 28.09.17 - 07:30
Может еще какие-нибудь источники есть?
   МимохожийОднако
 
24 - 28.09.17 - 07:32
Якни справа вверху. Там много чего
   VladZ
 
25 - 28.09.17 - 07:59
(5) "2. Написать процедуры в формах документов." - корявая постановка задачи.
   ildary
 
26 - 28.09.17 - 08:50
(25) Там же заголовок - ТестовОй задание.



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует