Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Я сломал 1с (вечный цикл)

Ø [Волшебник, 28.09.17 - 10:38]
Я сломал 1с (вечный цикл)
Я
   Pikyik
 
28.09.17 - 01:28
С формы регистра сведений вызываю код для автоматического добавления в этот же регистр сведений записей
&НаСервере
Процедура СозданиеНабораЗаписей(ДатаНачала,ДатаКонца,ПН,ВТ,СР,ЧТ,ПТ,СБ,ВС)
    ГрафикиРаботы = РегистрыСведений.ГрафикиРаботы;
    МенеджерРегистраСведений=ГрафикиРаботы.СоздатьНаборЗаписей();
    ТекДата=ДатаНачала;
    Пока ТекДата <= ДатаКонца цикл
        Запись=МенеджерРегистраСведений.Добавить();
        Запись.Дата=ТекДАта;
        Запись.Значение=1;
        Если ПН Тогда
            Если ДеньНедели(ТекДата)=1 Тогда
                Запись.Значение=0;
            КонецЕсли
        КонецЕсли;
        Если ВТ Тогда
            Если ДеньНедели(ТекДата)=2 Тогда
                Запись.Значение=0;
            КонецЕсли
        КонецЕсли;
        Если СР Тогда
            Если ДеньНедели(ТекДАта)=3 Тогда
                Запись.Значение=0;
            КонецЕсли
        КонецЕсли;
        Если ЧТ Тогда
            Если ДеньНедели(ТекДата)=4 Тогда
                Запись.Значение=0;
            КонецЕсли  
        КонецЕсли;
            
        Если ПТ Тогда
            Если ДеньНедели(ТекДата)=5 Тогда
                Запись.Значение=0;
            КонецЕсли
        КонецЕсли;

        Если СБ Тогда
            Если ДеньНедели(ТекДата)=6 Тогда
                Запись.Значение=0;
            КонецЕсли
        КонецЕсли;
        Если ВС Тогда
            Если ДеньНедели(ТекДата)=7 Тогда
                Запись.Значение=0;
            КонецЕсли
        КонецЕсли;
    ДатаНачала=ДатаНачала+86400;
    КонецЦикла;
    МенеджерРегистраСведений.Записать(Ложь);
КонецПроцедуры;
При его исполнении 1с тупит и вылетает. Вроде цикл не бесконечен. Подскажите пожалуйста что это может быть.

p.s. Я молодой и зелёный если можно объясняйте по слогам.
 
 
   H A D G E H O G s
 
1 - 28.09.17 - 01:44
ТекДата не меняется в цикле.
   H A D G E H O G s
 
2 - 28.09.17 - 01:46
С какие пор студентота изучает 1С?
   Pikyik
 
3 - 28.09.17 - 01:48
Точно. Спасибо)
   Pikyik
 
4 - 28.09.17 - 01:48
Да давно уже изучаем)
   H A D G E H O G s
 
5 - 28.09.17 - 01:50
Наступают тяжелые времена...
   H A D G E H O G s
 
6 - 28.09.17 - 01:51
Будущее уже здесь и стучиться кованным сапогом адокода поколения постпокемонов нам в конфигурации. Надо валить.
   Pikyik
 
7 - 28.09.17 - 01:58
Да нее. Мы скорее всего будем на заправках работать с таким образованием)
   Pikyik
 
8 - 28.09.17 - 01:58
Ну большинство)
   Pikyik
 
9 - 28.09.17 - 01:59
Это ж я ещё в группе типа очень умным считаюсь....
   H A D G E H O G s
 
10 - 28.09.17 - 02:13
Специальность? ВУЗ какой?
 
 Рекламное место пустует
   Pikyik
 
11 - 28.09.17 - 02:18
ИС(по отраслям), технарь)
   Pikyik
 
12 - 28.09.17 - 02:20
А кстати переименование переменной ТекДата ничего не изменило 
Процедура СозданиеНабораЗаписей(ДатаНачала,ДатаКонца,ПН,ВТ,СР,ЧТ,ПТ,СБ,ВС)
    ГрафикиРаботы = РегистрыСведений.ГрафикиРаботы;
    МенеджерРегистраСведений=ГрафикиРаботы.СоздатьНаборЗаписей();
    ТекДата=ДатаНачала;
    Пока ТекДата <= ДатаКонца цикл
        Запись=МенеджерРегистраСведений.Добавить();
        Запись.Дата=ТекДАта;
        Запись.Значение=1;
        Если ПН и ДеньНедели(ТекДата)=1 Тогда
                Запись.Значение=0;
        КонецЕсли;
        Если ВТ и ДеньНедели(ТекДата)=2 Тогда
                Запись.Значение=0;
        КонецЕсли;
        Если СР и ДеньНедели(ТекДАта)=3 Тогда
                Запись.Значение=0;
        КонецЕсли;
        Если ЧТ и ДеньНедели(ТекДата)=4 Тогда
                Запись.Значение=0; 
        КонецЕсли;
            
        Если ПТ и ДеньНедели(ТекДата)=5 Тогда
                Запись.Значение=0;
        КонецЕсли;

        Если СБ и ДеньНедели(ТекДата)=6 Тогда
                Запись.Значение=0;
        КонецЕсли;
        Если ВС и ДеньНедели(ТекДата)=7 Тогда
                Запись.Значение=0;
        КонецЕсли;
    ТекДата=ДатаНачала+86400;
    КонецЦикла;
    МенеджерРегистраСведений.Записать(Ложь);
КонецПроцедуры;
   Pikyik
 
13 - 28.09.17 - 02:20
Всё сам понял))
   Pikyik
 
14 - 28.09.17 - 02:22
А ещё вопрос такой. Можно ли как-то после всего этого обновить форму?
   H A D G E H O G s
 
15 - 28.09.17 - 02:32
Ну пусть будет так
ЭтаФорма.Список.Обновить();
   Pikyik
 
16 - 28.09.17 - 02:55
Пишет
    {РегистрСведений.ГрафикиРаботы.Форма.ФормаСписка.Форма(42)}: Метод объекта не обнаружен (Обновить)
   H A D G E H O G s
 
17 - 28.09.17 - 03:14
(16) Скинь базу на файлообменник
   VladZ
 
18 - 28.09.17 - 04:55
(0) Не нравится мне вот это "ПН,ВТ,СР,ЧТ,ПТ,СБ,ВС": слишком много параметров. Я бы объединил в одну  сущность.
   craxx
 
19 - 28.09.17 - 05:07
(18) Это что-то учебное. Почему бы нет. Вырастит - дозреет.
   GedKo
 
20 - 28.09.17 - 06:56
(18) я помню кто-то постил пример конфу со справочником аля "Месяц" и реквизитами "Число1"..."Число31"
   EvgeniuXP
 
21 - 28.09.17 - 07:02
МенеджерРегистраСведений - это не менеджер.
   Dmitry1c
 
22 - 28.09.17 - 07:10
У меня на 5 курсе был предмет, где изучали 1С. Я показал преподу профа по платформе и получил зачет автоматом, на этот предмет не ходил.
   0xFFFFFF
 
23 - 28.09.17 - 07:17
(0) Это ты еще не дошел до функции создания набора записей по дням года. Там вообще ахтунг. Представь
Процедура СозданиеНабораЗаписейПоДнямГода(ДатаНачала,ДатаКонца,Д1,Д2,Д3,Д4,Д5,Д6,Д7,Д8,Д9,Д10,Д11,Д12,Д13,Д14,Д15,Д16,Д17,Д18,Д19,Д20,Д21,Д22,Д23,Д24,Д25,Д26,Д27,Д28,Д29,Д30,Д31,Д32,Д33,Д34,Д35,Д36,Д37,Д38,Д39,Д40,Д41,Д42,Д43,Д44,Д45,Д46,Д47,Д48,Д49,Д50,Д51,Д52,Д53,Д54,Д55,Д56,Д57,Д58,Д59,Д60,Д61,Д62,Д63,Д64,Д65,Д66,Д67,Д68,Д69,Д70,Д71,Д72,Д73,Д74,Д75,Д76,Д77,Д78,Д79,Д80,Д81,Д82,Д83,Д84,Д85,Д86,Д87,Д88,Д89,Д90,Д91,Д92,Д93,Д94,Д95,Д96,Д97,Д98,Д99,Д100,Д101,Д102,Д103,Д104,Д105,Д106,Д107,Д108,Д109,Д110,Д111,Д112,Д113,Д114,Д115,Д116,Д117,Д118,Д119,Д120,Д121,Д122,Д123,Д124,Д125,Д126,Д127,Д128,Д129,Д130,Д131,Д132,Д133,Д134,Д135,Д136,Д137,Д138,Д139,Д140,Д141,Д142,Д143,Д144,Д145,Д146,Д147,Д148,Д149,Д150,Д151,Д152,Д153,Д154,Д155,Д156,Д157,Д158,Д159,Д160,Д161,Д162,Д163,Д164,Д165,Д166,Д167,Д168,Д169,Д170,Д171,Д172,Д173,Д174,Д175,Д176,Д177,Д178,Д179,Д180,Д181,Д182,Д183,Д184,Д185,Д186,Д187,Д188,Д189,Д190,Д191,Д192,Д193,Д194,Д195,Д196,Д197,Д198,Д199,Д200,Д201,Д202,Д203,Д204,Д205,Д206,Д207,Д208,Д209,Д210,Д211,Д212,Д213,Д214,Д215,Д216,Д217,Д218,Д219,Д220,Д221,Д222,Д223,Д224,Д225,Д226,Д227,Д228,Д229,Д230,Д231,Д232,Д233,Д234,Д235,Д236,Д237,Д238,Д239,Д240,Д241,Д242,Д243,Д244,Д245,Д246,Д247,Д248,Д249,Д250,Д251,Д252,Д253,Д254,Д255,Д256,Д257,Д258,Д259,Д260,Д261,Д262,Д263,Д264,Д265,Д266,Д267,Д268,Д269,Д270,Д271,Д272,Д273,Д274,Д275,Д276,Д277,Д278,Д279,Д280,Д281,Д282,Д283,Д284,Д285,Д286,Д287,Д288,Д289,Д290,Д291,Д292,Д293,Д294,Д295,Д296,Д297,Д298,Д299,Д300,Д301,Д302,Д303,Д304,Д305,Д306,Д307,Д308,Д309,Д310,Д311,Д312,Д313,Д314,Д315,Д316,Д317,Д318,Д319,Д320,Д321,Д322,Д323,Д324,Д325,Д326,Д327,Д328,Д329,Д330,Д331,Д332,Д333,Д334,Д335,Д336,Д337,Д338,Д339,Д340,Д341,Д342,Д343,Д344,Д345,Д346,Д347,Д348,Д349,Д350,Д351,Д352,Д353,Д354,Д355,Д356,Д357,Д358,Д359,Д360,Д361,Д362,Д363,Д364,Д365)
   0xFFFFFF
 
24 - 28.09.17 - 07:19
(0) текст приводить не буду, т.к. он не влезет в интернеты.
   HeKrendel
 
25 - 28.09.17 - 07:19
(23) А проверка на високосный год?
   0xFFFFFF
 
26 - 28.09.17 - 07:26
(25) так это  только в 2020м году. Там уже другие одинэсники пусть исправляют.
   Адинэснег
 
27 - 28.09.17 - 08:03
подрастают внедрюки...
   Dotoshin
 
28 - 28.09.17 - 08:11
(0) А теперь расскажи простыми русскими словами, что должен делать твой код?
   dmpl
 
29 - 28.09.17 - 08:23
(21) А это чтобы враг не догадался.
   rphosts
 
30 - 28.09.17 - 08:41
(16) у тебя форма вообще есть?
(14) может лучше ОповеститьОбИзменении?
   rudnitskij
 
31 - 28.09.17 - 09:33
(0) а что вообще должен делать ваш код? зачем параметры ПН - ВС?
   rphosts
 
32 - 28.09.17 - 09:57
(31) видимо по дням недели
   rudnitskij
 
33 - 28.09.17 - 10:05
(32) так а что он должен делать по дням недели? Часы заводить? Собаку кормить? Носки стирать? У меня подозрение, что этот код можно сократить минимум впятеро
 
 
   Бубр
 
34 - 28.09.17 - 10:24
Прочитал  название  и вспомнился ролик с ютуба "Мама  меня фура убила на линии вызывай гибдд" :)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует