Вход | Регистрация

1С:Предприятие ::

Метки: 

ОткрытьФОрмуМодально + SQL Server

Я
   Chuvaschow
 
27.09.17 - 20:08
Здравствуйте, Уважаемые форумчане!
Подскажите, пожалуйста. УТ 10.3 доработанная. РИБ, обмен через файловый ресурс. На днях центральную базу перевели из файловой в SQL вариант. Тут же обмен стал ругаться на вот эту процедуру в документе реализации.
В клиент-серверном варианте не так нужно открывать модально? Получается центальная база - клиент-серверная, РИБ - файловая.

//Проверка заполнения поля Продавец

Процедура ПроверкаЗаполненияПродавец(Продавец)
    Если Продавец.Пустая()Тогда
        Продавец = ОткрытьФормуМодально("Справочник.ФизическиеЛица.ФормаВыбора",,Продавец);
    КонецЕсли;
    
КонецПроцедуры//Проверка заполнения поля Продавец
 
  Рекламное место пустует
   Филиал-msk
 
1 - 27.09.17 - 20:14
(0) Дорабатавайте дальше.
На сервере формы никто не увидит.
   Chuvaschow
 
2 - 27.09.17 - 20:17
Понял.

Не подскажите как переписать под клиент-сервер и файловую версию одновременно?
   Филиал-msk
 
3 - 27.09.17 - 20:27
(2) Ээээ... Не использовать диалоги с клиентами на сервере?
   craxx
 
4 - 27.09.17 - 20:29
(2) Эта процедура откуда вызывается? Если из формы, оберни ее в конструкции #Если Клиент Тогда    #КонецЕсли
   Chuvaschow
 
5 - 27.09.17 - 20:31
(3) Это-то да, но... :)
(4) Вызывается из модуля объекта документа РеализацияТоваровИУслуг. При проведении документа выполняется проверка.
   craxx
 
6 - 27.09.17 - 20:33
(5) открывать модальные формы при проведении - за это нужно отрывать руки по самые ноги!
   МимохожийОднако
 
7 - 27.09.17 - 20:33
(5) Перенеси процедуру в модуль формы
   craxx
 
8 - 27.09.17 - 20:36
(7) он же при проведении пытается это делать
   Chuvaschow
 
9 - 27.09.17 - 20:38
(6) Наверное да :)) Но удобно жешь. Жмешь ОК, а документ тебе открывает форму выбора продавца.
   МимохожийОднако
 
10 - 27.09.17 - 20:39
(8) Из формы он уже этого не сможет
 
  Рекламное место пустует
   craxx
 
11 - 27.09.17 - 20:41
(9) А теперь запусти Групповое проведение - и наслаждайся эффектом. И это только малая часть.
   craxx
 
12 - 27.09.17 - 20:42
(11) Или "Восстановление последовательности". Вот где таких гениев находят? Удобно ему, млин.
   Chuvaschow
 
13 - 27.09.17 - 20:43
Запускал. Эффекта ноль, ибо поле уже заполнено. Процедура работает лишь на Пустая()
   Chuvaschow
 
14 - 27.09.17 - 20:43
(12) Ту не далеко :)
   craxx
 
15 - 27.09.17 - 20:47
(14) ты это можешь делать ПередЗаписью в форме. Вот там и делай. Но никак не в ОбработкеПроведения.
   Chuvaschow
 
16 - 27.09.17 - 20:48
(15) Понял, спасибо! Сейчас опробуем
   Chuvaschow
 
17 - 27.09.17 - 20:50
Работает. Спасибо! Опыт, сын ошибок трудных...
   Филиал-msk
 
18 - 27.09.17 - 20:50
Мне сегодня выражение Лефмихалыч весьма понравилось по похожему поводу - "Чтоб у вас там писюны на пальцах выросли" (:

Предлагаю вставить в ротацию афоризмов под нижним рекламным баннером.
   Филиал-msk
 
19 - 27.09.17 - 20:51
Про транзакции там, блокировки... не, нинада


Список тем форума
 
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует