Вход | Регистрация

1С:Предприятие ::

Метки: 

как удалить созданные элементы

Ø [Волшебник, 26.09.17 - 11:33]
Я
   malex18
 
26.09.17 - 10:44
Создал обработку, которая создает в справочнике элементы.
после выполнения обработки не получается удалить созданные элементы.
только пометить на удаление.через "все функции - удалить помеченные на удаление" тоже не получается.подскажите ка удалить созданные элементы
 
 
   Cyberhawk
 
1 - 26.09.17 - 10:45
"через "все функции - удалить помеченные на удаление" тоже не получается" // Подробнее
   Numerus Mikhail
 
2 - 26.09.17 - 10:46
Обычно там пишется почему нельзя удалить
возможно создается еще куча разных подчиненных справочников/записей в регистрах.
   malex18
 
3 - 26.09.17 - 10:49
ну помечаю на удаление созданные обработкой элементы.их всего 2
через все функции-удалить помеченные он их просто не видит.
   Волшебник
 
Модератор
4 - 26.09.17 - 10:50
Объект = ...ПолучитьОбъект()
Объект.Удалить()
   malex18
 
5 - 26.09.17 - 10:56
разобрался.забыл совсем про роли.
не ставил отметку о разрешении удаления.
что сказать,учиться, учиться и еще учиться
спасибо
   malex18
 
6 - 26.09.17 - 11:03
подскажите только как сделать.чтобы обработка создавала не один элемент а несколько
ну есть два реквизита в обработке :"наименование" и "количество элементов"
по кнопке "создать" обработка должна создавать соответствующее число элементов справочника.
например : "новый товар" и "3"
должно получиться "новый товар1", "новый товар2", "новый товар3"
???
   НЕА123
 
7 - 26.09.17 - 11:05
"новый товар"+1, "новый товар"+2, "новый товар"+3
   Numerus Mikhail
 
8 - 26.09.17 - 11:06
(6)
Так:

Сч = 0;
Пока Сч < Количество Цикл
   Сч = Сч + 1;
   НовыйЭлемент = Справочники.ТвойСправочник.СоздатьЭлемент();
   НовыйЭлемент.Наименование = Наименование + Сч;
КонецЦикла;
   Волшебник
 
Модератор
9 - 26.09.17 - 11:06
(8) Записать() забыл
   malex18
 
10 - 26.09.17 - 11:06
и что это значит?))
он должен создавать столько объектов,сколько указано в реквизите обработки)
счетчик нужен?или что?
 
 Рекламное место пустует
   malex18
 
11 - 26.09.17 - 11:07
точно!
спасибо!!
   Numerus Mikhail
 
12 - 26.09.17 - 11:07
(9) да, забыл :(
   malex18
 
13 - 26.09.17 - 11:27
Подскажите и в этой задачке)

Сделал обработку.в ней реквизит булево

если истина, то задавать вопрос при завершении работы системы

пишет , что значение не является значением объектного типа,

вот код процедуры при завершении работы системы

Процедура ПриЗавершенииРаботыСистемы(Константы)

    
    Если Константы.ЗадаватьВопросПриЗакрытииПрограммы  Тогда
        
            Ответ = Вопрос("Вы хотите закончить работу", РежимДиалогаВопрос.ДаНет);
            
            Если Ответ = КодВозвратаДиалога.Нет Тогда
                                
                Отказ = Истина;
                
            КонецЕсли; 
            
    КонецЕсли;

КонецПроцедуры
   malex18
 
14 - 26.09.17 - 11:28
точнее процедура "перед заверешением")
   h-sp
 
15 - 26.09.17 - 11:32
(14) Константы.ЗадаватьВопросПриЗакрытииПрограммы  нет такого слова. Прочитайте как правильно к константе обратиться.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует