Вход | Регистрация


КонсольЗаданий ошибка в типовой обработке

КонсольЗаданий ошибка в типовой обработке
Я
   ac13
 
25.09.17 - 16:39
{ВнешняяОбработка.КонсольЗаданий.Форма.ДиалогРегламентногоЗадания.Форма(11)}:
Поле объекта недоступно для записи (Пользователи)
Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();

Просто вдруг при открытии обработка выдала такую ошибку. С чего вдруг ...



Процедура ПриОткрытии()
    
    Для Каждого Метаданное из Метаданные.РегламентныеЗадания Цикл
        ЭлементыФормы.МетаданныеВыбор.СписокВыбора.Добавить(Метаданное, Метаданное.Представление());
    КонецЦикла;
    
    Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
    Для Каждого Пользователь из Пользователи Цикл
        ЭлементыФормы.ПользователиВыбор.СписокВыбора.Добавить(Пользователь.Имя, Пользователь.ПолноеИмя);
    КонецЦикла;
    ЭлементыФормы.ПользователиВыбор.СписокВыбора.СортироватьПоПредставлению();
    
    Если РегламентноеЗадание <> Неопределено Тогда
        МетаданныеВыбор = РегламентноеЗадание.Метаданные;
        ЭлементыФормы.МетаданныеВыбор.Доступность = Ложь;
        Наименование = РегламентноеЗадание.Наименование;
        Ключ = РегламентноеЗадание.Ключ;
        Использование = РегламентноеЗадание.Использование;
        ПользователиВыбор = РегламентноеЗадание.ИмяПользователя;
        КоличествоПовторовПриАварийномЗавершении = РегламентноеЗадание.КоличествоПовторовПриАварийномЗавершении;
        ИнтервалПовтораПриАварийномЗавершении = РегламентноеЗадание.ИнтервалПовтораПриАварийномЗавершении;
        Расписание = РегламентноеЗадание.Расписание;
        Параметры.ЗагрузитьЗначения(РегламентноеЗадание.Параметры);
    Иначе
        Расписание = Новый РасписаниеРегламентногоЗадания;
    КонецЕсли;
    
КонецПроцедуры
 
 
   Numerus Mikhail
 
1 - 25.09.17 - 16:41
Поставь точку остановки и посмотри перед этой ошибкой какой тип у "Пользователи"? Мне кажется у тебя есть общий модуль с таким названием или еще что-то.
   Базис
 
2 - 25.09.17 - 16:43
В УПП переименовывал реквизит во внешней обработке с Пользователи на Пользователи1, взлетело.
   ac13
 
3 - 25.09.17 - 16:45
(2) тоже такая ошибка была?
   Parenek_88
 
4 - 25.09.17 - 16:50
(3) да, такая

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует