Вход | Регистрация


Ошибка в ПКО при ПослеЗагрузкиОбъекта

Ошибка в ПКО при ПослеЗагрузкиОбъекта
Я
   Дмитрий1603
 
25.09.17 - 12:49
Переношу физические лица в КА из внешнего источника данных. При записи Физ лица, должен делать записи в РС - ДокументыФизическихлиц.
Для первого физЛица проходит все штатно, на втором выходит ошибка : Значение не является значением объектного типа ( получить ).
Вот код события ПослеЗагрузкиОбъекта:

Если Не ЗначениеЗаполнено(Объект.Ссылка) Тогда
    Объект.Записать();                     
КонецЕсли;

Если  НЕ ПустаяСтрока(ПараметрыОбъекта.Получить("Серия")) Тогда
    Набор = РегистрыСведений.ДокументыФизическихЛиц.СоздатьНаборЗаписей();
    Набор.Прочитать();
    НовЗапись = Набор.Добавить();
    //НоваяЗапись = РегистрыСведений.ДокументыФизическихЛиц.СоздатьМенеджерЗаписи();

    НовЗапись.Физлицо = Объект.Ссылка; 
    НовЗапись.ВидДокумента = Справочники.ВидыДокументовФизическихЛиц.ПаспортРФ; 
    НовЗапись.Серия = ПараметрыОбъекта.Получить("Серия"); 
    НовЗапись.Номер = ПараметрыОбъекта.Получить("Номер паспорта");
    НовЗапись.ДатаВыдачи = ПараметрыОбъекта.Получить("Дата выдачи паспорта");
    НовЗапись.КемВыдан = ПараметрыОбъекта.Получить("Кем выдан паспорт");
    НовЗапись.ЯвляетсяДокументомУдостоверяющимЛичность = Истина;
    НовЗапись.Период = ТекущаяДата();
    //НоваяЗапись.Записать();

    Набор.Записать();
КонецЕсли;

Если  НЕ ПустаяСтрока(ПараметрыОбъекта.Получить("Водительское_удостоверение")) Тогда
    Набор = РегистрыСведений.ДокументыФизическихЛиц.СоздатьНаборЗаписей();
    Набор.Прочитать();
    НовЗапись = Набор.Добавить();
    //НоваяЗапись = РегистрыСведений.ДокументыФизическихЛиц.СоздатьМенеджерЗаписи();

    НовЗапись.Физлицо = Объект.Ссылка; 
    НовЗапись.ВидДокумента = Справочники.ВидыДокументовФизическихЛиц.ВодительскоеУдостоверение; 
    НовЗапись.Номер = ПараметрыОбъекта.Получить("Водительское удостоверение");
    НовЗапись.ЯвляетсяДокументомУдостоверяющимЛичность = Ложь;
    НовЗапись.Период = ТекущаяДата();
    Набор.Записать();
КонецЕсли;    

Ругается на строку : Если  НЕ ПустаяСтрока(ПараметрыОбъекта.Получить("Серия")) Тогда


Не пойму в чем причина. если на первом объекте отрабатывает, то на следующих ругается.
 
 
   Ёпрст
 
1 - 25.09.17 - 12:51
Ну смотри в жуколове, чему равны ПараметрОбъекта
   Ёпрст
 
2 - 25.09.17 - 12:51
+ нам отсюда не видно, в каком месте  и как ты их устанавливаешь
   Дмитрий1603
 
3 - 25.09.17 - 12:53
Что за жуколов?
   Ёпрст
 
4 - 25.09.17 - 12:55
(3)
Отла?дчик (деба?ггер, англ. debugger от bug) — компьютерная программа, предназначенная для поиска ошибок в других программах, ядрах операционных систем
   Дмитрий1603
 
5 - 25.09.17 - 12:57
С удовольствием,  был бы он еще при работе с Универсальным обменом данных в формате XML
   Ёпрст
 
6 - 25.09.17 - 12:59
(5) а че , нету ?
   Ёпрст
 
7 - 25.09.17 - 12:59
галку воткни - режим отладки обработчиков
   aleks_default
 
8 - 25.09.17 - 13:00
Трындец. Читаешь целиком весь регистр (так как не установил отбор) и еще на что-то жалуешься? Срочно на курсы: 1С для чайников
   Дмитрий1603
 
9 - 25.09.17 - 13:57
(8) Эта строка никак не влияет на эту ошибку.
   Дмитрий1603
 
10 - 25.09.17 - 14:05
Код корректный, отработал
 
 Рекламное место пустует
   aleks_default
 
11 - 25.09.17 - 14:06
(9)Да что ты говоришь? А почитай в СП описание команды Записать(). И повторюсь ты читаешь ВЕСЬ набор, т. е. все существующие записи.
   aleks_default
 
12 - 25.09.17 - 14:07
*ВЕСЬ набор = ВЕСЬ регистр
   Дмитрий1603
 
13 - 25.09.17 - 14:11
(11) читать пустой изначально регистр, не думаю, что к чему-то страшному приведет.
   h-sp
 
14 - 25.09.17 - 14:40
(13) он пустой только для первой записи. Для второй записи он не пустой.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует