Вход | Регистрация

1С:Предприятие ::

Метки: 

при выполнении процедуры закрывается 1-ска

Я
   serg-lom89
 
22.09.17 - 17:12
при выполнении процедуры закрывается 1-ска.


    
    ЭлементыФормы.ПользователиИБ_ТЧ.Значение.Очистить();
    ПользователиИБ =ПолучитьПользователейИБ(); 
     ТЗ =КонвертироватьМассивПользователейВТЗ(ПользователиИБ);
    
    ЭлементыФормы.ПользователиИБ_ТЧ.Значение = ТЗ;
    ЭлементыФормы.ПользователиИБ_ТЧ.СоздатьКолонки();
    
    
    КоллекцияКолонокФормы =  ЭлементыФормы.ПользователиИБ_ТЧ.Колонки;
    Для Каждого Колонки Из  КоллекцияКолонокФормы  Цикл
        Колонки.ТолькоПросмотр = истина;
        Если типЗнч(Колонки.ЭлементУправления.Значение) = тип("Булево") Тогда
            Колонки.ДанныеФлажка = Колонки.Имя;    
            Колонки.Данные = "";
            Колонки.ТолькоПросмотр = ложь;
        КонецЕсли;
    КонецЦикла;
    
    
    КоллекцияКолонокФормы["УникальныйИдентификатор"].видимость = ложь;
    
    КоллекцияКолонокФормы["Пометка"].ТолькоПросмотр = ложь;
    КоллекцияКолонокФормы["Пометка"].ДанныеФлажка= "Пометка";
    КоллекцияКолонокФормы["Пометка"].Данные = "";
    


вот сама процедура

Хотя она отрабатывает перед открытием все норм.
я конечно перед этим создаю пользователя ИБ.И потом с помощью этой процедуры обновляю ТЧ обработки.
ЧЯДНТ?
 
  Рекламное место пустует
   serg-lom89
 
1 - 22.09.17 - 17:13
не совсем корректного написал..
На форме кнопка,по которой я создаю пользователя.
и потом с помощью этой процедуры(выше) обновляю данные формы
вот так
   serg-lom89
 
2 - 22.09.17 - 17:14
и происходит вылет 1с-ки
   Numerus Mikhail
 
3 - 22.09.17 - 17:59
В какой конкретно момент вылетает?
   lodger
 
4 - 22.09.17 - 18:31
(0) ЧЯДНТ? - меняешь элементы формы и их параметры на сервере, в то время как она одновременно существует еще и на клиенте.
если надо что-то спрятать-показать по изменению данных, то это решается страницами (без заголовка с табами), которые переключаются по изменению данных.
   serg-lom89
 
5 - 25.09.17 - 09:11
(3)
1) записали пользователя ,выходим из процедуры
2) выходим из (0) и тогда вылетает
   serg-lom89
 
6 - 25.09.17 - 09:12
(4)
так а как что бы просто обновить данные и вывести в ТЧ уже созданного пользователя?
   МимохожийОднако
 
7 - 25.09.17 - 09:22
Играешься с элементами формы вместо того, чтобы заново прочитать список с новым пользователем. А вот кода по созданию пользователя я не увидел.
   serg-lom89
 
8 - 25.09.17 - 09:26
(7)
(7)
    
    
    НовПользователь = ПользователиИнформационнойБазы.СоздатьПользователя();  
    Для каждого Строка из  СтруктураДанных Цикл
        НовПользователь[Строка.Ключ] = ПользовательКопируемый[Строка.Ключ];
    КонецЦикла;
    
    Для каждого Строка из  СтруктураДанныхЗначений Цикл
        НовПользователь[Строка.Ключ] = Строка.Значение;
    КонецЦикла;
    
    РолиНовогоПользователя = НовПользователь.Роли;
    РолиКопируемого = ПолучитьРолиПользователя(ПользовательКопируемый);
    Если  РолиКопируемого<>неопределено Тогда
        Для каждого Строка из РолиКопируемого Цикл
            РолиНовогоПользователя.Добавить(Строка.Значение);    
        КонецЦикла;
    КонецЕсли;
    отказ = ложь;
    Попытка
        НовПользователь.записать();
        Сообщить("записан пользователь "+ СокрЛП(НовПользователь));
    Исключение
        Сообщить(ОписаниеОшибки());
        отказ = истина;
    КонецПопытки;
   МимохожийОднако
 
9 - 25.09.17 - 09:29
Не проще ли разместить на форму вместо ТЗ форму списка справочника Пользователи и убрать процедуру по получению ТЗ и т.п. из (0)?
   serg-lom89
 
10 - 25.09.17 - 09:37
(9) можно и так
но хотелось бы решить как в (0),какие просто способы есть решения
 
  Рекламное место пустует
   МимохожийОднако
 
11 - 25.09.17 - 09:37
(10) ИМХО, это через задницу
   serg-lom89
 
12 - 25.09.17 - 09:38
(11) ахахахах)))
   serg-lom89
 
13 - 25.09.17 - 09:41
(9) как связать тогда пользователей ИБ и справочника пользователи?гуиды у них вроде разные будут
   h-sp
 
14 - 25.09.17 - 09:55
(13) один из этих 2х гуидов - это просто обычное поле. Просто тупо выясняешь какрой именно и легко его меняешь.
   serg-lom89
 
15 - 25.09.17 - 10:06
(14) хотелось бы как нить универсально что бы было...ничего не хотелось бы менять.
   serg-lom89
 
16 - 25.09.17 - 10:28
(15) вплане с гуидами


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует